Update to version 13
This commit is contained in:
parent
59185aa6d2
commit
fecd184ce6
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@
|
||||
/kmod-10.tar.xz
|
||||
/kmod-11.tar.xz
|
||||
/kmod-12.tar.xz
|
||||
/kmod-13.tar.xz
|
||||
|
@ -1,20 +0,0 @@
|
||||
diff --git a/tools/rmmod.c b/tools/rmmod.c
|
||||
index 7f2c2f6..7f4431c 100644
|
||||
--- a/tools/rmmod.c
|
||||
+++ b/tools/rmmod.c
|
||||
@@ -62,8 +62,14 @@ static void help(void)
|
||||
|
||||
static int check_module_inuse(struct kmod_module *mod) {
|
||||
struct kmod_list *holders;
|
||||
+ int state;
|
||||
|
||||
- if (kmod_module_get_initstate(mod) == -ENOENT) {
|
||||
+ state = kmod_module_get_initstate(mod);
|
||||
+
|
||||
+ if (state == KMOD_MODULE_BUILTIN) {
|
||||
+ ERR("Module %s is builtin.\n", kmod_module_get_name(mod));
|
||||
+ return -ENOENT;
|
||||
+ } else if (state < 0) {
|
||||
ERR("Module %s is not currently loaded\n",
|
||||
kmod_module_get_name(mod));
|
||||
return -ENOENT;
|
10
kmod.spec
10
kmod.spec
@ -1,6 +1,6 @@
|
||||
Name: kmod
|
||||
Version: 12
|
||||
Release: 4%{?dist}
|
||||
Version: 13
|
||||
Release: 1%{?dist}
|
||||
Summary: Linux kernel module management utilities
|
||||
|
||||
Group: System Environment/Kernel
|
||||
@ -16,8 +16,6 @@ BuildRequires: zlib-devel
|
||||
BuildRequires: xz-devel
|
||||
BuildRequires: libxslt
|
||||
|
||||
Patch0: fix-rmmod-builtin.patch
|
||||
|
||||
Provides: module-init-tools = 4.0-1
|
||||
Obsoletes: module-init-tools < 4.0-1
|
||||
Provides: /sbin/modprobe
|
||||
@ -48,7 +46,6 @@ applications that wish to load or unload Linux kernel modules.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
export V=1
|
||||
@ -109,6 +106,9 @@ install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/weak-modules
|
||||
%{_libdir}/libkmod.so
|
||||
|
||||
%changelog
|
||||
* Wed Apr 10 2013 Josh Boyer <jwboyer@redhat.com> - 13-1
|
||||
- Update to version 13
|
||||
|
||||
* Thu Mar 20 2013 Weiping Pan <wpan@redhat.com> - 12-3
|
||||
- Pull in weak-modules for kABI from Jon Masters <jcm@redhat.com>
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user