Update to version 19
This commit is contained in:
parent
0945e4f85d
commit
3aa5ad862c
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
|||||||
/kmod-16.tar.xz
|
/kmod-16.tar.xz
|
||||||
/kmod-17.tar.xz
|
/kmod-17.tar.xz
|
||||||
/kmod-18.tar.xz
|
/kmod-18.tar.xz
|
||||||
|
/kmod-19.tar.xz
|
||||||
|
@ -1,36 +0,0 @@
|
|||||||
From 27eceb2e4ecbf2e31940b67cee682a6935f61e6c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Tom Gundersen <teg@jklm.no>
|
|
||||||
Date: Mon, 27 Oct 2014 17:55:03 +0100
|
|
||||||
Subject: [PATCH] static-nodes: indicate that creation of static nodes should
|
|
||||||
only happen at boot
|
|
||||||
|
|
||||||
udev will only manage static nodes that exist at the time udev is started, so
|
|
||||||
creating static nodes later on will likely not behave as expected. In
|
|
||||||
particular, recreating the static nodes at run-time will reset any permissions
|
|
||||||
udev may have applied to the nodes at boot.
|
|
||||||
|
|
||||||
See <https://bugzilla.redhat.com/show_bug.cgi?id=1147248> and the discussion
|
|
||||||
following <http://permalink.gmane.org/gmane.comp.sysutils.systemd.devel/23795>.
|
|
||||||
|
|
||||||
Note that this requires (the yet to be released) systemd v217 or a backport
|
|
||||||
of systemd patch 8c94052ee543c3598a3c7b0c46688150aa2c6168.
|
|
||||||
---
|
|
||||||
tools/static-nodes.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/tools/static-nodes.c b/tools/static-nodes.c
|
|
||||||
index d1e3b6e..8d2356d 100644
|
|
||||||
--- a/tools/static-nodes.c
|
|
||||||
+++ b/tools/static-nodes.c
|
|
||||||
@@ -96,7 +96,7 @@ static int write_tmpfiles(FILE *out, char modname[], char devname[], char type,
|
|
||||||
return EXIT_FAILURE;
|
|
||||||
}
|
|
||||||
|
|
||||||
- ret = fprintf(out, "%c /dev/%s 0600 - - - %u:%u\n",
|
|
||||||
+ ret = fprintf(out, "%c! /dev/%s 0600 - - - %u:%u\n",
|
|
||||||
type, devname, maj, min);
|
|
||||||
if (ret < 0)
|
|
||||||
return EXIT_FAILURE;
|
|
||||||
--
|
|
||||||
1.9.3
|
|
||||||
|
|
10
kmod.spec
10
kmod.spec
@ -1,6 +1,6 @@
|
|||||||
Name: kmod
|
Name: kmod
|
||||||
Version: 18
|
Version: 19
|
||||||
Release: 4%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Linux kernel module management utilities
|
Summary: Linux kernel module management utilities
|
||||||
|
|
||||||
Group: System Environment/Kernel
|
Group: System Environment/Kernel
|
||||||
@ -22,8 +22,6 @@ Provides: module-init-tools = 4.0-1
|
|||||||
Obsoletes: module-init-tools < 4.0-1
|
Obsoletes: module-init-tools < 4.0-1
|
||||||
Provides: /sbin/modprobe
|
Provides: /sbin/modprobe
|
||||||
|
|
||||||
Patch1: 0001-static-nodes-indicate-that-creation-of-static-nodes-.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
The kmod package provides various programs needed for automatic
|
The kmod package provides various programs needed for automatic
|
||||||
loading and unloading of modules under 2.6, 3.x, and later kernels, as well
|
loading and unloading of modules under 2.6, 3.x, and later kernels, as well
|
||||||
@ -50,7 +48,6 @@ applications that wish to load or unload Linux kernel modules.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export V=1
|
export V=1
|
||||||
@ -114,6 +111,9 @@ install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/weak-modules
|
|||||||
%{_libdir}/libkmod.so
|
%{_libdir}/libkmod.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Nov 16 2014 Josh Boyer <jwboyer@fedoraproject.org> - 19-1
|
||||||
|
- Update to version 19
|
||||||
|
|
||||||
* Wed Oct 29 2014 Josh Boyer <jwboyer@fedoraproject.org> - 18-4
|
* Wed Oct 29 2014 Josh Boyer <jwboyer@fedoraproject.org> - 18-4
|
||||||
- Backport patch to fix device node permissions (rhbz 1147248)
|
- Backport patch to fix device node permissions (rhbz 1147248)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user