Merged update from upstream sources
This is an automated DistroBaker update from upstream sources. If you do not know what this is about or would like to opt out, contact the OSCI team. Source: https://src.fedoraproject.org/rpms/kmod.git#393f16a127b027b16b5193efadbbe59490fb0ee2
This commit is contained in:
parent
c62209c195
commit
2873506112
1
.gitignore
vendored
1
.gitignore
vendored
@ -19,3 +19,4 @@
|
||||
/kmod-25.tar.xz
|
||||
/kmod-26.tar.xz
|
||||
/kmod-27.tar.xz
|
||||
/kmod-28.tar.xz
|
||||
|
@ -1,53 +0,0 @@
|
||||
From 53b30aeba2dedae9f5558f560231d9462e063dfc Mon Sep 17 00:00:00 2001
|
||||
From: Lucas De Marchi <lucas.demarchi@intel.com>
|
||||
Date: Thu, 5 Mar 2020 13:33:10 -0800
|
||||
Subject: [PATCH] depmod: do not output .bin to stdout
|
||||
|
||||
index_write() relies on fseek/ftell to manage the position to which we
|
||||
are write and thus needs the file stream to support it.
|
||||
|
||||
Right now when trying to write the index to stdout we fail with:
|
||||
|
||||
depmod: tools/depmod.c:416: index_write: Assertion `initial_offset >= 0' failed.
|
||||
Aborted (core dumped)
|
||||
|
||||
We have no interest in outputting our index to stdout, so just skip it
|
||||
like is done with other indexes.
|
||||
|
||||
While at it, add/remove some newlines to improve readability.
|
||||
|
||||
Reported-by: Yanko Kaneti <yaneti@declera.com>
|
||||
Fix: b866b2165ae6 ("Lookup aliases in the modules.builtin.modinfo")
|
||||
---
|
||||
tools/depmod.c | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/depmod.c b/tools/depmod.c
|
||||
index fbbce10eb0db..875e31480818 100644
|
||||
--- a/tools/depmod.c
|
||||
+++ b/tools/depmod.c
|
||||
@@ -2408,8 +2408,10 @@ static int output_builtin_alias_bin(struct depmod *depmod, FILE *out)
|
||||
struct index_node *idx;
|
||||
struct kmod_list *l, *builtin = NULL;
|
||||
|
||||
- idx = index_create();
|
||||
+ if (out == stdout)
|
||||
+ return 0;
|
||||
|
||||
+ idx = index_create();
|
||||
if (idx == NULL) {
|
||||
ret = -ENOMEM;
|
||||
goto fail;
|
||||
@@ -2456,7 +2458,9 @@ static int output_builtin_alias_bin(struct depmod *depmod, FILE *out)
|
||||
|
||||
if (count)
|
||||
index_write(idx, out);
|
||||
+
|
||||
index_destroy(idx);
|
||||
+
|
||||
fail:
|
||||
if (builtin)
|
||||
kmod_module_unref_list(builtin);
|
||||
--
|
||||
2.25.0
|
||||
|
16
kmod.spec
16
kmod.spec
@ -1,6 +1,6 @@
|
||||
Name: kmod
|
||||
Version: 27
|
||||
Release: 3%{?dist}
|
||||
Version: 28
|
||||
Release: 1%{?dist}
|
||||
Summary: Linux kernel module management utilities
|
||||
|
||||
License: GPLv2+
|
||||
@ -9,14 +9,14 @@ Source0: https://www.kernel.org/pub/linux/utils/kernel/kmod/%{name}-%{version}.t
|
||||
Source1: weak-modules
|
||||
Exclusiveos: Linux
|
||||
|
||||
Patch01: 0001-depmod-do-not-output-.bin-to-stdout.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: xz-devel
|
||||
BuildRequires: libxslt
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: make
|
||||
BuildRequires: libzstd-devel
|
||||
|
||||
Provides: module-init-tools = 4.0-1
|
||||
Obsoletes: module-init-tools < 4.0-1
|
||||
@ -51,7 +51,8 @@ applications that wish to load or unload Linux kernel modules.
|
||||
%configure \
|
||||
--with-openssl \
|
||||
--with-zlib \
|
||||
--with-xz
|
||||
--with-xz \
|
||||
--with-zstd
|
||||
|
||||
%{make_build} V=1
|
||||
|
||||
@ -106,6 +107,11 @@ install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_sbindir}/weak-modules
|
||||
%{_libdir}/libkmod.so
|
||||
|
||||
%changelog
|
||||
* Thu Jan 07 2021 Josh Boyer <jwboyer@fedoraproject.org> - 28-1
|
||||
- New upstream v28
|
||||
- Enable zstd support
|
||||
- Resolves: rhbz#1913949
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 27-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (kmod-27.tar.xz) = e0513094935333fca1fb4c3e3493b232507a579ab00a6457cc9ed3e928363d05aad80634fb65a8287a336bf9895194c7be8ddc41bb088a6c2cca44fc1bfbdb6c
|
||||
SHA512 (kmod-28.tar.xz) = 50646dc72675a5e17b01e327e3d41b972f18aaeac20c8b00983c4d099c6218f35c32c184a833a2d7f716755d6a86851c90913d2835874cef933bdc4a9722df9a
|
||||
|
Loading…
Reference in New Issue
Block a user