New upstream v31

Resolves: rhbz#2241394
This commit is contained in:
Josh Boyer 2023-11-09 09:01:37 -05:00
parent 389eca78ce
commit 15b926cdb7
2 changed files with 6 additions and 40 deletions

View File

@ -1,37 +0,0 @@
configure.ac: In _Noreturn check, include <stdlib.h> for exit
Otherwise, an implicit functiona declaration is used, causing
a C99 compatibility issue.
Submitted upstream:
<https://lore.kernel.org/linux-modules/877cyq6kh9.fsf@oldenburg.str.redhat.com/>
diff --git a/configure b/configure
index d053310a8b4a313a..ec1f12d02428f848 100755
--- a/configure
+++ b/configure
@@ -14021,7 +14021,8 @@ rm -f core conftest.err conftest.$ac_objext conftest.beam conftest.$ac_ext
printf %s "checking whether _Noreturn is supported... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-_Noreturn int foo(void) { exit(0); }
+#include <stdlib.h>
+ _Noreturn int foo(void) { exit(0); }
_ACEOF
if ac_fn_c_try_compile "$LINENO"
then :
diff --git a/configure.ac b/configure.ac
index 6989e9360da23721..12e0518533201ccf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -68,7 +68,8 @@ AC_COMPILE_IFELSE(
AC_MSG_CHECKING([whether _Noreturn is supported])
AC_COMPILE_IFELSE(
- [AC_LANG_SOURCE([[_Noreturn int foo(void) { exit(0); }]])],
+ [AC_LANG_SOURCE([[#include <stdlib.h>
+ _Noreturn int foo(void) { exit(0); }]])],
[AC_DEFINE([HAVE_NORETURN], [1], [Define if _Noreturn is available])
AC_MSG_RESULT([yes])],
[AC_MSG_RESULT([no])])

View File

@ -15,8 +15,8 @@
%bcond_without zstd
Name: kmod
Version: 30
Release: 6%{?dist}
Version: 31
Release: 1%{?dist}
Summary: Linux kernel module management utilities
License: GPLv2+
@ -24,7 +24,6 @@ URL: https://git.kernel.org/pub/scm/utils/kernel/kmod/kmod.git
Source0: https://www.kernel.org/pub/linux/utils/kernel/kmod/%{name}-%{version}.tar.xz
Source1: weak-modules
Source2: depmod.conf.dist
Patch0: kmod-configure-c99.patch
Exclusiveos: Linux
BuildRequires: gcc
@ -150,6 +149,10 @@ install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/depmod.d/dist.conf
%{_libdir}/libkmod.so
%changelog
* Thu Nov 09 2023 Josh Boyer <jwboyer@fedoraproject.org> - 31-1
- New upstream v31
- Resolves: rhbz#2241394
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 30-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild