2fc7312546
Backport the patches required to make the hardening build flags work with kexec-tools and makedumpfile, and enabld hardening flags in spec file. This will make the pacakge pass all warnings for kexec and makedumpfile reported by annocheck. Didn't find any issue with basic tests with kexec and makedumpfile. Signed-off-by: Kairui Song <kasong@redhat.com> Acked-by: Dave Young <dyoung@redhat.com>
42 lines
1.4 KiB
Diff
42 lines
1.4 KiB
Diff
From 2f007b48c581a81d7e95678b6bcb77cfbe177135 Mon Sep 17 00:00:00 2001
|
|
From: Kairui Song <kasong@redhat.com>
|
|
Date: Tue, 29 Jan 2019 11:14:15 +0800
|
|
Subject: [PATCH] [PATCH v2] honor the CFLAGS from environment variables
|
|
|
|
This makes it possible to pass in extra cflags, for example, hardening
|
|
flags could be passed in with environment variable when building a
|
|
hardened package.
|
|
|
|
Also introduce a CFLAGS_BASE to hold common CFLAGS, which simplify the
|
|
CFLAGS definition.
|
|
|
|
Suggested-by: Kazuhito Hagio <k-hagio@ab.jp.nec.com>
|
|
Signed-off-by: Kairui Song <kasong@redhat.com>
|
|
---
|
|
Makefile | 9 ++++-----
|
|
1 file changed, 4 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index ea3c47d..bd681d2 100644
|
|
--- a/makedumpfile-1.6.5/Makefile
|
|
+++ b/makedumpfile-1.6.5/Makefile
|
|
@@ -8,11 +8,10 @@ ifeq ($(strip $CC),)
|
|
CC = gcc
|
|
endif
|
|
|
|
-CFLAGS = -g -O2 -Wall -D_FILE_OFFSET_BITS=64 \
|
|
- -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE \
|
|
- -DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(DATE)"'
|
|
-CFLAGS_ARCH = -g -O2 -Wall -D_FILE_OFFSET_BITS=64 \
|
|
- -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
|
|
+CFLAGS_BASE := $(CFLAGS) -g -O2 -Wall -D_FILE_OFFSET_BITS=64 \
|
|
+ -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE
|
|
+CFLAGS := $(CFLAGS_BASE) -DVERSION='"$(VERSION)"' -DRELEASE_DATE='"$(DATE)"'
|
|
+CFLAGS_ARCH := $(CFLAGS_BASE)
|
|
# LDFLAGS = -L/usr/local/lib -I/usr/local/include
|
|
|
|
HOST_ARCH := $(shell uname -m)
|
|
--
|
|
2.20.1
|
|
|