- Build for x86_64 as well. Kdump support doesn't work there, but users
should be able to use kexec.
This commit is contained in:
parent
0112f3628c
commit
e97a6c60ad
14
kexec-tools-1.101-disable-kdump-x8664.patch
Normal file
14
kexec-tools-1.101-disable-kdump-x8664.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- kexec-tools-1.101/Makefile.orig 2005-11-03 10:34:21.000000000 -0500
|
||||
+++ kexec-tools-1.101/Makefile 2005-11-03 10:34:47.000000000 -0500
|
||||
@@ -43,9 +43,9 @@ PKGLIBDIR=$(LIBDIR)/$(PACKAGE)
|
||||
PKGINCLUDEIR=$(INCLUDEDIR)/$(PACKAGE)
|
||||
|
||||
MAN_PAGES:= kexec/kexec.8
|
||||
-BINARIES_i386:= $(SBINDIR)/kexec $(PKGLIBDIR)/kexec_test
|
||||
+BINARIES_i386:= $(SBINDIR)/kexec $(PKGLIBDIR)/kexec_test $(SBINDIR)/kdump
|
||||
BINARIES_x86_64:=$(SBINDIR)/kexec $(PKGLIBDIR)/kexec_test
|
||||
-BINARIES:=$(SBINDIR)/kexec $(SBINDIR)/kdump $(BINARIES_$(ARCH))
|
||||
+BINARIES:=$(SBINDIR)/kexec $(BINARIES_$(ARCH))
|
||||
|
||||
TARGETS:=$(BINARIES) $(MAN_PAGES)
|
||||
|
@ -1,15 +1,22 @@
|
||||
Name: kexec-tools
|
||||
Version: 1.101
|
||||
Release: 3
|
||||
Release: 4
|
||||
License: GPL
|
||||
Group: Applications/System
|
||||
Summary: The kexec/kdump userspace component.
|
||||
ExclusiveArch: %{ix86}
|
||||
ExclusiveArch: %{ix86} x86_64
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
Source1: kdump.init
|
||||
Source2: kdump.sysconfig
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
|
||||
|
||||
%define kdump 0
|
||||
|
||||
%ifarch %{ix86}
|
||||
%define kdump 1
|
||||
%endif
|
||||
|
||||
|
||||
#
|
||||
# Patches 0 through 100 are meant for x86 kexec-tools enablement
|
||||
#
|
||||
@ -18,6 +25,7 @@ Patch1: kexec-tools-1.101-kdump.patch
|
||||
#
|
||||
# Patches 101 through 200 are meant for x86_64 kexec-tools enablement
|
||||
#
|
||||
Patch101: kexec-tools-1.101-disable-kdump-x8664.patch
|
||||
|
||||
#
|
||||
# Patches 201 through 300 are meant for ia64 kexec-tools enablement
|
||||
@ -38,9 +46,12 @@ component of the kernel's kexec feature.
|
||||
%setup -q -n %{name}-%{version}
|
||||
rm -f ../kexec-tools-1.101.spec
|
||||
%patch1 -p1
|
||||
%patch101 -p1
|
||||
|
||||
%if %{kdump}
|
||||
cp $RPM_SOURCE_DIR/kdump.init .
|
||||
cp $RPM_SOURCE_DIR/kdump.sysconfig .
|
||||
%endif
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -52,16 +63,21 @@ rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
|
||||
mkdir -p -m755 $RPM_BUILD_ROOT/etc/sysconfig
|
||||
%if %{kdump}
|
||||
install -m 644 kdump.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/kdump
|
||||
install -m 755 kdump.init $RPM_BUILD_ROOT/etc/rc.d/init.d/kdump
|
||||
%endif
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%post
|
||||
%if %{kdump}
|
||||
chkconfig --add kdump
|
||||
%endif
|
||||
|
||||
%postun
|
||||
|
||||
if [ "$1" -ge 1 ]; then
|
||||
/sbin/service kdump condrestart > /dev/null 2>&1 || :
|
||||
fi
|
||||
@ -76,15 +92,22 @@ exit 0
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%{_sbindir}/kexec
|
||||
%if %{kdump}
|
||||
%{_sbindir}/kdump
|
||||
%{_libdir}/kexec-tools/kexec_test
|
||||
%config(noreplace,missingok) /etc/sysconfig/kdump
|
||||
%config /etc/rc.d/init.d/kdump
|
||||
%endif
|
||||
|
||||
%{_libdir}/kexec-tools/kexec_test
|
||||
%doc News
|
||||
%doc COPYING
|
||||
%doc TODO
|
||||
|
||||
%changelog
|
||||
* Thu Nov 3 2005 Jeff Moyer <jmoyer@redhat.com> - 1.101-4
|
||||
- Build for x86_64 as well. Kdump support doesn't work there, but users
|
||||
should be able to use kexec.
|
||||
|
||||
* Fri Sep 23 2005 Jeff Moyer <jmoyer@redhat.com> - 1.101-3
|
||||
- Add a kdump sysconfig file and init script
|
||||
- Spec file additions for pre/post install/uninstall
|
||||
|
Loading…
Reference in New Issue
Block a user