Fix building failure due to makedumpfile's compile flag

From: Pingfan Liu <piliu@redhat.com>

makedumpfile: remove -lebl

-lebl has been removed from elfutils.

Signed-off-by: Kairui Song <kasong@redhat.com>
This commit is contained in:
Kairui Song 2019-12-28 03:12:27 +08:00
parent 68dcfcfb47
commit b301d6c4f4
2 changed files with 28 additions and 0 deletions

View File

@ -0,0 +1,26 @@
From 3beef142bc003d9cf2e957c6a21e51d661f9b13e Mon Sep 17 00:00:00 2001
From: Pingfan Liu <piliu@redhat.com>
Date: Thu, 28 Nov 2019 21:23:00 +0800
Subject: [PATCH] makedumpfile: remove -lebl
Signed-off-by: Pingfan Liu <piliu@redhat.com>
---
makedumpfile-1.6.6/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/makedumpfile-1.6.6/Makefile b/makedumpfile-1.6.6/Makefile
index 1fdb628..df21b93 100644
--- a/makedumpfile-1.6.6/Makefile
+++ b/makedumpfile-1.6.6/Makefile
@@ -50,7 +50,7 @@ OBJ_PART=$(patsubst %.c,%.o,$(SRC_PART))
SRC_ARCH = arch/arm.c arch/arm64.c arch/x86.c arch/x86_64.c arch/ia64.c arch/ppc64.c arch/s390x.c arch/ppc.c arch/sparc64.c
OBJ_ARCH=$(patsubst %.c,%.o,$(SRC_ARCH))
-LIBS = -ldw -lbz2 -lebl -ldl -lelf -lz
+LIBS = -ldw -lbz2 -ldl -lelf -lz
ifneq ($(LINKTYPE), dynamic)
LIBS := -static $(LIBS)
endif
--
2.20.1

View File

@ -101,6 +101,7 @@ Patch102: kexec-tools-2.0.20-makedumpfile-Fix-exclusion-range-in-find_vmemmap_pa
Patch601: kexec-tools-2.0.20-makedumpfile-Do-not-proceed-when-get_num_dumpable_cyclic-fails.patch
Patch602: kexec-tools-2.0.20-makedumpfile-Increase-SECTION_MAP_LAST_BIT-to-4.patch
Patch603: kexec-tools-2.0.20-makedumpfile-Fix-inconsistent-return-value-from-find_vmemmap.patch
Patch604: kexec-tools-2.0.20-makedumpfile-remove-lebl.patch
%description
kexec-tools provides /sbin/kexec binary that facilitates a new
@ -122,6 +123,7 @@ tar -z -x -v -f %{SOURCE19}
%patch101 -p1
%patch102 -p1
%patch603 -p1
%patch604 -p1
%ifarch ppc
%define archdef ARCH=ppc