Release 2.0.20-1
Signed-off-by: Kairui Song <kasong@redhat.com>
This commit is contained in:
parent
1d5d39f3d4
commit
7cb4be80cd
@ -1,88 +0,0 @@
|
|||||||
From 940c3a1e1a304fbecc850c593a272215b0f52eab Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kairui Song <kasong@redhat.com>
|
|
||||||
Date: Wed, 31 Jul 2019 16:30:47 +0800
|
|
||||||
Subject: [PATCH] x86: Fix broken multiboot2 buliding for i386
|
|
||||||
|
|
||||||
When building for i386, an error occured:
|
|
||||||
|
|
||||||
kexec/arch/i386/kexec-x86.c:39:22: error: 'multiboot2_x86_probe'
|
|
||||||
undeclared here (not in a function); did you mean 'multiboot_x86_probe'?
|
|
||||||
39 | { "multiboot2-x86", multiboot2_x86_probe, multiboot2_x86_load,
|
|
||||||
| ^~~~~~~~~~~~~~~~~~~~
|
|
||||||
| multiboot_x86_probe
|
|
||||||
|
|
||||||
kexec/arch/i386/kexec-x86.c:39:44: error: 'multiboot2_x86_load'
|
|
||||||
undeclared here (not in a function); did you mean 'multiboot_x86_load'?
|
|
||||||
39 | { "multiboot2-x86", multiboot2_x86_probe, multiboot2_x86_load,
|
|
||||||
| ^~~~~~~~~~~~~~~~~~~
|
|
||||||
| multiboot_x86_load
|
|
||||||
kexec/arch/i386/kexec-x86.c:40:4: error: 'multiboot2_x86_usage'
|
|
||||||
undeclared here (not in a function); did you mean 'multiboot_x86_usage'?
|
|
||||||
40 | multiboot2_x86_usage },
|
|
||||||
| ^~~~~~~~~~~~~~~~~~~~
|
|
||||||
| multiboot_x86_usage
|
|
||||||
|
|
||||||
Fix this issue by putting the definition in the right header, also tidy
|
|
||||||
up Makefile.
|
|
||||||
|
|
||||||
Fixes: 22a2ed55132e ("x86: Support multiboot2 images")
|
|
||||||
Signed-off-by: Kairui Song <kasong@redhat.com>
|
|
||||||
---
|
|
||||||
kexec/arch/i386/Makefile | 2 +-
|
|
||||||
kexec/arch/i386/kexec-x86.h | 5 +++++
|
|
||||||
kexec/arch/x86_64/kexec-x86_64.h | 5 -----
|
|
||||||
3 files changed, 6 insertions(+), 6 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/kexec/arch/i386/Makefile b/kexec/arch/i386/Makefile
|
|
||||||
index 105cefd..f486103 100644
|
|
||||||
--- a/kexec/arch/i386/Makefile
|
|
||||||
+++ b/kexec/arch/i386/Makefile
|
|
||||||
@@ -7,6 +7,7 @@ i386_KEXEC_SRCS += kexec/arch/i386/kexec-elf-x86.c
|
|
||||||
i386_KEXEC_SRCS += kexec/arch/i386/kexec-elf-rel-x86.c
|
|
||||||
i386_KEXEC_SRCS += kexec/arch/i386/kexec-bzImage.c
|
|
||||||
i386_KEXEC_SRCS += kexec/arch/i386/kexec-multiboot-x86.c
|
|
||||||
+i386_KEXEC_SRCS += kexec/arch/i386/kexec-mb2-x86.c
|
|
||||||
i386_KEXEC_SRCS += kexec/arch/i386/kexec-beoboot-x86.c
|
|
||||||
i386_KEXEC_SRCS += kexec/arch/i386/kexec-nbi.c
|
|
||||||
i386_KEXEC_SRCS += kexec/arch/i386/x86-linux-setup.c
|
|
||||||
@@ -14,7 +15,6 @@ i386_KEXEC_SRCS += kexec/arch/i386/crashdump-x86.c
|
|
||||||
|
|
||||||
dist += kexec/arch/i386/Makefile $(i386_KEXEC_SRCS) \
|
|
||||||
kexec/arch/i386/crashdump-x86.h \
|
|
||||||
- kexec/arch/i386/kexec-mb2-x86.c \
|
|
||||||
kexec/arch/i386/kexec-x86.h \
|
|
||||||
kexec/arch/i386/x86-linux-setup.h \
|
|
||||||
kexec/arch/i386/include/arch/options.h
|
|
||||||
diff --git a/kexec/arch/i386/kexec-x86.h b/kexec/arch/i386/kexec-x86.h
|
|
||||||
index 1b58c3b..16d0f6c 100644
|
|
||||||
--- a/kexec/arch/i386/kexec-x86.h
|
|
||||||
+++ b/kexec/arch/i386/kexec-x86.h
|
|
||||||
@@ -60,6 +60,11 @@ int multiboot_x86_load(int argc, char **argv, const char *buf, off_t len,
|
|
||||||
struct kexec_info *info);
|
|
||||||
void multiboot_x86_usage(void);
|
|
||||||
|
|
||||||
+int multiboot2_x86_load(int argc, char **argv, const char *buf, off_t len,
|
|
||||||
+ struct kexec_info *info);
|
|
||||||
+void multiboot2_x86_usage(void);
|
|
||||||
+int multiboot2_x86_probe(const char *buf, off_t buf_len);
|
|
||||||
+
|
|
||||||
int elf_x86_probe(const char *buf, off_t len);
|
|
||||||
int elf_x86_load(int argc, char **argv, const char *buf, off_t len,
|
|
||||||
struct kexec_info *info);
|
|
||||||
diff --git a/kexec/arch/x86_64/kexec-x86_64.h b/kexec/arch/x86_64/kexec-x86_64.h
|
|
||||||
index 21c3a73..4cdeffb 100644
|
|
||||||
--- a/kexec/arch/x86_64/kexec-x86_64.h
|
|
||||||
+++ b/kexec/arch/x86_64/kexec-x86_64.h
|
|
||||||
@@ -33,9 +33,4 @@ int bzImage64_load(int argc, char **argv, const char *buf, off_t len,
|
|
||||||
struct kexec_info *info);
|
|
||||||
void bzImage64_usage(void);
|
|
||||||
|
|
||||||
-int multiboot2_x86_load(int argc, char **argv, const char *buf, off_t len,
|
|
||||||
- struct kexec_info *info);
|
|
||||||
-void multiboot2_x86_usage(void);
|
|
||||||
-int multiboot2_x86_probe(const char *buf, off_t buf_len);
|
|
||||||
-
|
|
||||||
#endif /* KEXEC_X86_64_H */
|
|
||||||
--
|
|
||||||
2.21.0
|
|
||||||
|
|
@ -4,8 +4,8 @@
|
|||||||
%global mkdf_shortver %(c=%{mkdf_ver}; echo ${c:0:7})
|
%global mkdf_shortver %(c=%{mkdf_ver}; echo ${c:0:7})
|
||||||
|
|
||||||
Name: kexec-tools
|
Name: kexec-tools
|
||||||
Version: 2.0.20
|
Version: 2.0.21
|
||||||
Release: 21%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
Summary: The kexec/kdump userspace component
|
Summary: The kexec/kdump userspace component
|
||||||
|
|
||||||
@ -80,7 +80,6 @@ Requires: systemd-udev%{?_isa}
|
|||||||
#
|
#
|
||||||
# Patches 0 through 100 are meant for x86 kexec-tools enablement
|
# Patches 0 through 100 are meant for x86 kexec-tools enablement
|
||||||
#
|
#
|
||||||
Patch0: kexec-tools-2.0.20-fix-broken-multiboot2-buliding-for-i386.patch
|
|
||||||
|
|
||||||
#
|
#
|
||||||
# Patches 101 through 200 are meant for x86_64 kexec-tools enablement
|
# Patches 101 through 200 are meant for x86_64 kexec-tools enablement
|
||||||
@ -101,7 +100,6 @@ Patch0: kexec-tools-2.0.20-fix-broken-multiboot2-buliding-for-i386.patch
|
|||||||
# Patches 601 onward are generic patches
|
# Patches 601 onward are generic patches
|
||||||
#
|
#
|
||||||
Patch601: ./kexec-tools-2.0.20-eppic-Remove-duplicated-variable-declaration.patch
|
Patch601: ./kexec-tools-2.0.20-eppic-Remove-duplicated-variable-declaration.patch
|
||||||
Patch602: ./kexec-tools-2.0.20-Remove-duplicated-variable-declarations.patch
|
|
||||||
Patch603: ./kexec-tools-2.0.20-makedumpfile-printk-add-support-for-lockless-ringbuffer.patch
|
Patch603: ./kexec-tools-2.0.20-makedumpfile-printk-add-support-for-lockless-ringbuffer.patch
|
||||||
Patch604: ./kexec-tools-2.0.20-makedumpfile-printk-use-committed-finalized-state-value.patch
|
Patch604: ./kexec-tools-2.0.20-makedumpfile-printk-use-committed-finalized-state-value.patch
|
||||||
|
|
||||||
@ -119,10 +117,7 @@ mkdir -p -m755 kcp
|
|||||||
tar -z -x -v -f %{SOURCE9}
|
tar -z -x -v -f %{SOURCE9}
|
||||||
tar -z -x -v -f %{SOURCE19}
|
tar -z -x -v -f %{SOURCE19}
|
||||||
|
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%patch601 -p1
|
%patch601 -p1
|
||||||
%patch602 -p1
|
|
||||||
%patch603 -p1
|
%patch603 -p1
|
||||||
%patch604 -p1
|
%patch604 -p1
|
||||||
|
|
||||||
@ -363,6 +358,14 @@ done
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 23 2020 Kairui Song <kasong@redhat.com> - 2.0.21-1
|
||||||
|
- makedumpfile: printk: use committed/finalized state values
|
||||||
|
- makedumpfile: printk: add support for lockless ringbuffer
|
||||||
|
- dracut-module-setup.sh: Use systemctl call to replace ln_r
|
||||||
|
- Doc: improve mkdumprd man page
|
||||||
|
- Don's try to restart dracut-initqueue if it's already failed
|
||||||
|
- dracut-module-setup.sh: use auto6 for ipv6
|
||||||
|
|
||||||
* Mon Nov 30 2020 Kairui Song <kasong@redhat.com> - 2.0.20-21
|
* Mon Nov 30 2020 Kairui Song <kasong@redhat.com> - 2.0.20-21
|
||||||
- Rebase makedumpfile to 1.6.8
|
- Rebase makedumpfile to 1.6.8
|
||||||
- fadump-howto: update about 'nocma' and 'off' options for 'fadump=' parameter
|
- fadump-howto: update about 'nocma' and 'off' options for 'fadump=' parameter
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
SHA512 (eppic-d84c354.tar.gz) = 455b3386c3e4cc546b858f1f8b0e6874072aaae708ebe072452fb5f0b6a81b1f3a315b40f94c3967f38525cadd276864a7bc7f0f12fa421655dcc3b15b70914d
|
SHA512 (eppic-d84c354.tar.gz) = 455b3386c3e4cc546b858f1f8b0e6874072aaae708ebe072452fb5f0b6a81b1f3a315b40f94c3967f38525cadd276864a7bc7f0f12fa421655dcc3b15b70914d
|
||||||
SHA512 (kexec-tools-2.0.20.tar.xz) = 3112b6202c1030705c53e3f65a2b58aec14d65333a35aad681d48b9f2bd1c51a2e05c985a1e5e867ab02f8a9c97708483d9d225619db7c6993676f1a242e2d99
|
|
||||||
SHA512 (makedumpfile-1.6.8.tar.gz) = 15e60688b06013bf86e339ec855774ea2c904d425371ea867101704ba0611c69da891eb3cc96f67eb10197d8c42d217ea28bf11bcaa93ddc2495cbf984c0b7ec
|
SHA512 (makedumpfile-1.6.8.tar.gz) = 15e60688b06013bf86e339ec855774ea2c904d425371ea867101704ba0611c69da891eb3cc96f67eb10197d8c42d217ea28bf11bcaa93ddc2495cbf984c0b7ec
|
||||||
|
SHA512 (kexec-tools-2.0.21.tar.xz) = f487d2e243c2c4f29fbc9da7d06806f65210f717904655fc84d8d162b9c4614c3dd62e1bb47104a79f0dc2af04e462baf764fb309b5d7e6d287264cb48fd2a3e
|
||||||
|
Loading…
Reference in New Issue
Block a user