Makefile: Fix early-kdump file names

Resolves: RHEL-40956

commit 5109f119b643a416f24938774c02e39bb5d30467
Author: Philipp Rudo <prudo@redhat.com>
Date:   Mon Jun 24 13:44:22 2024 +0200

    Makefile: Fix early-kdump file names

    When creating the kdump-utils subpackage the files for earlykdump were
    incorrectly renamed to kdump.sh and kdump-module-setup.sh rather than
    the expected early-kdump.sh and module-setup.sh. These incorrect file
    names then got transferred to the newly created Makefile with fe372af
    ("Upstream kdump-utils").

    With those incorrect file names dracut fails when trying to add the
    earlykdump module with

            # dracut --add earlykdump kdump.img
            dracut[E]: Module 'earlykdump' cannot be installed.

    Fix the file names to allow installing the earlykdump module.

    Fixes: 372b4c6 ("Add kdump-utils subpackage")
    Signed-off-by: Philipp Rudo <prudo@redhat.com>

Signed-off-by: Philipp Rudo <prudo@redhat.com>
This commit is contained in:
Philipp Rudo 2024-07-09 15:37:11 +02:00
parent 3fe4cdffbc
commit 5e77777a6b
2 changed files with 45 additions and 0 deletions

View File

@ -0,0 +1,43 @@
From e6b134a1593036b47a2a35da3c695a0db90de73f Mon Sep 17 00:00:00 2001
From: Philipp Rudo <prudo@redhat.com>
Date: Mon, 24 Jun 2024 13:44:22 +0200
Subject: [PATCH 6/7] Makefile: Fix early-kdump file names
When creating the kdump-utils subpackage the files for earlykdump were
incorrectly renamed to kdump.sh and kdump-module-setup.sh rather than
the expected early-kdump.sh and module-setup.sh. These incorrect file
names then got transferred to the newly created Makefile with fe372af
("Upstream kdump-utils").
With those incorrect file names dracut fails when trying to add the
earlykdump module with
# dracut --add earlykdump kdump.img
dracut[E]: Module 'earlykdump' cannot be installed.
Fix the file names to allow installing the earlykdump module.
Fixes: 372b4c6 ("Add kdump-utils subpackage")
Signed-off-by: Philipp Rudo <prudo@redhat.com>
---
Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index e1a511c..538e4f4 100644
--- a/Makefile
+++ b/Makefile
@@ -26,8 +26,8 @@ dracut-modules:
install -m 644 dracut-kdump-emergency.target $(kdumpbasemoddir)/kdump-emergency.target
mkdir -p -m755 $(dracutmoddir)/99earlykdump
- install -m 755 dracut-early-kdump.sh $(dracutmoddir)/99earlykdump/kdump.sh
- install -m 755 dracut-early-kdump-module-setup.sh $(dracutmoddir)/99earlykdump/kdump-module-setup.sh
+ install -m 755 dracut-early-kdump.sh $(dracutmoddir)/99earlykdump/early-kdump.sh
+ install -m 755 dracut-early-kdump-module-setup.sh $(dracutmoddir)/99earlykdump/module-setup.sh
ifeq ($(ARCH), $(filter ppc64le ppc64,$(ARCH)))
mkdir -p -m755 $(dracutmoddir)/99zz-fadumpinit
--
2.45.2

View File

@ -70,6 +70,7 @@ Patch614: 0002-kdump-lib-fix-sed-expression-in-prepare_cmdline-on-a.patch
Patch615: 0003-kdumpctl-Simplify-fadump-handling-in-reset_crashkern.patch Patch615: 0003-kdumpctl-Simplify-fadump-handling-in-reset_crashkern.patch
Patch616: 0004-kdumpctl.8-Add-description-to-reset-crashkernel-rebo.patch Patch616: 0004-kdumpctl.8-Add-description-to-reset-crashkernel-rebo.patch
Patch617: 0005-dracut-kdump.sh-Save-kexec-dmesg.log-after-failure_a.patch Patch617: 0005-dracut-kdump.sh-Save-kexec-dmesg.log-after-failure_a.patch
Patch618: 0006-Makefile-Fix-early-kdump-file-names.patch
%description %description
kexec-tools provides /sbin/kexec binary that facilitates a new kexec-tools provides /sbin/kexec binary that facilitates a new
@ -170,6 +171,7 @@ tar -z -x -v -f %{SOURCE19}
%patch 615 -p1 -d kdump-utils-%{kdump_utils_ver} %patch 615 -p1 -d kdump-utils-%{kdump_utils_ver}
%patch 616 -p1 -d kdump-utils-%{kdump_utils_ver} %patch 616 -p1 -d kdump-utils-%{kdump_utils_ver}
%patch 617 -p1 -d kdump-utils-%{kdump_utils_ver} %patch 617 -p1 -d kdump-utils-%{kdump_utils_ver}
%patch 618 -p1 -d kdump-utils-%{kdump_utils_ver}
%ifarch ppc %ifarch ppc
%define archdef ARCH=ppc %define archdef ARCH=ppc