Resolves: bz 235030

This commit is contained in:
Neil Horman 2007-04-10 15:03:31 +00:00
parent 14cfbd3690
commit 4394da70ce
2 changed files with 19 additions and 1 deletions

View File

@ -0,0 +1,13 @@
--- kexec-tools-1.101/kexec/arch/ppc64/kexec-ppc64.c.orig 2007-04-10 10:53:44.000000000 -0400
+++ kexec-tools-1.101/kexec/arch/ppc64/kexec-ppc64.c 2007-04-10 10:53:58.000000000 -0400
@@ -369,8 +369,8 @@
}
rmo_base = ((unsigned long long *)buf)[0];
rmo_top = rmo_base + ((unsigned long long *)buf)[1];
- if (rmo_top > 0x30000000UL)
- rmo_top = 0x30000000UL;
+ if (rmo_top > 0x07C00000UL)
+ rmo_top = 0x07C00000UL;
fclose(file);
closedir(cdir);

View File

@ -1,6 +1,6 @@
Name: kexec-tools
Version: 1.101
Release: 65%{?dist}
Release: 66%{?dist}
License: GPL
Group: Applications/System
Summary: The kexec/kdump userspace component.
@ -65,6 +65,7 @@ Patch303: kexec-tools-1.101-ppc64-cliargs.patch
Patch304: kexec-tools-1.101-ppc64-platform-fix.patch
Patch305: kexec-tools-1.101-ppc64-64k-pages.patch
Patch306: kexec-tools-1.101-ppc64-memory_regions.patch
Patch307: kexec-tools-1.101-ppc64_rmo_top.patch
#
# Patches 401 through 500 are meant for s390 kexec-tools enablement
@ -118,6 +119,7 @@ rm -f ../kexec-tools-1.101.spec
%patch304 -p1
%patch305 -p1
%patch306 -p1
%patch307 -p1
%patch401 -p1
%patch501 -p1
%patch601 -p1
@ -239,6 +241,9 @@ rm -f %{_datadir}/firstboot/modules/firstboot_kdump.py
%doc kexec-kdump-howto.txt
%changelog
* Tue Apr 10 2007 Neil Horman <nhorman@redhat.com> - 1.101-66%{dist}
- Reduce rmo_top to 0x7c000000 for PS3 (bz 235030)
* Mon Mar 26 2007 Neil Horman <nhorman@redhat.com> - 1.101-65%{dist}
- Fix spec to own kexec_tools directory (bz 219035)