Making makedumpfile a dynamic binary

This commit is contained in:
Neil Horman 2009-07-06 19:58:59 +00:00
parent a4bf642ce9
commit 2c04e2b8b2
2 changed files with 18 additions and 1 deletions

View File

@ -0,0 +1,12 @@
diff -up kexec-tools-2.0.0/makedumpfile-1.3.3/Makefile.orig kexec-tools-2.0.0/makedumpfile-1.3.3/Makefile
--- kexec-tools-2.0.0/makedumpfile-1.3.3/Makefile.orig 2009-07-06 15:45:56.000000000 -0400
+++ kexec-tools-2.0.0/makedumpfile-1.3.3/Makefile 2009-07-06 15:46:06.000000000 -0400
@@ -32,7 +32,7 @@ $(OBJ_ARCH): $(SRC_ARCH)
$(CC) $(CFLAGS_ARCH) -c -o ./$@ ./$(@:.o=.c)
makedumpfile: $(SRC) $(OBJ_ARCH)
- $(CC) $(CFLAGS) $(OBJ_ARCH) -o $@ $< -static -ldw -lelf -lz
+ $(CC) $(CFLAGS) $(OBJ_ARCH) -o $@ $< -ldw -lelf -lz
gzip -c ./makedumpfile.8 > ./makedumpfile.8.gz
clean:

View File

@ -1,6 +1,6 @@
Name: kexec-tools
Version: 2.0.0
Release: 19%{?dist}
Release: 20%{?dist}
License: GPLv2
Group: Applications/System
Summary: The kexec/kdump userspace component.
@ -68,6 +68,7 @@ Obsoletes: diskdumputils netdump
# Patches 601 onward are generic patches
#
Patch601: kexec-tools-2.0.0-disable-kexec-test.patch
Patch602: kexec-tools-2.0.0-makedumpfile-dynamic-build.patch
%description
kexec-tools provides /sbin/kexec binary that facilitates a new
@ -83,6 +84,7 @@ mkdir -p -m755 kcp
tar -z -x -v -f %{SOURCE9}
%patch601 -p1
%patch602 -p1
tar -z -x -v -f %{SOURCE13}
@ -258,6 +260,9 @@ done
%changelog
* Mon Jul 06 2009 Neil Horman <nhorman@redhat.com> 2.0.0-20
- Make makedumpfile a dynamic binary
* Mon Jul 06 2009 Neil Horman <nhorman@redhat.com> 2.0.0-19
- Fix build issue