88e47722ba
Signed-off-by: Zamir SUN <sztsian@gmail.com>
50 lines
1.7 KiB
Diff
50 lines
1.7 KiB
Diff
From b90d567d467778eb7d9142788cc7061b9cdff7fa Mon Sep 17 00:00:00 2001
|
|
From: Zamir SUN <sztsian@gmail.com>
|
|
Date: Mon, 12 Oct 2020 21:52:09 +0800
|
|
Subject: [PATCH] kernelshark: Temporary move libtraceevent back to
|
|
%{_libdir}/trace-cmd
|
|
|
|
Signed-off-by: Zamir SUN <sztsian@gmail.com>
|
|
---
|
|
Makefile | 4 ++--
|
|
kernel-shark/CMakeLists.txt | 1 +
|
|
2 files changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index b034042..a02d1c2 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -68,7 +68,7 @@ plugin_tracecmd_dir = $(libdir)/trace-cmd/plugins
|
|
python_dir ?= $(libdir)/traceevent/python
|
|
var_dir = $(HOME)/.trace-cmd/
|
|
else
|
|
-plugin_traceevent_dir = $(libdir)/traceevent/plugins
|
|
+plugin_traceevent_dir = $(libdir)/trace-cmd/plugins
|
|
python_dir ?= $(libdir)/trace-cmd/python
|
|
PLUGIN_DIR_TRACEEVENT = -DPLUGIN_TRACEEVENT_DIR="$(plugin_traceevent_dir)"
|
|
PLUGIN_DIR_TRACECMD = -DPLUGIN_TRACECMD_DIR="$(plugin_tracecmd_dir)"
|
|
@@ -407,7 +407,7 @@ install: install_cmd
|
|
@echo "Note: to install the gui, type \"make install_gui\""
|
|
@echo " to install man pages, type \"make install_doc\""
|
|
|
|
-install_gui: install_cmd gui
|
|
+install_gui: gui
|
|
$(Q)$(MAKE) $(S) -C $(kshark-dir)/build install
|
|
|
|
install_libs: libs
|
|
diff --git a/kernel-shark/CMakeLists.txt b/kernel-shark/CMakeLists.txt
|
|
index c95249e..213f777 100644
|
|
--- a/kernel-shark/CMakeLists.txt
|
|
+++ b/kernel-shark/CMakeLists.txt
|
|
@@ -79,6 +79,7 @@ endif (CMAKE_BUILD_TYPE MATCHES Package)
|
|
|
|
include_directories(${KS_DIR}/src/
|
|
${KS_DIR}/build/src/
|
|
+ ${TRACEEVENT_LIBRARY}
|
|
${JSONC_INCLUDE_DIR}
|
|
${TRACECMD_INCLUDE_DIR}
|
|
${TRACEFS_INCLUDE_DIR})
|
|
--
|
|
2.26.2
|
|
|