Update to 2.1.0
This commit is contained in:
parent
98b8c94b56
commit
a83a9bb07d
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
/trace-cmd-kernelshark-v1.1.tar.gz
|
||||
/trace-cmd-kernelshark-v1.2.tar.gz
|
||||
/trace-cmd-kernelshark-v1.3.tar.gz
|
||||
/kernel-shark-kernelshark-v2.1.0.tar.gz
|
||||
|
@ -1,26 +0,0 @@
|
||||
From a0a28e0b5161203c7576a430ca12d11a16a88e74 Mon Sep 17 00:00:00 2001
|
||||
From: Zamir SUN <sztsian@gmail.com>
|
||||
Date: Thu, 24 Sep 2020 21:19:00 +0800
|
||||
Subject: [PATCH] Do not install trace-cmd when only building kernelshark
|
||||
|
||||
Signed-off-by: Zamir SUN <sztsian@gmail.com>
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index bbdf15e..a489fe8 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -338,7 +338,7 @@ install: install_cmd
|
||||
@echo "Note: to install the gui, type \"make install_gui\""
|
||||
@echo " to install man pages, type \"make install_doc\""
|
||||
|
||||
-install_gui: install_cmd gui
|
||||
+install_gui: gui
|
||||
$(Q)$(MAKE) $(S) -C $(kshark-dir)/build install
|
||||
|
||||
install_libs: libs
|
||||
--
|
||||
2.26.2
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: kernelshark
|
||||
Version: 1.3
|
||||
Release: 4%{?dist}
|
||||
Version: 2.1.0
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
|
||||
# As of 1.1, only kernelshark.cpp, kshark-record.cpp and examples are GPL-2.0. The rest of kernel-shark is LGPL-2.1.
|
||||
@ -9,9 +9,10 @@ License: GPLv2 and LGPLv2
|
||||
Summary: GUI analysis for Ftrace data captured by trace-cmd
|
||||
|
||||
URL: https://kernelshark.org
|
||||
Source0: https://git.kernel.org/pub/scm/utils/trace-cmd/trace-cmd.git/snapshot/trace-cmd-kernelshark-v%{version}.tar.gz
|
||||
Source0: https://git.kernel.org/pub/scm/utils/trace-cmd/kernel-shark.git/snapshot/kernel-shark-kernelshark-v%{version}.tar.gz
|
||||
Source1: %{name}.appdata.xml
|
||||
Patch0: 0001-Do-not-install-trace-cmd-when-only-building-kernelsh.patch
|
||||
|
||||
ExcludeArch: %{ix86} %{arm}
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: desktop-file-utils
|
||||
@ -28,9 +29,13 @@ BuildRequires: pkgconfig(Qt5Core)
|
||||
BuildRequires: libtracecmd-devel
|
||||
BuildRequires: libtraceevent-devel
|
||||
BuildRequires: libtracefs-devel
|
||||
BuildRequires: libtracecmd
|
||||
BuildRequires: trace-cmd
|
||||
BuildRequires: xmlto
|
||||
BuildRequires: make
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: freeglut-devel
|
||||
BuildRequires: gnu-free-sans-fonts
|
||||
Requires: polkit
|
||||
|
||||
|
||||
@ -41,31 +46,29 @@ file. kernelshark can read this file and produce a graph and list
|
||||
view of its data.
|
||||
|
||||
%prep
|
||||
%autosetup -n trace-cmd-%{name}-v%{version}
|
||||
%autosetup -n kernel-shark-%{name}-v%{version}
|
||||
|
||||
%build
|
||||
# MANPAGE_DOCBOOK_XSL define is hack to avoid using locate
|
||||
# -z muldefs to workaround the enforcing multi definition check of gcc10.
|
||||
# and it need to be removed once upstream fixed the variable name
|
||||
# Do not use parallel compile because it makes compiling fail
|
||||
MANPAGE_DOCBOOK_XSL=`rpm -ql docbook-style-xsl | grep manpages/docbook.xsl`
|
||||
CFLAGS="%{optflags} -D_GNU_SOURCE" LDFLAGS="%{build_ldflags} -z muldefs" BUILD_TYPE=Release \
|
||||
make -p V=9999999999 MANPAGE_DOCBOOK_XSL=$MANPAGE_DOCBOOK_XSL \
|
||||
prefix=%{_prefix} libdir=%{_libdir} gui
|
||||
cd build
|
||||
cmake .. -DCMAKE_BUILD_TYPE=Package -D_INSTALL_PREFIX=%{_prefix} -D_LIBDIR=%{_libdir} -DCMAKE_C_FLAGS_PACKAGE="%{optflags}" -DCMAKE_EXE_LINKER_FLAGS="%{build_ldflags}"
|
||||
make
|
||||
|
||||
%install
|
||||
make libdir=%{_libdir} prefix=%{_prefix} V=1 DESTDIR=%{buildroot}/ CFLAGS="%{optflags} -D_GNU_SOURCE" LDFLAGS="%{build_ldflags} -z muldefs " BUILD_TYPE=Release install_gui
|
||||
find %{buildroot}%{_datadir} -type f | xargs chmod u-x,g-x,o-x
|
||||
find %{buildroot}%{_libdir} -type f -iname "*.so" | xargs chmod 0755
|
||||
cd build
|
||||
make libdir=%{_libdir} prefix=%{_prefix} V=1 DESTDIR=%{buildroot}/ install
|
||||
sed -i '/Version/d' %{buildroot}/%{_datadir}/applications/kernelshark.desktop
|
||||
desktop-file-validate %{buildroot}/%{_datadir}/applications/kernelshark.desktop
|
||||
mkdir -p %{buildroot}%{_metainfodir}/
|
||||
cp %{SOURCE1} %{buildroot}%{_metainfodir}/
|
||||
appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/%{name}.appdata.xml
|
||||
|
||||
#Remove all rpath
|
||||
find %{buildroot} -type f -perm 755 -name \*so\* -exec chrpath --delete {} \;
|
||||
chrpath --delete %{buildroot}/%{_bindir}/kernelshark
|
||||
chrpath --delete %{buildroot}/%{_bindir}/kshark-record
|
||||
|
||||
%files
|
||||
%license COPYING
|
||||
%doc COPYING.LIB README
|
||||
%doc README
|
||||
%{_bindir}/kernelshark
|
||||
%{_bindir}/kshark-record
|
||||
%{_bindir}/kshark-su-record
|
||||
@ -76,8 +79,18 @@ appstream-util validate-relax --nonet %{buildroot}%{_metainfodir}/%{name}.appdat
|
||||
%{_datadir}/icons/kernelshark/*
|
||||
%{_datadir}/polkit-1/actions/org.freedesktop.kshark-record.policy
|
||||
%{_metainfodir}/%{name}.appdata.xml
|
||||
%{_libdir}/libkshark-gui.so.2.1.0
|
||||
%{_libdir}/libkshark-plot.so.2.1.0
|
||||
%{_libdir}/libkshark.so
|
||||
%{_libdir}/libkshark.so.2
|
||||
%{_libdir}/libkshark.so.2.1.0
|
||||
%{_libdir}/pkgconfig/libkshark.pc
|
||||
%{_includedir}/%{name}
|
||||
|
||||
%changelog
|
||||
* Fri Apre 15 2022 Zamir SUN <sztsian@gmail.com> - 1:2.1.0-1
|
||||
- Update to 2.1.0
|
||||
|
||||
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 1:1.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (trace-cmd-kernelshark-v1.3.tar.gz) = 1c4a72af2086e0752af3af9101cd064dd7a94398ebb19e2ea5f8bb9026d722da1707f950a348a9da2220ca879ee785a784904c657a127424b89a2fb063ff8681
|
||||
SHA512 (kernel-shark-kernelshark-v2.1.0.tar.gz) = 4b463cf06a919d67fa38ada8221e4702e2fac725d917e7abd12e1d69880ba964881ac549caf90bd7cb22edea4f28d7937494a05f75218f16fe2edcdff7161c3e
|
||||
|
Loading…
Reference in New Issue
Block a user