8bf7e7fde6
* Wed Sep 30 2020 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.9.0-0.rc7.20200930gitfb0155a09b02.21] - Merge ark-patches Resolves: rhbz# Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
61 lines
2.6 KiB
Diff
61 lines
2.6 KiB
Diff
From 746f534a4809e07f427f7d13d10f3a6a9641e5c3 Mon Sep 17 00:00:00 2001
|
|
From: Tony Ambardar <tony.ambardar@gmail.com>
|
|
Date: Sat, 5 Sep 2020 14:48:31 -0700
|
|
Subject: [PATCH] tools/libbpf: Avoid counting local symbols in ABI check
|
|
|
|
Ignore the below, we are actually reverting this patch for now
|
|
|
|
Encountered the following failure building libbpf from kernel 5.8.5 sources
|
|
with GCC 8.4.0 and binutils 2.34: (long paths shortened)
|
|
|
|
Investigation shows _fini and _init are actually local symbols counted
|
|
amongst global ones:
|
|
|
|
$ readelf --dyn-syms --wide libbpf.so|head -10
|
|
|
|
Symbol table '.dynsym' contains 343 entries:
|
|
Num: Value Size Type Bind Vis Ndx Name
|
|
0: 00000000 0 NOTYPE LOCAL DEFAULT UND
|
|
1: 00004098 0 SECTION LOCAL DEFAULT 11
|
|
2: 00004098 8 FUNC LOCAL DEFAULT 11 _init@@LIBBPF_0.0.1
|
|
3: 00023040 8 FUNC LOCAL DEFAULT 14 _fini@@LIBBPF_0.0.1
|
|
4: 00000000 0 OBJECT GLOBAL DEFAULT ABS LIBBPF_0.0.4
|
|
5: 00000000 0 OBJECT GLOBAL DEFAULT ABS LIBBPF_0.0.1
|
|
6: 0000ffa4 8 FUNC GLOBAL DEFAULT 12 bpf_object__find_map_by_offset@@LIBBPF_0.0.1
|
|
|
|
A previous commit filtered global symbols in sharedobjs/libbpf-in.o. Do the
|
|
same with the libbpf.so DSO for consistent comparison.
|
|
|
|
Fixes: 306b267cb3c4 ("libbpf: Verify versioned symbols")
|
|
Signed-off-by: Tony Ambardar <Tony.Ambardar@gmail.com>
|
|
Signed-off-by: Alexei Starovoitov <ast@kernel.org>
|
|
Acked-by: Andrii Nakryiko <andriin@fb.com>
|
|
Link: https://lore.kernel.org/bpf/20200905214831.1565465-1-Tony.Ambardar@gmail.com
|
|
---
|
|
tools/lib/bpf/Makefile | 2 ++
|
|
1 file changed, 2 insertions(+)
|
|
|
|
diff --git a/tools/lib/bpf/Makefile b/tools/lib/bpf/Makefile
|
|
index b78484e7a608..9ae8f4ef0aac 100644
|
|
--- a/tools/lib/bpf/Makefile
|
|
+++ b/tools/lib/bpf/Makefile
|
|
@@ -152,7 +152,6 @@ GLOBAL_SYM_COUNT = $(shell readelf -s --wide $(BPF_IN_SHARED) | \
|
|
awk '/GLOBAL/ && /DEFAULT/ && !/UND/ {print $$NF}' | \
|
|
sort -u | wc -l)
|
|
VERSIONED_SYM_COUNT = $(shell readelf --dyn-syms --wide $(OUTPUT)libbpf.so | \
|
|
- awk '/GLOBAL/ && /DEFAULT/ && !/UND/ {print $$NF}' | \
|
|
grep -Eo '[^ ]+@LIBBPF_' | cut -d@ -f1 | sort -u | wc -l)
|
|
|
|
CMD_TARGETS = $(LIB_TARGET) $(PC_FILE)
|
|
@@ -219,7 +220,6 @@ check_abi: $(OUTPUT)libbpf.so
|
|
awk '/GLOBAL/ && /DEFAULT/ && !/UND/ {print $$NF}'| \
|
|
sort -u > $(OUTPUT)libbpf_global_syms.tmp; \
|
|
readelf --dyn-syms --wide $(OUTPUT)libbpf.so | \
|
|
- awk '/GLOBAL/ && /DEFAULT/ && !/UND/ {print $$NF}'| \
|
|
grep -Eo '[^ ]+@LIBBPF_' | cut -d@ -f1 | \
|
|
sort -u > $(OUTPUT)libbpf_versioned_syms.tmp; \
|
|
diff -u $(OUTPUT)libbpf_global_syms.tmp \
|
|
--
|
|
2.28.0
|
|
|