597 lines
20 KiB
Diff
597 lines
20 KiB
Diff
From patchwork Fri Aug 12 11:07:14 2016
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [v9,1/4] of/serial: move earlycon early_param handling to serial
|
|
From: Aleksey Makarov <aleksey.makarov@linaro.org>
|
|
X-Patchwork-Id: 9276727
|
|
Message-Id: <20160812110717.12351-1-aleksey.makarov@linaro.org>
|
|
To: "Rafael J . Wysocki" <rjw@rjwysocki.net>,
|
|
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
|
Cc: linux-serial@vger.kernel.org, linux-acpi@vger.kernel.org,
|
|
linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
|
|
Aleksey Makarov <aleksey.makarov@linaro.org>,
|
|
Russell King <linux@arm.linux.org.uk>, Len Brown <lenb@kernel.org>,
|
|
Leif Lindholm <leif.lindholm@linaro.org>,
|
|
Graeme Gregory <graeme.gregory@linaro.org>, Al Stone <ahs3@redhat.com>,
|
|
Christopher Covington <cov@codeaurora.org>,
|
|
Yury Norov <ynorov@caviumnetworks.com>,
|
|
Peter Hurley <peter@hurleysoftware.com>,
|
|
Andy Shevchenko <andy.shevchenko@gmail.com>,
|
|
"Zheng, Lv" <lv.zheng@intel.com>, Mark Salter <msalter@redhat.com>,
|
|
Kefeng Wang <wangkefeng.wang@huawei.com>,
|
|
Rob Herring <robh+dt@kernel.org>, Frank Rowand <frowand.list@gmail.com>,
|
|
Jiri Slaby <jslaby@suse.com>, devicetree@vger.kernel.org
|
|
Date: Fri, 12 Aug 2016 14:07:14 +0300
|
|
|
|
From: Leif Lindholm <leif.lindholm@linaro.org>
|
|
|
|
We have multiple "earlycon" early_param handlers - merge the DT one into
|
|
the main earlycon one. It's a cleanup that also will be useful
|
|
to defer setting up DT console until ACPI/DT decision is made.
|
|
|
|
Rename the exported function to avoid clashing with the function from
|
|
arch/microblaze/kernel/prom.c
|
|
|
|
Signed-off-by: Leif Lindholm <leif.lindholm@linaro.org>
|
|
Signed-off-by: Aleksey Makarov <aleksey.makarov@linaro.org>
|
|
Acked-by: Rob Herring <robh@kernel.org>
|
|
Acked-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
|
Reviewed-by: Peter Hurley <peter@hurleysoftware.com>
|
|
Tested-by: Kefeng Wang <wangkefeng.wang@huawei.com>
|
|
---
|
|
drivers/of/fdt.c | 11 +----------
|
|
drivers/tty/serial/earlycon.c | 2 +-
|
|
include/linux/of_fdt.h | 3 +++
|
|
3 files changed, 5 insertions(+), 11 deletions(-)
|
|
|
|
diff --git a/drivers/of/fdt.c b/drivers/of/fdt.c
|
|
index 55f1b83..741cac53 100644
|
|
--- a/drivers/of/fdt.c
|
|
+++ b/drivers/of/fdt.c
|
|
@@ -924,7 +924,7 @@ static inline void early_init_dt_check_for_initrd(unsigned long node)
|
|
|
|
#ifdef CONFIG_SERIAL_EARLYCON
|
|
|
|
-static int __init early_init_dt_scan_chosen_serial(void)
|
|
+int __init early_init_dt_scan_chosen_stdout(void)
|
|
{
|
|
int offset;
|
|
const char *p, *q, *options = NULL;
|
|
@@ -968,15 +968,6 @@ static int __init early_init_dt_scan_chosen_serial(void)
|
|
}
|
|
return -ENODEV;
|
|
}
|
|
-
|
|
-static int __init setup_of_earlycon(char *buf)
|
|
-{
|
|
- if (buf)
|
|
- return 0;
|
|
-
|
|
- return early_init_dt_scan_chosen_serial();
|
|
-}
|
|
-early_param("earlycon", setup_of_earlycon);
|
|
#endif
|
|
|
|
/**
|
|
diff --git a/drivers/tty/serial/earlycon.c b/drivers/tty/serial/earlycon.c
|
|
index 067783f..7aae655 100644
|
|
--- a/drivers/tty/serial/earlycon.c
|
|
+++ b/drivers/tty/serial/earlycon.c
|
|
@@ -209,7 +209,7 @@ static int __init param_setup_earlycon(char *buf)
|
|
* don't generate a warning from parse_early_params() in that case
|
|
*/
|
|
if (!buf || !buf[0])
|
|
- return 0;
|
|
+ return early_init_dt_scan_chosen_stdout();
|
|
|
|
err = setup_earlycon(buf);
|
|
if (err == -ENOENT || err == -EALREADY)
|
|
diff --git a/include/linux/of_fdt.h b/include/linux/of_fdt.h
|
|
index 26c3302..4341f32 100644
|
|
--- a/include/linux/of_fdt.h
|
|
+++ b/include/linux/of_fdt.h
|
|
@@ -14,6 +14,7 @@
|
|
|
|
#include <linux/types.h>
|
|
#include <linux/init.h>
|
|
+#include <linux/errno.h>
|
|
|
|
/* Definitions used by the flattened device tree */
|
|
#define OF_DT_HEADER 0xd00dfeed /* marker */
|
|
@@ -66,6 +67,7 @@ extern int early_init_dt_scan_chosen(unsigned long node, const char *uname,
|
|
int depth, void *data);
|
|
extern int early_init_dt_scan_memory(unsigned long node, const char *uname,
|
|
int depth, void *data);
|
|
+extern int early_init_dt_scan_chosen_stdout(void);
|
|
extern void early_init_fdt_scan_reserved_mem(void);
|
|
extern void early_init_fdt_reserve_self(void);
|
|
extern void early_init_dt_add_memory_arch(u64 base, u64 size);
|
|
@@ -94,6 +96,7 @@ extern void early_get_first_memblock_info(void *, phys_addr_t *);
|
|
extern u64 of_flat_dt_translate_address(unsigned long node);
|
|
extern void of_fdt_limit_memory(int limit);
|
|
#else /* CONFIG_OF_FLATTREE */
|
|
+static inline int early_init_dt_scan_chosen_stdout(void) { return -ENODEV; }
|
|
static inline void early_init_fdt_scan_reserved_mem(void) {}
|
|
static inline void early_init_fdt_reserve_self(void) {}
|
|
static inline const char *of_flat_dt_get_machine_name(void) { return NULL; }
|
|
From patchwork Thu Aug 11 15:31:39 2016
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [v9,2/4] ACPI: parse SPCR and enable matching console
|
|
From: Aleksey Makarov <aleksey.makarov@linaro.org>
|
|
X-Patchwork-Id: 9275443
|
|
Message-Id: <20160811153152.755-3-aleksey.makarov@linaro.org>
|
|
To: "Rafael J . Wysocki" <rjw@rjwysocki.net>,
|
|
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
|
Cc: linux-serial@vger.kernel.org, linux-acpi@vger.kernel.org,
|
|
linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
|
|
Aleksey Makarov <aleksey.makarov@linaro.org>,
|
|
Russell King <linux@arm.linux.org.uk>, Len Brown <lenb@kernel.org>,
|
|
Leif Lindholm <leif.lindholm@linaro.org>,
|
|
Graeme Gregory <graeme.gregory@linaro.org>, Al Stone <ahs3@redhat.com>,
|
|
Christopher Covington <cov@codeaurora.org>,
|
|
Yury Norov <ynorov@caviumnetworks.com>,
|
|
Peter Hurley <peter@hurleysoftware.com>,
|
|
Andy Shevchenko <andy.shevchenko@gmail.com>,
|
|
"Zheng, Lv" <lv.zheng@intel.com>, Mark Salter <msalter@redhat.com>,
|
|
Kefeng Wang <wangkefeng.wang@huawei.com>, Jiri Slaby <jslaby@suse.com>
|
|
Date: Thu, 11 Aug 2016 18:31:39 +0300
|
|
|
|
'ARM Server Base Boot Requiremets' [1] mentions SPCR (Serial Port
|
|
Console Redirection Table) [2] as a mandatory ACPI table that
|
|
specifies the configuration of serial console.
|
|
|
|
Defer initialization of DT earlycon until ACPI/DT decision is made.
|
|
|
|
Parse the ACPI SPCR table, setup earlycon if required,
|
|
enable specified console.
|
|
|
|
Thanks to Peter Hurley for explaining how this should work.
|
|
|
|
[1] http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.den0044a/index.html
|
|
[2] https://msdn.microsoft.com/en-us/library/windows/hardware/dn639132(v=vs.85).aspx
|
|
|
|
Signed-off-by: Aleksey Makarov <aleksey.makarov@linaro.org>
|
|
Reviewed-by: Peter Hurley <peter@hurleysoftware.com>
|
|
Tested-by: Kefeng Wang <wangkefeng.wang@huawei.com>
|
|
Acked-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
|
|
---
|
|
drivers/acpi/Kconfig | 3 ++
|
|
drivers/acpi/Makefile | 1 +
|
|
drivers/acpi/spcr.c | 111 ++++++++++++++++++++++++++++++++++++++++++
|
|
drivers/tty/serial/earlycon.c | 19 +++++++-
|
|
include/linux/acpi.h | 6 +++
|
|
include/linux/serial_core.h | 9 +++-
|
|
6 files changed, 146 insertions(+), 3 deletions(-)
|
|
create mode 100644 drivers/acpi/spcr.c
|
|
|
|
diff --git a/drivers/acpi/Kconfig b/drivers/acpi/Kconfig
|
|
index 6cef2d1..4a269f9 100644
|
|
--- a/drivers/acpi/Kconfig
|
|
+++ b/drivers/acpi/Kconfig
|
|
@@ -77,6 +77,9 @@ config ACPI_DEBUGGER_USER
|
|
|
|
endif
|
|
|
|
+config ACPI_SPCR_TABLE
|
|
+ bool
|
|
+
|
|
config ACPI_SLEEP
|
|
bool
|
|
depends on SUSPEND || HIBERNATION
|
|
diff --git a/drivers/acpi/Makefile b/drivers/acpi/Makefile
|
|
index e5ada78..d799593 100644
|
|
--- a/drivers/acpi/Makefile
|
|
+++ b/drivers/acpi/Makefile
|
|
@@ -81,6 +81,7 @@ obj-$(CONFIG_ACPI_EC_DEBUGFS) += ec_sys.o
|
|
obj-$(CONFIG_ACPI_CUSTOM_METHOD)+= custom_method.o
|
|
obj-$(CONFIG_ACPI_BGRT) += bgrt.o
|
|
obj-$(CONFIG_ACPI_CPPC_LIB) += cppc_acpi.o
|
|
+obj-$(CONFIG_ACPI_SPCR_TABLE) += spcr.o
|
|
obj-$(CONFIG_ACPI_DEBUGGER_USER) += acpi_dbg.o
|
|
|
|
# processor has its own "processor." module_param namespace
|
|
diff --git a/drivers/acpi/spcr.c b/drivers/acpi/spcr.c
|
|
new file mode 100644
|
|
index 0000000..e8d7bc7
|
|
--- /dev/null
|
|
+++ b/drivers/acpi/spcr.c
|
|
@@ -0,0 +1,111 @@
|
|
+/*
|
|
+ * Copyright (c) 2012, Intel Corporation
|
|
+ * Copyright (c) 2015, Red Hat, Inc.
|
|
+ * Copyright (c) 2015, 2016 Linaro Ltd.
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify
|
|
+ * it under the terms of the GNU General Public License version 2 as
|
|
+ * published by the Free Software Foundation.
|
|
+ *
|
|
+ */
|
|
+
|
|
+#define pr_fmt(fmt) "ACPI: SPCR: " fmt
|
|
+
|
|
+#include <linux/acpi.h>
|
|
+#include <linux/console.h>
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/serial_core.h>
|
|
+
|
|
+/**
|
|
+ * parse_spcr() - parse ACPI SPCR table and add preferred console
|
|
+ *
|
|
+ * @earlycon: set up earlycon for the console specified by the table
|
|
+ *
|
|
+ * For the architectures with support for ACPI, CONFIG_ACPI_SPCR_TABLE may be
|
|
+ * defined to parse ACPI SPCR table. As a result of the parsing preferred
|
|
+ * console is registered and if @earlycon is true, earlycon is set up.
|
|
+ *
|
|
+ * When CONFIG_ACPI_SPCR_TABLE is defined, this function should be called
|
|
+ * from arch inintialization code as soon as the DT/ACPI decision is made.
|
|
+ *
|
|
+ */
|
|
+int __init parse_spcr(bool earlycon)
|
|
+{
|
|
+ static char opts[64];
|
|
+ struct acpi_table_spcr *table;
|
|
+ acpi_size table_size;
|
|
+ acpi_status status;
|
|
+ char *uart;
|
|
+ char *iotype;
|
|
+ int baud_rate;
|
|
+ int err;
|
|
+
|
|
+ if (acpi_disabled)
|
|
+ return -ENODEV;
|
|
+
|
|
+ status = acpi_get_table_with_size(ACPI_SIG_SPCR, 0,
|
|
+ (struct acpi_table_header **)&table,
|
|
+ &table_size);
|
|
+
|
|
+ if (ACPI_FAILURE(status))
|
|
+ return -ENOENT;
|
|
+
|
|
+ if (table->header.revision < 2) {
|
|
+ err = -ENOENT;
|
|
+ pr_err("wrong table version\n");
|
|
+ goto done;
|
|
+ }
|
|
+
|
|
+ iotype = table->serial_port.space_id == ACPI_ADR_SPACE_SYSTEM_MEMORY ?
|
|
+ "mmio" : "io";
|
|
+
|
|
+ switch (table->interface_type) {
|
|
+ case ACPI_DBG2_ARM_SBSA_32BIT:
|
|
+ iotype = "mmio32";
|
|
+ /* fall through */
|
|
+ case ACPI_DBG2_ARM_PL011:
|
|
+ case ACPI_DBG2_ARM_SBSA_GENERIC:
|
|
+ case ACPI_DBG2_BCM2835:
|
|
+ uart = "pl011";
|
|
+ break;
|
|
+ case ACPI_DBG2_16550_COMPATIBLE:
|
|
+ case ACPI_DBG2_16550_SUBSET:
|
|
+ uart = "uart";
|
|
+ break;
|
|
+ default:
|
|
+ err = -ENOENT;
|
|
+ goto done;
|
|
+ }
|
|
+
|
|
+ switch (table->baud_rate) {
|
|
+ case 3:
|
|
+ baud_rate = 9600;
|
|
+ break;
|
|
+ case 4:
|
|
+ baud_rate = 19200;
|
|
+ break;
|
|
+ case 6:
|
|
+ baud_rate = 57600;
|
|
+ break;
|
|
+ case 7:
|
|
+ baud_rate = 115200;
|
|
+ break;
|
|
+ default:
|
|
+ err = -ENOENT;
|
|
+ goto done;
|
|
+ }
|
|
+
|
|
+ snprintf(opts, sizeof(opts), "%s,%s,0x%llx,%d", uart, iotype,
|
|
+ table->serial_port.address, baud_rate);
|
|
+
|
|
+ pr_info("console: %s\n", opts);
|
|
+
|
|
+ if (earlycon)
|
|
+ setup_earlycon(opts);
|
|
+
|
|
+ err = add_preferred_console(uart, 0, opts + strlen(uart) + 1);
|
|
+
|
|
+done:
|
|
+ early_acpi_os_unmap_memory((void __iomem *)table, table_size);
|
|
+ return err;
|
|
+}
|
|
diff --git a/drivers/tty/serial/earlycon.c b/drivers/tty/serial/earlycon.c
|
|
index 7aae655..ea00b9f 100644
|
|
--- a/drivers/tty/serial/earlycon.c
|
|
+++ b/drivers/tty/serial/earlycon.c
|
|
@@ -21,6 +21,7 @@
|
|
#include <linux/sizes.h>
|
|
#include <linux/of.h>
|
|
#include <linux/of_fdt.h>
|
|
+#include <linux/acpi.h>
|
|
|
|
#ifdef CONFIG_FIX_EARLYCON_MEM
|
|
#include <asm/fixmap.h>
|
|
@@ -199,6 +200,14 @@ int __init setup_earlycon(char *buf)
|
|
return -ENOENT;
|
|
}
|
|
|
|
+/*
|
|
+ * When CONFIG_ACPI_SPCR_TABLE is defined, "earlycon" without parameters in
|
|
+ * command line does not start DT earlycon immediately, instead it defers
|
|
+ * starting it until DT/ACPI decision is made. At that time if ACPI is enabled
|
|
+ * call parse_spcr(), else call early_init_dt_scan_chosen_stdout()
|
|
+ */
|
|
+bool earlycon_init_is_deferred __initdata;
|
|
+
|
|
/* early_param wrapper for setup_earlycon() */
|
|
static int __init param_setup_earlycon(char *buf)
|
|
{
|
|
@@ -208,8 +217,14 @@ static int __init param_setup_earlycon(char *buf)
|
|
* Just 'earlycon' is a valid param for devicetree earlycons;
|
|
* don't generate a warning from parse_early_params() in that case
|
|
*/
|
|
- if (!buf || !buf[0])
|
|
- return early_init_dt_scan_chosen_stdout();
|
|
+ if (!buf || !buf[0]) {
|
|
+ if (IS_ENABLED(CONFIG_ACPI_SPCR_TABLE)) {
|
|
+ earlycon_init_is_deferred = true;
|
|
+ return 0;
|
|
+ } else {
|
|
+ return early_init_dt_scan_chosen_stdout();
|
|
+ }
|
|
+ }
|
|
|
|
err = setup_earlycon(buf);
|
|
if (err == -ENOENT || err == -EALREADY)
|
|
diff --git a/include/linux/acpi.h b/include/linux/acpi.h
|
|
index 4d8452c..32407e4 100644
|
|
--- a/include/linux/acpi.h
|
|
+++ b/include/linux/acpi.h
|
|
@@ -1074,4 +1074,10 @@ void acpi_table_upgrade(void);
|
|
static inline void acpi_table_upgrade(void) { }
|
|
#endif
|
|
|
|
+#ifdef CONFIG_ACPI_SPCR_TABLE
|
|
+int parse_spcr(bool earlycon);
|
|
+#else
|
|
+static inline int parse_spcr(bool earlycon) { return 0; }
|
|
+#endif
|
|
+
|
|
#endif /*_LINUX_ACPI_H*/
|
|
diff --git a/include/linux/serial_core.h b/include/linux/serial_core.h
|
|
index 2f44e20..04b8cfb 100644
|
|
--- a/include/linux/serial_core.h
|
|
+++ b/include/linux/serial_core.h
|
|
@@ -367,11 +367,18 @@ extern const struct earlycon_id __earlycon_table_end[];
|
|
|
|
#define EARLYCON_DECLARE(_name, fn) OF_EARLYCON_DECLARE(_name, "", fn)
|
|
|
|
-extern int setup_earlycon(char *buf);
|
|
extern int of_setup_earlycon(const struct earlycon_id *match,
|
|
unsigned long node,
|
|
const char *options);
|
|
|
|
+#ifdef CONFIG_SERIAL_EARLYCON
|
|
+extern bool earlycon_init_is_deferred __initdata;
|
|
+extern int setup_earlycon(char *buf);
|
|
+#else
|
|
+static const bool earlycon_init_is_deferred;
|
|
+static inline int setup_earlycon(char *buf) { return 0; }
|
|
+#endif
|
|
+
|
|
struct uart_port *uart_get_console(struct uart_port *ports, int nr,
|
|
struct console *c);
|
|
int uart_parse_earlycon(char *p, unsigned char *iotype, unsigned long *addr,
|
|
From patchwork Thu Aug 11 15:31:40 2016
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [v9,3/4] ARM64: ACPI: enable ACPI_SPCR_TABLE
|
|
From: Aleksey Makarov <aleksey.makarov@linaro.org>
|
|
X-Patchwork-Id: 9275457
|
|
Message-Id: <20160811153152.755-4-aleksey.makarov@linaro.org>
|
|
To: "Rafael J . Wysocki" <rjw@rjwysocki.net>,
|
|
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
|
Cc: linux-serial@vger.kernel.org, linux-acpi@vger.kernel.org,
|
|
linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
|
|
Aleksey Makarov <aleksey.makarov@linaro.org>,
|
|
Russell King <linux@arm.linux.org.uk>, Len Brown <lenb@kernel.org>,
|
|
Leif Lindholm <leif.lindholm@linaro.org>,
|
|
Graeme Gregory <graeme.gregory@linaro.org>, Al Stone <ahs3@redhat.com>,
|
|
Christopher Covington <cov@codeaurora.org>,
|
|
Yury Norov <ynorov@caviumnetworks.com>,
|
|
Peter Hurley <peter@hurleysoftware.com>,
|
|
Andy Shevchenko <andy.shevchenko@gmail.com>,
|
|
"Zheng, Lv" <lv.zheng@intel.com>, Mark Salter <msalter@redhat.com>,
|
|
Kefeng Wang <wangkefeng.wang@huawei.com>,
|
|
Catalin Marinas <catalin.marinas@arm.com>,
|
|
Will Deacon <will.deacon@arm.com>
|
|
Date: Thu, 11 Aug 2016 18:31:40 +0300
|
|
|
|
SBBR mentions SPCR as a mandatory ACPI table. So enable it for ARM64
|
|
|
|
Earlycon should be set up as early as possible. ACPI boot tables are
|
|
mapped in arch/arm64/kernel/acpi.c:acpi_boot_table_init() that
|
|
is called from setup_arch() and that's where we parse SPCR.
|
|
So it has to be opted-in per-arch.
|
|
|
|
When ACPI_SPCR_TABLE is defined initialization of DT earlycon is
|
|
deferred until the DT/ACPI decision is done. Initialize DT earlycon
|
|
if ACPI is disabled.
|
|
|
|
Signed-off-by: Aleksey Makarov <aleksey.makarov@linaro.org>
|
|
Tested-by: Kefeng Wang <wangkefeng.wang@huawei.com>
|
|
---
|
|
arch/arm64/Kconfig | 1 +
|
|
arch/arm64/kernel/acpi.c | 11 ++++++++++-
|
|
2 files changed, 11 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/arch/arm64/Kconfig b/arch/arm64/Kconfig
|
|
index 69c8787..a54dfc0 100644
|
|
--- a/arch/arm64/Kconfig
|
|
+++ b/arch/arm64/Kconfig
|
|
@@ -4,6 +4,7 @@ config ARM64
|
|
select ACPI_GENERIC_GSI if ACPI
|
|
select ACPI_REDUCED_HARDWARE_ONLY if ACPI
|
|
select ACPI_MCFG if ACPI
|
|
+ select ACPI_SPCR_TABLE if ACPI
|
|
select ARCH_HAS_DEVMEM_IS_ALLOWED
|
|
select ARCH_HAS_ACPI_TABLE_UPGRADE if ACPI
|
|
select ARCH_HAS_ATOMIC64_DEC_IF_POSITIVE
|
|
diff --git a/arch/arm64/kernel/acpi.c b/arch/arm64/kernel/acpi.c
|
|
index 3e4f1a4..252a6d9 100644
|
|
--- a/arch/arm64/kernel/acpi.c
|
|
+++ b/arch/arm64/kernel/acpi.c
|
|
@@ -24,6 +24,7 @@
|
|
#include <linux/memblock.h>
|
|
#include <linux/of_fdt.h>
|
|
#include <linux/smp.h>
|
|
+#include <linux/serial_core.h>
|
|
|
|
#include <asm/cputype.h>
|
|
#include <asm/cpu_ops.h>
|
|
@@ -206,7 +207,7 @@ void __init acpi_boot_table_init(void)
|
|
if (param_acpi_off ||
|
|
(!param_acpi_on && !param_acpi_force &&
|
|
of_scan_flat_dt(dt_scan_depth1_nodes, NULL)))
|
|
- return;
|
|
+ goto done;
|
|
|
|
/*
|
|
* ACPI is disabled at this point. Enable it in order to parse
|
|
@@ -226,6 +227,14 @@ void __init acpi_boot_table_init(void)
|
|
if (!param_acpi_force)
|
|
disable_acpi();
|
|
}
|
|
+
|
|
+done:
|
|
+ if (acpi_disabled) {
|
|
+ if (earlycon_init_is_deferred)
|
|
+ early_init_dt_scan_chosen_stdout();
|
|
+ } else {
|
|
+ parse_spcr(earlycon_init_is_deferred);
|
|
+ }
|
|
}
|
|
|
|
#ifdef CONFIG_ACPI_APEI
|
|
From patchwork Mon Aug 15 13:35:03 2016
|
|
Content-Type: text/plain; charset="utf-8"
|
|
MIME-Version: 1.0
|
|
Content-Transfer-Encoding: 7bit
|
|
Subject: [v9,4/4] serial: pl011: add console matching function
|
|
From: Aleksey Makarov <aleksey.makarov@linaro.org>
|
|
X-Patchwork-Id: 9280971
|
|
Message-Id: <20160815133505.15294-1-aleksey.makarov@linaro.org>
|
|
To: "Rafael J . Wysocki" <rjw@rjwysocki.net>,
|
|
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
|
|
Cc: linux-serial@vger.kernel.org, linux-acpi@vger.kernel.org,
|
|
linux-kernel@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
|
|
Aleksey Makarov <aleksey.makarov@linaro.org>,
|
|
Russell King <linux@arm.linux.org.uk>, Len Brown <lenb@kernel.org>,
|
|
Leif Lindholm <leif.lindholm@linaro.org>,
|
|
Graeme Gregory <graeme.gregory@linaro.org>, Al Stone <ahs3@redhat.com>,
|
|
Christopher Covington <cov@codeaurora.org>,
|
|
Yury Norov <ynorov@caviumnetworks.com>,
|
|
Peter Hurley <peter@hurleysoftware.com>,
|
|
Andy Shevchenko <andy.shevchenko@gmail.com>,
|
|
"Zheng, Lv" <lv.zheng@intel.com>, Mark Salter <msalter@redhat.com>,
|
|
Kefeng Wang <wangkefeng.wang@huawei.com>,
|
|
Russell King <linux@armlinux.org.uk>, Jiri Slaby <jslaby@suse.com>
|
|
Date: Mon, 15 Aug 2016 16:35:03 +0300
|
|
|
|
This patch adds function pl011_console_match() that implements
|
|
method match of struct console. It allows to match consoles against
|
|
data specified in a string, for example taken from command line or
|
|
compiled by ACPI SPCR table handler.
|
|
|
|
Signed-off-by: Aleksey Makarov <aleksey.makarov@linaro.org>
|
|
Reviewed-by: Peter Hurley <peter@hurleysoftware.com>
|
|
Acked-by: Russell King <rmk+kernel@armlinux.org.uk>
|
|
---
|
|
drivers/tty/serial/amba-pl011.c | 55 +++++++++++++++++++++++++++++++++++++++++
|
|
1 file changed, 55 insertions(+)
|
|
|
|
diff --git a/drivers/tty/serial/amba-pl011.c b/drivers/tty/serial/amba-pl011.c
|
|
index 8a9e213..2f9af8a 100644
|
|
--- a/drivers/tty/serial/amba-pl011.c
|
|
+++ b/drivers/tty/serial/amba-pl011.c
|
|
@@ -2288,12 +2288,67 @@ static int __init pl011_console_setup(struct console *co, char *options)
|
|
return uart_set_options(&uap->port, co, baud, parity, bits, flow);
|
|
}
|
|
|
|
+/**
|
|
+ * pl011_console_match - non-standard console matching
|
|
+ * @co: registering console
|
|
+ * @name: name from console command line
|
|
+ * @idx: index from console command line
|
|
+ * @options: ptr to option string from console command line
|
|
+ *
|
|
+ * Only attempts to match console command lines of the form:
|
|
+ * console=pl011,mmio|mmio32,<addr>[,<options>]
|
|
+ * console=pl011,0x<addr>[,<options>]
|
|
+ * This form is used to register an initial earlycon boot console and
|
|
+ * replace it with the amba_console at pl011 driver init.
|
|
+ *
|
|
+ * Performs console setup for a match (as required by interface)
|
|
+ * If no <options> are specified, then assume the h/w is already setup.
|
|
+ *
|
|
+ * Returns 0 if console matches; otherwise non-zero to use default matching
|
|
+ */
|
|
+static int __init pl011_console_match(struct console *co, char *name, int idx,
|
|
+ char *options)
|
|
+{
|
|
+ unsigned char iotype;
|
|
+ unsigned long addr;
|
|
+ int i;
|
|
+
|
|
+ if (strcmp(name, "pl011") != 0)
|
|
+ return -ENODEV;
|
|
+
|
|
+ if (uart_parse_earlycon(options, &iotype, &addr, &options))
|
|
+ return -ENODEV;
|
|
+
|
|
+ if (iotype != UPIO_MEM && iotype != UPIO_MEM32)
|
|
+ return -ENODEV;
|
|
+
|
|
+ /* try to match the port specified on the command line */
|
|
+ for (i = 0; i < ARRAY_SIZE(amba_ports); i++) {
|
|
+ struct uart_port *port;
|
|
+
|
|
+ if (!amba_ports[i])
|
|
+ continue;
|
|
+
|
|
+ port = &amba_ports[i]->port;
|
|
+
|
|
+ if (port->mapbase != addr)
|
|
+ continue;
|
|
+
|
|
+ co->index = i;
|
|
+ port->cons = co;
|
|
+ return pl011_console_setup(co, options);
|
|
+ }
|
|
+
|
|
+ return -ENODEV;
|
|
+}
|
|
+
|
|
static struct uart_driver amba_reg;
|
|
static struct console amba_console = {
|
|
.name = "ttyAMA",
|
|
.write = pl011_console_write,
|
|
.device = uart_console_device,
|
|
.setup = pl011_console_setup,
|
|
+ .match = pl011_console_match,
|
|
.flags = CON_PRINTBUFFER,
|
|
.index = -1,
|
|
.data = &amba_reg,
|