From 223ab06d1528b3f4e36275df0ec2fa7b2904f635 Mon Sep 17 00:00:00 2001
From: Josh Boyer <jwboyer@fedoraproject.org>
Date: Mon, 24 Nov 2014 08:25:40 -0500
Subject: [PATCH 1/3] Linux v3.18-rc6

---
 ...tomatically-enforce-module-signature.patch |  2 +-
 ...add-driver-for-the-Goodix-touchpanel.patch |  2 +-
 config-generic                                |  2 +-
 ...ECURE_BOOT_SIG_ENFORCE-depend-on-EFI.patch |  2 +-
 kernel-arm64.patch                            | 17 -------
 kernel.spec                                   | 11 ++---
 ...ove-lockdep-check-in-sched_move_task.patch | 49 -------------------
 sources                                       |  2 +-
 8 files changed, 10 insertions(+), 77 deletions(-)
 delete mode 100644 sched-Remove-lockdep-check-in-sched_move_task.patch

diff --git a/Add-option-to-automatically-enforce-module-signature.patch b/Add-option-to-automatically-enforce-module-signature.patch
index 852cd77ec..d53e1f3f9 100644
--- a/Add-option-to-automatically-enforce-module-signature.patch
+++ b/Add-option-to-automatically-enforce-module-signature.patch
@@ -33,7 +33,7 @@ index 199f453cb4de..ec38acf00b40 100644
  290/040	ALL	edd_mbr_sig_buffer EDD MBR signatures
  2D0/A00	ALL	e820_map	E820 memory map table
 diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
-index ded8a6774ac9..750d32268fb1 100644
+index 41a503c15862..7b8969db8398 100644
 --- a/arch/x86/Kconfig
 +++ b/arch/x86/Kconfig
 @@ -1611,6 +1611,16 @@ config EFI_MIXED
diff --git a/Input-add-driver-for-the-Goodix-touchpanel.patch b/Input-add-driver-for-the-Goodix-touchpanel.patch
index 96ddeceab..807609c50 100644
--- a/Input-add-driver-for-the-Goodix-touchpanel.patch
+++ b/Input-add-driver-for-the-Goodix-touchpanel.patch
@@ -21,7 +21,7 @@ Signed-off-by: Dmitry Torokhov <dmitry.torokhov@gmail.com>
  create mode 100644 drivers/input/touchscreen/goodix.c
 
 diff --git a/MAINTAINERS b/MAINTAINERS
-index c444907ccd69..766848ecf8f5 100644
+index 0ff630de8a6d..e4b643f22336 100644
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
 @@ -4154,6 +4154,12 @@ L:	linux-media@vger.kernel.org
diff --git a/config-generic b/config-generic
index 0bf45a93d..9ab515879 100644
--- a/config-generic
+++ b/config-generic
@@ -4186,7 +4186,7 @@ CONFIG_9P_FSCACHE=y
 CONFIG_9P_FS_POSIX_ACL=y
 CONFIG_9P_FS_SECURITY=y
 CONFIG_FUSE_FS=m
-CONFIG_OVERLAYFS_FS=m
+CONFIG_OVERLAY_FS=m
 # CONFIG_OMFS_FS is not set
 CONFIG_CUSE=m
 # CONFIG_F2FS_FS is not set
diff --git a/efi-Make-EFI_SECURE_BOOT_SIG_ENFORCE-depend-on-EFI.patch b/efi-Make-EFI_SECURE_BOOT_SIG_ENFORCE-depend-on-EFI.patch
index 925c0e0a7..bb2f8524b 100644
--- a/efi-Make-EFI_SECURE_BOOT_SIG_ENFORCE-depend-on-EFI.patch
+++ b/efi-Make-EFI_SECURE_BOOT_SIG_ENFORCE-depend-on-EFI.patch
@@ -11,7 +11,7 @@ Signed-off-by: Josh Boyer <jwboyer@fedoraproject.org>
  1 file changed, 2 insertions(+), 1 deletion(-)
 
 diff --git a/arch/x86/Kconfig b/arch/x86/Kconfig
-index 750d32268fb1..f560653b8c4f 100644
+index 7b8969db8398..d1f4a3d88dfc 100644
 --- a/arch/x86/Kconfig
 +++ b/arch/x86/Kconfig
 @@ -1612,7 +1612,8 @@ config EFI_MIXED
diff --git a/kernel-arm64.patch b/kernel-arm64.patch
index d109fbbf3..6106d5b9c 100644
--- a/kernel-arm64.patch
+++ b/kernel-arm64.patch
@@ -11507,23 +11507,6 @@ index 9ecabfa..9029d59c 100644
  static int xgene_pcie_probe_bridge(struct platform_device *pdev)
  {
  	struct device_node *dn = pdev->dev.of_node;
-@@ -631,10 +798,15 @@ static int xgene_pcie_probe_bridge(struct platform_device *pdev)
- 	if (ret)
- 		return ret;
- 
--	bus = pci_scan_root_bus(&pdev->dev, 0, &xgene_pcie_ops, port, &res);
-+	bus = pci_create_root_bus(&pdev->dev, 0,
-+					&xgene_pcie_ops, port, &res);
- 	if (!bus)
- 		return -ENOMEM;
- 
-+	pci_scan_child_bus(bus);
-+	pci_assign_unassigned_bus_resources(bus);
-+	pci_bus_add_devices(bus);
-+
- 	platform_set_drvdata(pdev, port);
- 	return 0;
- }
 diff --git a/drivers/pnp/resource.c b/drivers/pnp/resource.c
 index 782e822..d952462 100644
 --- a/drivers/pnp/resource.c
diff --git a/kernel.spec b/kernel.spec
index 7acce7119..469902112 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -42,7 +42,7 @@ Summary: The Linux kernel
 # For non-released -rc kernels, this will be appended after the rcX and
 # gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
 #
-%global baserelease 3
+%global baserelease 1
 %global fedora_build %{baserelease}
 
 # base_sublevel is the kernel version we're starting with and patching
@@ -67,7 +67,7 @@ Summary: The Linux kernel
 # The next upstream release sublevel (base_sublevel+1)
 %define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
 # The rc snapshot level
-%define rcrev 5
+%define rcrev 6
 # The git snapshot level
 %define gitrev 0
 # Set rpm version accordingly
@@ -609,8 +609,6 @@ Patch26059: i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
 
 Patch26064: Input-add-driver-for-the-Goodix-touchpanel.patch
 
-Patch26065: sched-Remove-lockdep-check-in-sched_move_task.patch
-
 #rhbz 1135338
 Patch26070: HID-add-support-for-MS-Surface-Pro-3-Type-Cover.patch
 
@@ -1332,8 +1330,6 @@ ApplyPatch i8042-Add-notimeout-quirk-for-Fujitsu-Lifebook-A544-.patch
 
 ApplyPatch Input-add-driver-for-the-Goodix-touchpanel.patch
 
-ApplyPatch sched-Remove-lockdep-check-in-sched_move_task.patch
-
 #rhbz 1135338
 ApplyPatch HID-add-support-for-MS-Surface-Pro-3-Type-Cover.patch
 
@@ -2205,6 +2201,9 @@ fi
 #                                    ||----w |
 #                                    ||     ||
 %changelog
+* Mon Nov 24 2014 Josh Boyer <jwboyer@fedoraproject.org>
+- Linux v3.18-rc6
+
 * Fri Nov 21 2014 Josh Boyer <jwboyer@fedoraproject.org>
 - Move TPM drivers to main kernel package (rhbz 1164937)
 
diff --git a/sched-Remove-lockdep-check-in-sched_move_task.patch b/sched-Remove-lockdep-check-in-sched_move_task.patch
deleted file mode 100644
index b740be10d..000000000
--- a/sched-Remove-lockdep-check-in-sched_move_task.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From: Kirill Tkhai <ktkhai@parallels.com>
-Date: Tue, 28 Oct 2014 08:24:34 +0300
-Subject: [PATCH] sched: Remove lockdep check in sched_move_task()
-
-sched_move_task() is the only interface to change sched_task_group:
-cpu_cgrp_subsys methods and autogroup_move_group() use it.
-
-Everything is synchronized by task_rq_lock(), so cpu_cgroup_attach()
-is ordered with other users of sched_move_task(). This means we do no
-need RCU here: if we've dereferenced a tg here, the .attach method
-hasn't been called for it yet.
-
-Thus, we should pass "true" to task_css_check() to silence lockdep
-warnings.
-
-Fixes: eeb61e53ea19 ("sched: Fix race between task_group and sched_task_group")
-Reported-by: Oleg Nesterov <oleg@redhat.com>
-Reported-by: Fengguang Wu <fengguang.wu@intel.com>
-Signed-off-by: Kirill Tkhai <ktkhai@parallels.com>
-Signed-off-by: Peter Zijlstra (Intel) <peterz@infradead.org>
-Cc: Linus Torvalds <torvalds@linux-foundation.org>
-Link: http://lkml.kernel.org/r/1414473874.8574.2.camel@tkhai
-Signed-off-by: Ingo Molnar <mingo@kernel.org>
----
- kernel/sched/core.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/kernel/sched/core.c b/kernel/sched/core.c
-index 240157c13ddc..6841fb46eb07 100644
---- a/kernel/sched/core.c
-+++ b/kernel/sched/core.c
-@@ -7444,8 +7444,12 @@ void sched_move_task(struct task_struct *tsk)
- 	if (unlikely(running))
- 		put_prev_task(rq, tsk);
- 
--	tg = container_of(task_css_check(tsk, cpu_cgrp_id,
--				lockdep_is_held(&tsk->sighand->siglock)),
-+	/*
-+	 * All callers are synchronized by task_rq_lock(); we do not use RCU
-+	 * which is pointless here. Thus, we pass "true" to task_css_check()
-+	 * to prevent lockdep warnings.
-+	 */
-+	tg = container_of(task_css_check(tsk, cpu_cgrp_id, true),
- 			  struct task_group, css);
- 	tg = autogroup_task_group(tsk, tg);
- 	tsk->sched_task_group = tg;
--- 
-1.9.3
-
diff --git a/sources b/sources
index 105408a10..14b27178e 100644
--- a/sources
+++ b/sources
@@ -1,3 +1,3 @@
 fb30d0f29214d75cddd2faa94f73d5cf  linux-3.17.tar.xz
 159e969cbc27201d8e2fa0f609dc722f  perf-man-3.17.tar.gz
-852725a732b5e21318324296f1940dfd  patch-3.18-rc5.xz
+fcfb06d0d29d6f51d79bcd4c2c4e622c  patch-3.18-rc6.xz

From 7c8fdb7e5e94bdb382821333477effc093f85dc7 Mon Sep 17 00:00:00 2001
From: Josh Boyer <jwboyer@fedoraproject.org>
Date: Mon, 24 Nov 2014 08:28:29 -0500
Subject: [PATCH 2/3] Add quirk for Laser Mouse 6000 (rhbz 1165206)

---
 kernel.spec                                   |  7 +++++
 ...eset-resume-quirk-for-MS-Wireless-La.patch | 31 +++++++++++++++++++
 2 files changed, 38 insertions(+)
 create mode 100644 usb-quirks-Add-reset-resume-quirk-for-MS-Wireless-La.patch

diff --git a/kernel.spec b/kernel.spec
index 469902112..2710406ca 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -612,6 +612,9 @@ Patch26064: Input-add-driver-for-the-Goodix-touchpanel.patch
 #rhbz 1135338
 Patch26070: HID-add-support-for-MS-Surface-Pro-3-Type-Cover.patch
 
+#rhbz 1165206
+Patch26071: usb-quirks-Add-reset-resume-quirk-for-MS-Wireless-La.patch
+
 # git clone ssh://git.fedorahosted.org/git/kernel-arm64.git, git diff master...devel
 Patch30000: kernel-arm64.patch
 
@@ -1333,6 +1336,9 @@ ApplyPatch Input-add-driver-for-the-Goodix-touchpanel.patch
 #rhbz 1135338
 ApplyPatch HID-add-support-for-MS-Surface-Pro-3-Type-Cover.patch
 
+#rhbz 1165206
+ApplyPatch usb-quirks-Add-reset-resume-quirk-for-MS-Wireless-La.patch
+
 %if 0%{?aarch64patches}
 ApplyPatch kernel-arm64.patch
 %ifnarch aarch64 # this is stupid, but i want to notice before secondary koji does.
@@ -2203,6 +2209,7 @@ fi
 %changelog
 * Mon Nov 24 2014 Josh Boyer <jwboyer@fedoraproject.org>
 - Linux v3.18-rc6
+- Add quirk for Laser Mouse 6000 (rhbz 1165206)
 
 * Fri Nov 21 2014 Josh Boyer <jwboyer@fedoraproject.org>
 - Move TPM drivers to main kernel package (rhbz 1164937)
diff --git a/usb-quirks-Add-reset-resume-quirk-for-MS-Wireless-La.patch b/usb-quirks-Add-reset-resume-quirk-for-MS-Wireless-La.patch
new file mode 100644
index 000000000..e590df222
--- /dev/null
+++ b/usb-quirks-Add-reset-resume-quirk-for-MS-Wireless-La.patch
@@ -0,0 +1,31 @@
+From: Hans de Goede <hdegoede@redhat.com>
+Date: Thu, 20 Nov 2014 15:16:01 +0100
+Subject: [PATCH] usb-quirks: Add reset-resume quirk for MS Wireless Laser
+ Mouse 6000
+
+This wireless mouse receiver needs a reset-resume quirk to properly come
+out of reset.
+
+BugLink: https://bugzilla.redhat.com/show_bug.cgi?id=1165206
+Signed-off-by: Hans de Goede <hdegoede@redhat.com>
+---
+ drivers/usb/core/quirks.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/drivers/usb/core/quirks.c b/drivers/usb/core/quirks.c
+index 39b4081b632d..96fafed92b76 100644
+--- a/drivers/usb/core/quirks.c
++++ b/drivers/usb/core/quirks.c
+@@ -44,6 +44,9 @@ static const struct usb_device_id usb_quirk_list[] = {
+ 	/* Creative SB Audigy 2 NX */
+ 	{ USB_DEVICE(0x041e, 0x3020), .driver_info = USB_QUIRK_RESET_RESUME },
+ 
++	/* Microsoft Wireless Laser Mouse 6000 Receiver */
++	{ USB_DEVICE(0x045e, 0x00e1), .driver_info = USB_QUIRK_RESET_RESUME },
++
+ 	/* Microsoft LifeCam-VX700 v2.0 */
+ 	{ USB_DEVICE(0x045e, 0x0770), .driver_info = USB_QUIRK_RESET_RESUME },
+ 
+-- 
+1.9.3
+

From 258c0838a1f71d15e569ab302030f4837be9cb19 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
Date: Mon, 24 Nov 2014 18:33:15 +0100
Subject: [PATCH 3/3] do not disable PPP networking on s390

---
 config-s390x | 1 -
 1 file changed, 1 deletion(-)

diff --git a/config-s390x b/config-s390x
index a76cad62b..9534f51be 100644
--- a/config-s390x
+++ b/config-s390x
@@ -83,7 +83,6 @@ CONFIG_TN3270_FS=m
 #
 CONFIG_S390_TAPE_34XX=m
 
-# CONFIG_PPP is not set
 # CONFIG_SLIP is not set
 
 #