From e927dd559134b84ce614391ce0600af8b08f4d97 Mon Sep 17 00:00:00 2001
From: Josh Boyer <jwboyer@redhat.com>
Date: Tue, 11 Sep 2012 09:04:07 -0400
Subject: [PATCH] Drop old Xen EC2 patch.  It is no longer needed per Matt
 Wilson

---
 fix_xen_guest_on_old_EC2.patch | 34 ----------------------------------
 kernel.spec                    |  7 ++++---
 2 files changed, 4 insertions(+), 37 deletions(-)
 delete mode 100644 fix_xen_guest_on_old_EC2.patch

diff --git a/fix_xen_guest_on_old_EC2.patch b/fix_xen_guest_on_old_EC2.patch
deleted file mode 100644
index e86200295..000000000
--- a/fix_xen_guest_on_old_EC2.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-
-Legacy hypervisors (RHEL 5.0 and RHEL 5.1) do not handle guest writes to
-cr4 gracefully. If a guest attempts to write a bit of cr4 that is
-unsupported, then the HV is so offended it crashes the domain. While
-later guest kernels (such as RHEL6) don't assume the HV supports all
-features, they do expect nicer responses. That assumption introduced
-code that probes whether or not xsave is supported early in the boot. So
-now when attempting to boot a RHEL6 guest on RHEL5.0 or RHEL5.1 an early
-crash will occur.
-
-This patch is quite obviously an undesirable hack. The real fix for this
-problem should be in the HV, and is, in later HVs. However, to support
-running on old HVs, RHEL6 can take this small change. No impact will
-occur for running on any RHEL HV (not even RHEL 5.5 supports xsave).
-There is only potential for guest performance loss on upstream Xen.
-
----
- arch/x86/xen/enlighten.c |    1 +
- 1 files changed, 1 insertions(+), 0 deletions(-)
-
-diff --git a/arch/x86/xen/enlighten.c b/arch/x86/xen/enlighten.c
-index 52f8e19..6db3d67 100644
---- a/arch/x86/xen/enlighten.c
-+++ b/arch/x86/xen/enlighten.c
-@@ -802,6 +802,7 @@ static void xen_write_cr4(unsigned long cr4)
- {
- 	cr4 &= ~X86_CR4_PGE;
- 	cr4 &= ~X86_CR4_PSE;
-+	cr4 &= ~X86_CR4_OSXSAVE;
- 
- 	native_write_cr4(cr4);
- }
--- 
-1.6.6.1
diff --git a/kernel.spec b/kernel.spec
index 33ceef277..3159f8e71 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -62,7 +62,7 @@ Summary: The Linux kernel
 # For non-released -rc kernels, this will be appended after the rcX and
 # gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
 #
-%global baserelease 1
+%global baserelease 2
 %global fedora_build %{baserelease}
 
 # base_sublevel is the kernel version we're starting with and patching
@@ -687,7 +687,6 @@ Patch1000: secure-boot-20120809.patch
 Patch1100: handle-efi-roms.patch
 
 # virt + ksm patches
-Patch1555: fix_xen_guest_on_old_EC2.patch
 
 # DRM
 #atch1700: drm-edid-try-harder-to-fix-up-broken-headers.patch
@@ -1403,7 +1402,6 @@ ApplyPatch secure-boot-20120809.patch
 ApplyPatch handle-efi-roms.patch
 
 # Assorted Virt Fixes
-ApplyPatch fix_xen_guest_on_old_EC2.patch
 
 # DRM core
 #ApplyPatch drm-edid-try-harder-to-fix-up-broken-headers.patch
@@ -2323,6 +2321,9 @@ fi
 #                 ||----w |
 #                 ||     ||
 %changelog
+* Tue Sep 11 2012 Josh Boyer <jwboyer@redhat.com> - 3.6.0-0.rc5.git1.2
+- Drop old Xen EC2 patch.  It is no longer needed per Matt Wilson
+
 * Tue Sep 11 2012 Josh Boyer <jwboyer@redhat.com> - 3.6.0-0.rc5.git1.1
 - Linux v3.6-rc5-32-g1a95620
 - Reenable debugging options.