From acf0fc7b147a8873f4bd61b47d3073e03e692532 Mon Sep 17 00:00:00 2001
From: Dave Jones <davej@redhat.com>
Date: Sat, 27 Aug 2011 13:27:38 -0400
Subject: [PATCH] NX emulation fixes

Fix get_gate_vma usage in i386 NX emulation
Fix up dependancy on the dropped randomization patch.
---
 kernel.spec                       | 4 ++++
 linux-2.6-i386-nx-emulation.patch | 4 ++--
 2 files changed, 6 insertions(+), 2 deletions(-)

diff --git a/kernel.spec b/kernel.spec
index 30afcb918..02e35f40b 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -2033,6 +2033,10 @@ fi
 #                 ||----w |
 #                 ||     ||
 %changelog
+* Sat Aug 27 2011 Dave Jones <davej@redhat.com>
+- Fix get_gate_vma usage in i386 NX emulation
+  Fix up dependancy on the dropped randomization patch.
+
 * Sat Aug 27 2011 Josh Boyer <jwboyer@redhat.com>
 - Linux 3.1-rc3-git6
 
diff --git a/linux-2.6-i386-nx-emulation.patch b/linux-2.6-i386-nx-emulation.patch
index 856b9b95a..33a343747 100644
--- a/linux-2.6-i386-nx-emulation.patch
+++ b/linux-2.6-i386-nx-emulation.patch
@@ -249,7 +249,7 @@
 +		for (vma = current->mm->mmap; vma; vma = vma->vm_next)
 +			if ((vma->vm_flags & VM_EXEC) && (vma->vm_end > limit))
 +				limit = vma->vm_end;
-+		vma = get_gate_vma(current);
++		vma = get_gate_vma(current->mm);
 +		if (vma && (vma->vm_flags & VM_EXEC) && (vma->vm_end > limit))
 +			limit = vma->vm_end;
 +		spin_unlock(&current->mm->page_table_lock);
@@ -606,7 +606,7 @@ index 57d1868..29c0c35 100644
 +	/* in the case of NX emulation, shove the brk segment way out of the
 +	   way of the exec randomization area, since it can collide with
 +	   future allocations if not. */
-+	if ( (mm->get_unmapped_exec_area == arch_get_unmapped_exec_area) &&
++	if ( (mm->get_unmapped_exec == arch_get_unmapped_exec_area) &&
 +	     (mm->brk < 0x08000000) ) {
 +		bump = (TASK_SIZE/6);
 +	}