From 5f1f3d0921078ca95f08c4030671c2a884bd5847 Mon Sep 17 00:00:00 2001
From: Josh Boyer <jwboyer@redhat.com>
Date: Thu, 6 Mar 2014 09:22:21 -0500
Subject: [PATCH] Fix bogus WARN in iwlwifi (rhbz 1071998)

---
 bug-1071998.patch | 21 +++++++++++++++++++++
 kernel.spec       |  9 +++++++++
 2 files changed, 30 insertions(+)
 create mode 100644 bug-1071998.patch

diff --git a/bug-1071998.patch b/bug-1071998.patch
new file mode 100644
index 000000000..d1b438567
--- /dev/null
+++ b/bug-1071998.patch
@@ -0,0 +1,21 @@
+@@ -, +, @@ 
+---
+ drivers/net/wireless/iwlwifi/mvm/coex.c | 7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+--- a/drivers/net/wireless/iwlwifi/mvm/bt-coex.c	
++++ a/drivers/net/wireless/iwlwifi/mvm/bt-coex.c	
+@@ -1119,8 +1119,11 @@ void iwl_mvm_bt_rssi_event(struct iwl_mvm *mvm, struct ieee80211_vif *vif,
+ 
+ 	lockdep_assert_held(&mvm->mutex);
+ 
+-	/* Rssi update while not associated ?! */
+-	if (WARN_ON_ONCE(mvmvif->ap_sta_id == IWL_MVM_STATION_COUNT))
++	/*
++	 * Rssi update while not associated - can happen since the statistics
++	 * are handled asynchronously
++	 */
++	if (mvmvif->ap_sta_id == IWL_MVM_STATION_COUNT)
+ 		return;
+ 
+ 	/* No BT - reports should be disabled */
+-- 
diff --git a/kernel.spec b/kernel.spec
index 75245c584..e77090ed0 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -631,6 +631,9 @@ Patch25002: cifs-mask-off-top-byte-in-get_rfc1002_length.patch
 #CVE-2014-0102 rhbz 1071396
 Patch25026: keyring-fix.patch
 
+#rhbz 1071998
+Patch25034: bug-1071998.patch
+
 # END OF PATCH DEFINITIONS
 
 %endif
@@ -1281,6 +1284,9 @@ ApplyPatch cifs-mask-off-top-byte-in-get_rfc1002_length.patch
 #CVE-2014-0102 rhbz 1071396
 ApplyPatch keyring-fix.patch
 
+#rhbz 1071998
+ApplyPatch bug-1071998.patch
+
 # END OF PATCH APPLICATIONS
 
 %endif
@@ -2060,6 +2066,9 @@ fi
 #                                    ||----w |
 #                                    ||     ||
 %changelog
+* Thu Mar 06 2014 Josh Boyer <jwboyer@fedoraproject.org>
+- Fix bogus WARN in iwlwifi (rhbz 1071998)
+
 * Wed Mar 05 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.14.0-0.rc5.git2.1
 - Linux v3.14-rc5-185-gc3bebc7