From 5d8b3e4c0d601cf4956ff1e4a7f9a2fa8f3e4343 Mon Sep 17 00:00:00 2001
From: Rado Vrbovsky <rvrbovsk@redhat.com>
Date: Thu, 12 Sep 2024 09:49:38 +0000
Subject: [PATCH] kernel-5.14.0-508.el9

* Thu Sep 12 2024 Rado Vrbovsky <rvrbovsk@redhat.com> [5.14.0-508.el9]
- usb: xhci: prevent potential failure in handle_tx_event() for Transfer events without TRB (Desnes Nunes) [RHEL-52378] {CVE-2024-42226}
- redhat: set defaults for RHEL 9.5 (Lucas Zampieri)
- redhat/configs: Make CONFIG_REGULATOR_GPIO built-in (Luiz Capitulino) [RHEL-21095]
- redhat/configs: enable a bunch of regulators (Luiz Capitulino) [RHEL-21095]
- md-cluster: fix no recovery job when adding/re-adding a disk (Nigel Croxon) [RHEL-46615]
- md-cluster: fix hanging issue while a new disk adding (Nigel Croxon) [RHEL-46615]
- md/raid5: recheck if reshape has finished with device_lock held (Nigel Croxon) [RHEL-46615]
- md: Don't wait for MD_RECOVERY_NEEDED for HOT_REMOVE_DISK ioctl (Nigel Croxon) [RHEL-46615]
- md-cluster: Constify struct md_cluster_operations (Nigel Croxon) [RHEL-46615]
- md/raid5: fix spares errors about rcu usage (Nigel Croxon) [RHEL-46615]
- md: pass in max_sectors for pers->sync_request() (Nigel Croxon) [RHEL-46615]
- md: factor out helpers for different sync_action in md_do_sync() (Nigel Croxon) [RHEL-46615]
- md: replace last_sync_action with new enum type (Nigel Croxon) [RHEL-46615]
- md: use new helpers in md_do_sync() (Nigel Croxon) [RHEL-46615]
- md: don't fail action_store() if sync_thread is not registered (Nigel Croxon) [RHEL-46615]
- md: remove parameter check_seq for stop_sync_thread() (Nigel Croxon) [RHEL-46615]
- md: replace sysfs api sync_action with new helpers (Nigel Croxon) [RHEL-46615]
- md: factor out helper to start reshape from action_store() (Nigel Croxon) [RHEL-46615]
- md: add new helpers for sync_action (Nigel Croxon) [RHEL-46615]
- md: add a new enum type sync_action (Nigel Croxon) [RHEL-46615]
- md: rearrange recovery_flags (Nigel Croxon) [RHEL-46615]
- md/md-bitmap: fix writing non bitmap pages (Nigel Croxon) [RHEL-46615]
- md: make md_flush_request() more readable (Nigel Croxon) [RHEL-46615]
- md: change the return value type of md_write_start to void (Nigel Croxon) [RHEL-46615]
- md: do not delete safemode_timer in mddev_suspend (Nigel Croxon) [RHEL-46615]
- lib: objagg: Fix general protection fault (Waiman Long) [RHEL-54790 RHEL-54793] {CVE-2024-43846}
- Revert "x86/topology: Switch over to GENERIC_CPU_DEVICES" (David Arcari) [RHEL-58031]
- Revert "x86/topology: use weak version of arch_unregister_cpu()" (David Arcari) [RHEL-58031]
- Revert "x86/topology: convert to use arch_cpu_is_hotpluggable()" (David Arcari) [RHEL-58031]
- Revert "x86/cpu: Move leftover contents of topology.c to setup.c" (David Arcari) [RHEL-58031]
- x86/resctrl: Remove redundant variable in mbm_config_write_domain() (David Arcari) [RHEL-57701]
- x86/resctrl: Read supported bandwidth sources from CPUID (David Arcari) [RHEL-57701]
- x86/resctrl: Remove hard-coded memory bandwidth limit (David Arcari) [RHEL-57701]
Resolves: RHEL-21095, RHEL-46615, RHEL-52378, RHEL-54790, RHEL-54793, RHEL-57701, RHEL-58031

Signed-off-by: Rado Vrbovsky <rvrbovsk@redhat.com>
---
 Makefile.rhelver                     |  2 +-
 kernel-aarch64-64k-debug-rhel.config | 10 +++----
 kernel-aarch64-64k-rhel.config       | 10 +++----
 kernel-aarch64-debug-rhel.config     | 10 +++----
 kernel-aarch64-rhel.config           | 10 +++----
 kernel-aarch64-rt-debug-rhel.config  | 10 +++----
 kernel-aarch64-rt-rhel.config        | 10 +++----
 kernel.changelog                     | 41 ++++++++++++++++++++++++++
 kernel.spec                          | 43 +++++++++++++++++++++++++---
 sources                              |  6 ++--
 10 files changed, 114 insertions(+), 38 deletions(-)

diff --git a/Makefile.rhelver b/Makefile.rhelver
index 361ba2a92..586f0e715 100644
--- a/Makefile.rhelver
+++ b/Makefile.rhelver
@@ -12,7 +12,7 @@ RHEL_MINOR = 6
 #
 # Use this spot to avoid future merge conflicts.
 # Do not trim this comment.
-RHEL_RELEASE = 507
+RHEL_RELEASE = 508
 
 #
 # ZSTREAM
diff --git a/kernel-aarch64-64k-debug-rhel.config b/kernel-aarch64-64k-debug-rhel.config
index f1c51dc63..d3777fa40 100644
--- a/kernel-aarch64-64k-debug-rhel.config
+++ b/kernel-aarch64-64k-debug-rhel.config
@@ -4730,7 +4730,7 @@ CONFIG_REGMAP_KUNIT=m
 # CONFIG_REGULATOR_ACT8865 is not set
 # CONFIG_REGULATOR_AD5398 is not set
 # CONFIG_REGULATOR_ANATOP is not set
-# CONFIG_REGULATOR_ARM_SCMI is not set
+CONFIG_REGULATOR_ARM_SCMI=m
 # CONFIG_REGULATOR_AT803X_PHY is not set
 CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_DA9121 is not set
@@ -4740,7 +4740,7 @@ CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_FAN53555 is not set
 # CONFIG_REGULATOR_FAN53880 is not set
 CONFIG_REGULATOR_FIXED_VOLTAGE=y
-CONFIG_REGULATOR_GPIO=m
+CONFIG_REGULATOR_GPIO=y
 # CONFIG_REGULATOR_ISL6271A is not set
 # CONFIG_REGULATOR_ISL9305 is not set
 # CONFIG_REGULATOR_LP3971 is not set
@@ -4767,13 +4767,13 @@ CONFIG_REGULATOR_MAX77686=m
 # CONFIG_REGULATOR_MP886X is not set
 # CONFIG_REGULATOR_MPQ7920 is not set
 # CONFIG_REGULATOR_MT6311 is not set
-# CONFIG_REGULATOR_PCA9450 is not set
-# CONFIG_REGULATOR_PF8X00 is not set
+CONFIG_REGULATOR_PCA9450=m
+CONFIG_REGULATOR_PF8X00=m
 CONFIG_REGULATOR_PFUZE100=m
 # CONFIG_REGULATOR_PV88060 is not set
 # CONFIG_REGULATOR_PV88080 is not set
 # CONFIG_REGULATOR_PV88090 is not set
-# CONFIG_REGULATOR_PWM is not set
+CONFIG_REGULATOR_PWM=y
 # CONFIG_REGULATOR_RASPBERRYPI_TOUCHSCREEN_ATTINY is not set
 # CONFIG_REGULATOR_RT4801 is not set
 # CONFIG_REGULATOR_RT4803 is not set
diff --git a/kernel-aarch64-64k-rhel.config b/kernel-aarch64-64k-rhel.config
index f8081aa0b..817d96808 100644
--- a/kernel-aarch64-64k-rhel.config
+++ b/kernel-aarch64-64k-rhel.config
@@ -4708,7 +4708,7 @@ CONFIG_REGMAP_KUNIT=m
 # CONFIG_REGULATOR_ACT8865 is not set
 # CONFIG_REGULATOR_AD5398 is not set
 # CONFIG_REGULATOR_ANATOP is not set
-# CONFIG_REGULATOR_ARM_SCMI is not set
+CONFIG_REGULATOR_ARM_SCMI=m
 # CONFIG_REGULATOR_AT803X_PHY is not set
 CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_DA9121 is not set
@@ -4718,7 +4718,7 @@ CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_FAN53555 is not set
 # CONFIG_REGULATOR_FAN53880 is not set
 CONFIG_REGULATOR_FIXED_VOLTAGE=y
-CONFIG_REGULATOR_GPIO=m
+CONFIG_REGULATOR_GPIO=y
 # CONFIG_REGULATOR_ISL6271A is not set
 # CONFIG_REGULATOR_ISL9305 is not set
 # CONFIG_REGULATOR_LP3971 is not set
@@ -4745,13 +4745,13 @@ CONFIG_REGULATOR_MAX77686=m
 # CONFIG_REGULATOR_MP886X is not set
 # CONFIG_REGULATOR_MPQ7920 is not set
 # CONFIG_REGULATOR_MT6311 is not set
-# CONFIG_REGULATOR_PCA9450 is not set
-# CONFIG_REGULATOR_PF8X00 is not set
+CONFIG_REGULATOR_PCA9450=m
+CONFIG_REGULATOR_PF8X00=m
 CONFIG_REGULATOR_PFUZE100=m
 # CONFIG_REGULATOR_PV88060 is not set
 # CONFIG_REGULATOR_PV88080 is not set
 # CONFIG_REGULATOR_PV88090 is not set
-# CONFIG_REGULATOR_PWM is not set
+CONFIG_REGULATOR_PWM=y
 # CONFIG_REGULATOR_RASPBERRYPI_TOUCHSCREEN_ATTINY is not set
 # CONFIG_REGULATOR_RT4801 is not set
 # CONFIG_REGULATOR_RT4803 is not set
diff --git a/kernel-aarch64-debug-rhel.config b/kernel-aarch64-debug-rhel.config
index 7e628b75b..3772e8505 100644
--- a/kernel-aarch64-debug-rhel.config
+++ b/kernel-aarch64-debug-rhel.config
@@ -4727,7 +4727,7 @@ CONFIG_REGMAP_KUNIT=m
 # CONFIG_REGULATOR_ACT8865 is not set
 # CONFIG_REGULATOR_AD5398 is not set
 # CONFIG_REGULATOR_ANATOP is not set
-# CONFIG_REGULATOR_ARM_SCMI is not set
+CONFIG_REGULATOR_ARM_SCMI=m
 # CONFIG_REGULATOR_AT803X_PHY is not set
 CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_DA9121 is not set
@@ -4737,7 +4737,7 @@ CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_FAN53555 is not set
 # CONFIG_REGULATOR_FAN53880 is not set
 CONFIG_REGULATOR_FIXED_VOLTAGE=y
-CONFIG_REGULATOR_GPIO=m
+CONFIG_REGULATOR_GPIO=y
 # CONFIG_REGULATOR_ISL6271A is not set
 # CONFIG_REGULATOR_ISL9305 is not set
 # CONFIG_REGULATOR_LP3971 is not set
@@ -4764,13 +4764,13 @@ CONFIG_REGULATOR_MAX77686=m
 # CONFIG_REGULATOR_MP886X is not set
 # CONFIG_REGULATOR_MPQ7920 is not set
 # CONFIG_REGULATOR_MT6311 is not set
-# CONFIG_REGULATOR_PCA9450 is not set
-# CONFIG_REGULATOR_PF8X00 is not set
+CONFIG_REGULATOR_PCA9450=m
+CONFIG_REGULATOR_PF8X00=m
 CONFIG_REGULATOR_PFUZE100=m
 # CONFIG_REGULATOR_PV88060 is not set
 # CONFIG_REGULATOR_PV88080 is not set
 # CONFIG_REGULATOR_PV88090 is not set
-# CONFIG_REGULATOR_PWM is not set
+CONFIG_REGULATOR_PWM=y
 # CONFIG_REGULATOR_RASPBERRYPI_TOUCHSCREEN_ATTINY is not set
 # CONFIG_REGULATOR_RT4801 is not set
 # CONFIG_REGULATOR_RT4803 is not set
diff --git a/kernel-aarch64-rhel.config b/kernel-aarch64-rhel.config
index c6d378a61..025871c33 100644
--- a/kernel-aarch64-rhel.config
+++ b/kernel-aarch64-rhel.config
@@ -4705,7 +4705,7 @@ CONFIG_REGMAP_KUNIT=m
 # CONFIG_REGULATOR_ACT8865 is not set
 # CONFIG_REGULATOR_AD5398 is not set
 # CONFIG_REGULATOR_ANATOP is not set
-# CONFIG_REGULATOR_ARM_SCMI is not set
+CONFIG_REGULATOR_ARM_SCMI=m
 # CONFIG_REGULATOR_AT803X_PHY is not set
 CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_DA9121 is not set
@@ -4715,7 +4715,7 @@ CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_FAN53555 is not set
 # CONFIG_REGULATOR_FAN53880 is not set
 CONFIG_REGULATOR_FIXED_VOLTAGE=y
-CONFIG_REGULATOR_GPIO=m
+CONFIG_REGULATOR_GPIO=y
 # CONFIG_REGULATOR_ISL6271A is not set
 # CONFIG_REGULATOR_ISL9305 is not set
 # CONFIG_REGULATOR_LP3971 is not set
@@ -4742,13 +4742,13 @@ CONFIG_REGULATOR_MAX77686=m
 # CONFIG_REGULATOR_MP886X is not set
 # CONFIG_REGULATOR_MPQ7920 is not set
 # CONFIG_REGULATOR_MT6311 is not set
-# CONFIG_REGULATOR_PCA9450 is not set
-# CONFIG_REGULATOR_PF8X00 is not set
+CONFIG_REGULATOR_PCA9450=m
+CONFIG_REGULATOR_PF8X00=m
 CONFIG_REGULATOR_PFUZE100=m
 # CONFIG_REGULATOR_PV88060 is not set
 # CONFIG_REGULATOR_PV88080 is not set
 # CONFIG_REGULATOR_PV88090 is not set
-# CONFIG_REGULATOR_PWM is not set
+CONFIG_REGULATOR_PWM=y
 # CONFIG_REGULATOR_RASPBERRYPI_TOUCHSCREEN_ATTINY is not set
 # CONFIG_REGULATOR_RT4801 is not set
 # CONFIG_REGULATOR_RT4803 is not set
diff --git a/kernel-aarch64-rt-debug-rhel.config b/kernel-aarch64-rt-debug-rhel.config
index b7861e854..20ce2cd15 100644
--- a/kernel-aarch64-rt-debug-rhel.config
+++ b/kernel-aarch64-rt-debug-rhel.config
@@ -4817,7 +4817,7 @@ CONFIG_REGMAP_KUNIT=m
 # CONFIG_REGULATOR_ACT8865 is not set
 # CONFIG_REGULATOR_AD5398 is not set
 # CONFIG_REGULATOR_ANATOP is not set
-# CONFIG_REGULATOR_ARM_SCMI is not set
+CONFIG_REGULATOR_ARM_SCMI=m
 # CONFIG_REGULATOR_AT803X_PHY is not set
 CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_DA9121 is not set
@@ -4827,7 +4827,7 @@ CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_FAN53555 is not set
 # CONFIG_REGULATOR_FAN53880 is not set
 CONFIG_REGULATOR_FIXED_VOLTAGE=y
-CONFIG_REGULATOR_GPIO=m
+CONFIG_REGULATOR_GPIO=y
 # CONFIG_REGULATOR_ISL6271A is not set
 # CONFIG_REGULATOR_ISL9305 is not set
 # CONFIG_REGULATOR_LP3971 is not set
@@ -4854,13 +4854,13 @@ CONFIG_REGULATOR_MAX77686=m
 # CONFIG_REGULATOR_MP886X is not set
 # CONFIG_REGULATOR_MPQ7920 is not set
 # CONFIG_REGULATOR_MT6311 is not set
-# CONFIG_REGULATOR_PCA9450 is not set
-# CONFIG_REGULATOR_PF8X00 is not set
+CONFIG_REGULATOR_PCA9450=m
+CONFIG_REGULATOR_PF8X00=m
 CONFIG_REGULATOR_PFUZE100=m
 # CONFIG_REGULATOR_PV88060 is not set
 # CONFIG_REGULATOR_PV88080 is not set
 # CONFIG_REGULATOR_PV88090 is not set
-# CONFIG_REGULATOR_PWM is not set
+CONFIG_REGULATOR_PWM=y
 # CONFIG_REGULATOR_RASPBERRYPI_TOUCHSCREEN_ATTINY is not set
 # CONFIG_REGULATOR_RT4801 is not set
 # CONFIG_REGULATOR_RT4803 is not set
diff --git a/kernel-aarch64-rt-rhel.config b/kernel-aarch64-rt-rhel.config
index c001cbb07..949d5f874 100644
--- a/kernel-aarch64-rt-rhel.config
+++ b/kernel-aarch64-rt-rhel.config
@@ -4795,7 +4795,7 @@ CONFIG_REGMAP_KUNIT=m
 # CONFIG_REGULATOR_ACT8865 is not set
 # CONFIG_REGULATOR_AD5398 is not set
 # CONFIG_REGULATOR_ANATOP is not set
-# CONFIG_REGULATOR_ARM_SCMI is not set
+CONFIG_REGULATOR_ARM_SCMI=m
 # CONFIG_REGULATOR_AT803X_PHY is not set
 CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_DA9121 is not set
@@ -4805,7 +4805,7 @@ CONFIG_REGULATOR_BD718XX=m
 # CONFIG_REGULATOR_FAN53555 is not set
 # CONFIG_REGULATOR_FAN53880 is not set
 CONFIG_REGULATOR_FIXED_VOLTAGE=y
-CONFIG_REGULATOR_GPIO=m
+CONFIG_REGULATOR_GPIO=y
 # CONFIG_REGULATOR_ISL6271A is not set
 # CONFIG_REGULATOR_ISL9305 is not set
 # CONFIG_REGULATOR_LP3971 is not set
@@ -4832,13 +4832,13 @@ CONFIG_REGULATOR_MAX77686=m
 # CONFIG_REGULATOR_MP886X is not set
 # CONFIG_REGULATOR_MPQ7920 is not set
 # CONFIG_REGULATOR_MT6311 is not set
-# CONFIG_REGULATOR_PCA9450 is not set
-# CONFIG_REGULATOR_PF8X00 is not set
+CONFIG_REGULATOR_PCA9450=m
+CONFIG_REGULATOR_PF8X00=m
 CONFIG_REGULATOR_PFUZE100=m
 # CONFIG_REGULATOR_PV88060 is not set
 # CONFIG_REGULATOR_PV88080 is not set
 # CONFIG_REGULATOR_PV88090 is not set
-# CONFIG_REGULATOR_PWM is not set
+CONFIG_REGULATOR_PWM=y
 # CONFIG_REGULATOR_RASPBERRYPI_TOUCHSCREEN_ATTINY is not set
 # CONFIG_REGULATOR_RT4801 is not set
 # CONFIG_REGULATOR_RT4803 is not set
diff --git a/kernel.changelog b/kernel.changelog
index 61f6ea49b..749f568e8 100644
--- a/kernel.changelog
+++ b/kernel.changelog
@@ -1,3 +1,39 @@
+* Thu Sep 12 2024 Rado Vrbovsky <rvrbovsk@redhat.com> [5.14.0-508.el9]
+- usb: xhci: prevent potential failure in handle_tx_event() for Transfer events without TRB (Desnes Nunes) [RHEL-52378] {CVE-2024-42226}
+- redhat: set defaults for RHEL 9.5 (Lucas Zampieri)
+- redhat/configs: Make CONFIG_REGULATOR_GPIO built-in (Luiz Capitulino) [RHEL-21095]
+- redhat/configs: enable a bunch of regulators (Luiz Capitulino) [RHEL-21095]
+- md-cluster: fix no recovery job when adding/re-adding a disk (Nigel Croxon) [RHEL-46615]
+- md-cluster: fix hanging issue while a new disk adding (Nigel Croxon) [RHEL-46615]
+- md/raid5: recheck if reshape has finished with device_lock held (Nigel Croxon) [RHEL-46615]
+- md: Don't wait for MD_RECOVERY_NEEDED for HOT_REMOVE_DISK ioctl (Nigel Croxon) [RHEL-46615]
+- md-cluster: Constify struct md_cluster_operations (Nigel Croxon) [RHEL-46615]
+- md/raid5: fix spares errors about rcu usage (Nigel Croxon) [RHEL-46615]
+- md: pass in max_sectors for pers->sync_request() (Nigel Croxon) [RHEL-46615]
+- md: factor out helpers for different sync_action in md_do_sync() (Nigel Croxon) [RHEL-46615]
+- md: replace last_sync_action with new enum type (Nigel Croxon) [RHEL-46615]
+- md: use new helpers in md_do_sync() (Nigel Croxon) [RHEL-46615]
+- md: don't fail action_store() if sync_thread is not registered (Nigel Croxon) [RHEL-46615]
+- md: remove parameter check_seq for stop_sync_thread() (Nigel Croxon) [RHEL-46615]
+- md: replace sysfs api sync_action with new helpers (Nigel Croxon) [RHEL-46615]
+- md: factor out helper to start reshape from action_store() (Nigel Croxon) [RHEL-46615]
+- md: add new helpers for sync_action (Nigel Croxon) [RHEL-46615]
+- md: add a new enum type sync_action (Nigel Croxon) [RHEL-46615]
+- md: rearrange recovery_flags (Nigel Croxon) [RHEL-46615]
+- md/md-bitmap: fix writing non bitmap pages (Nigel Croxon) [RHEL-46615]
+- md: make md_flush_request() more readable (Nigel Croxon) [RHEL-46615]
+- md: change the return value type of md_write_start to void (Nigel Croxon) [RHEL-46615]
+- md: do not delete safemode_timer in mddev_suspend (Nigel Croxon) [RHEL-46615]
+- lib: objagg: Fix general protection fault (Waiman Long) [RHEL-54790 RHEL-54793] {CVE-2024-43846}
+- Revert "x86/topology: Switch over to GENERIC_CPU_DEVICES" (David Arcari) [RHEL-58031]
+- Revert "x86/topology: use weak version of arch_unregister_cpu()" (David Arcari) [RHEL-58031]
+- Revert "x86/topology: convert to use arch_cpu_is_hotpluggable()" (David Arcari) [RHEL-58031]
+- Revert "x86/cpu: Move leftover contents of topology.c to setup.c" (David Arcari) [RHEL-58031]
+- x86/resctrl: Remove redundant variable in mbm_config_write_domain() (David Arcari) [RHEL-57701]
+- x86/resctrl: Read supported bandwidth sources from CPUID (David Arcari) [RHEL-57701]
+- x86/resctrl: Remove hard-coded memory bandwidth limit (David Arcari) [RHEL-57701]
+Resolves: RHEL-21095, RHEL-46615, RHEL-52378, RHEL-54790, RHEL-54793, RHEL-57701, RHEL-58031
+
 * Wed Sep 11 2024 Rado Vrbovsky <rvrbovsk@redhat.com> [5.14.0-507.el9]
 - block: fix deadlock between sd_remove & sd_release (CKI Backport Bot) [RHEL-54997] {CVE-2024-42294}
 - gpio: prevent potential speculation leaks in gpio_device_get_desc() (CKI Backport Bot) [RHEL-56213] {CVE-2024-44931}
@@ -345,6 +381,11 @@ Resolves: RHEL-3230, RHEL-37349, RHEL-38600, RHEL-50255, RHEL-52234, RHEL-53992,
 - Revert "x86/topology: Fix max_siblings calculation for some hybrid cpus" (David Arcari) [RHEL-43147]
 Resolves: RHEL-43147, RHEL-54768
 
+* Tue Sep 03 2024 Lucas Zampieri <lzampier@redhat.com> [5.14.0-503.1.1.el9_5]
+- usb: xhci: prevent potential failure in handle_tx_event() for Transfer events without TRB (Desnes Nunes) [RHEL-52378] {CVE-2024-42226}
+- redhat: set defaults for RHEL 9.5 (Lucas Zampieri)
+Resolves: RHEL-52378
+
 * Thu Aug 22 2024 Lucas Zampieri <lzampier@redhat.com> [5.14.0-503.el9]
 - Revert "Merge: scsi: fnic: driver update" (John Meneghini) [RHEL-36420]
 - dev/parport: fix the array out-of-bounds risk (CKI Backport Bot) [RHEL-54990] {CVE-2024-42301}
diff --git a/kernel.spec b/kernel.spec
index 9aec588cf..c576a1fb6 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -165,15 +165,15 @@ Summary: The Linux kernel
 # define buildid .local
 %define specversion 5.14.0
 %define patchversion 5.14
-%define pkgrelease 507
+%define pkgrelease 508
 %define kversion 5
-%define tarfile_release 5.14.0-507.el9
+%define tarfile_release 5.14.0-508.el9
 # This is needed to do merge window version magic
 %define patchlevel 14
 # This allows pkg_release to have configurable %%{?dist} tag
-%define specrelease 507%{?buildid}%{?dist}
+%define specrelease 508%{?buildid}%{?dist}
 # This defines the kabi tarball version
-%define kabiversion 5.14.0-507.el9
+%define kabiversion 5.14.0-508.el9
 
 #
 # End of genspec.sh variables
@@ -3799,6 +3799,41 @@ fi
 #
 #
 %changelog
+* Thu Sep 12 2024 Rado Vrbovsky <rvrbovsk@redhat.com> [5.14.0-508.el9]
+- usb: xhci: prevent potential failure in handle_tx_event() for Transfer events without TRB (Desnes Nunes) [RHEL-52378] {CVE-2024-42226}
+- redhat: set defaults for RHEL 9.5 (Lucas Zampieri)
+- redhat/configs: Make CONFIG_REGULATOR_GPIO built-in (Luiz Capitulino) [RHEL-21095]
+- redhat/configs: enable a bunch of regulators (Luiz Capitulino) [RHEL-21095]
+- md-cluster: fix no recovery job when adding/re-adding a disk (Nigel Croxon) [RHEL-46615]
+- md-cluster: fix hanging issue while a new disk adding (Nigel Croxon) [RHEL-46615]
+- md/raid5: recheck if reshape has finished with device_lock held (Nigel Croxon) [RHEL-46615]
+- md: Don't wait for MD_RECOVERY_NEEDED for HOT_REMOVE_DISK ioctl (Nigel Croxon) [RHEL-46615]
+- md-cluster: Constify struct md_cluster_operations (Nigel Croxon) [RHEL-46615]
+- md/raid5: fix spares errors about rcu usage (Nigel Croxon) [RHEL-46615]
+- md: pass in max_sectors for pers->sync_request() (Nigel Croxon) [RHEL-46615]
+- md: factor out helpers for different sync_action in md_do_sync() (Nigel Croxon) [RHEL-46615]
+- md: replace last_sync_action with new enum type (Nigel Croxon) [RHEL-46615]
+- md: use new helpers in md_do_sync() (Nigel Croxon) [RHEL-46615]
+- md: don't fail action_store() if sync_thread is not registered (Nigel Croxon) [RHEL-46615]
+- md: remove parameter check_seq for stop_sync_thread() (Nigel Croxon) [RHEL-46615]
+- md: replace sysfs api sync_action with new helpers (Nigel Croxon) [RHEL-46615]
+- md: factor out helper to start reshape from action_store() (Nigel Croxon) [RHEL-46615]
+- md: add new helpers for sync_action (Nigel Croxon) [RHEL-46615]
+- md: add a new enum type sync_action (Nigel Croxon) [RHEL-46615]
+- md: rearrange recovery_flags (Nigel Croxon) [RHEL-46615]
+- md/md-bitmap: fix writing non bitmap pages (Nigel Croxon) [RHEL-46615]
+- md: make md_flush_request() more readable (Nigel Croxon) [RHEL-46615]
+- md: change the return value type of md_write_start to void (Nigel Croxon) [RHEL-46615]
+- md: do not delete safemode_timer in mddev_suspend (Nigel Croxon) [RHEL-46615]
+- lib: objagg: Fix general protection fault (Waiman Long) [RHEL-54790 RHEL-54793] {CVE-2024-43846}
+- Revert "x86/topology: Switch over to GENERIC_CPU_DEVICES" (David Arcari) [RHEL-58031]
+- Revert "x86/topology: use weak version of arch_unregister_cpu()" (David Arcari) [RHEL-58031]
+- Revert "x86/topology: convert to use arch_cpu_is_hotpluggable()" (David Arcari) [RHEL-58031]
+- Revert "x86/cpu: Move leftover contents of topology.c to setup.c" (David Arcari) [RHEL-58031]
+- x86/resctrl: Remove redundant variable in mbm_config_write_domain() (David Arcari) [RHEL-57701]
+- x86/resctrl: Read supported bandwidth sources from CPUID (David Arcari) [RHEL-57701]
+- x86/resctrl: Remove hard-coded memory bandwidth limit (David Arcari) [RHEL-57701]
+
 * Wed Sep 11 2024 Rado Vrbovsky <rvrbovsk@redhat.com> [5.14.0-507.el9]
 - block: fix deadlock between sd_remove & sd_release (CKI Backport Bot) [RHEL-54997] {CVE-2024-42294}
 - gpio: prevent potential speculation leaks in gpio_device_get_desc() (CKI Backport Bot) [RHEL-56213] {CVE-2024-44931}
diff --git a/sources b/sources
index f920e84d1..06669bbfd 100644
--- a/sources
+++ b/sources
@@ -1,3 +1,3 @@
-SHA512 (linux-5.14.0-507.el9.tar.xz) = b16ff635c6716ac1fe52fde9f93244bae4213215aaf2c26307364e8923c12f3903578a37153961a18f43922277ccd342f3e568d524bd1253ed519959238087bd
-SHA512 (kernel-abi-stablelists-5.14.0-507.el9.tar.bz2) = 9589ae53694d502c95d12575fa0c46cb510797eb9d4dbeb1f8a45f90f9f55bfe5b160caf819a72021f9c0d6413ee82cadb213f162d697f9aeac0b7bc31ece049
-SHA512 (kernel-kabi-dw-5.14.0-507.el9.tar.bz2) = 3d08f838767b27b87724fed347ce3be63fce15e5eded0576121c474d14db4a6d07895b350c635e343d5522ac237dfd982d1f39b8480c4129f4eb79f6a64115cb
+SHA512 (linux-5.14.0-508.el9.tar.xz) = 06e720699eab7b53bf285cf456828f80a4ee49133087513c9881379143a1f1cd57a0a73f56215e801cda058c447621263ebb87cea8cb689ed1e6dc33337d3e7c
+SHA512 (kernel-abi-stablelists-5.14.0-508.el9.tar.bz2) = 5c4be4ad6df2c1e1e05df957506aea1226c3e1e5441a7d0802ba48f92f59e8bebda103abff097b981691caae3ebbd18b98ec85484f1c96ec6c1637edcde12d1f
+SHA512 (kernel-kabi-dw-5.14.0-508.el9.tar.bz2) = 3d08f838767b27b87724fed347ce3be63fce15e5eded0576121c474d14db4a6d07895b350c635e343d5522ac237dfd982d1f39b8480c4129f4eb79f6a64115cb