From 4679d77e75d6238441aa96e947224a32ac701a4f Mon Sep 17 00:00:00 2001
From: Chuck Ebbert <cebbert@redhat.com>
Date: Wed, 16 Feb 2011 08:20:49 -0500
Subject: [PATCH] Add support for Airprime/Sierra USB IP modem (#676860)

---
 kernel.spec                             |  9 ++++++++
 usb-sierra-add-airprime-direct-ip.patch | 30 +++++++++++++++++++++++++
 2 files changed, 39 insertions(+)
 create mode 100644 usb-sierra-add-airprime-direct-ip.patch

diff --git a/kernel.spec b/kernel.spec
index bea7bb547..16ce1fcef 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -735,6 +735,9 @@ Patch12438: ath5k-fix-fast-channel-change.patch
 
 Patch12440: bridge-fix-mglist-corruption-that-leads-to-memory-corruption.patch
 
+# rhbz#676860
+Patch12441: usb-sierra-add-airprime-direct-ip.patch
+
 %endif
 
 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
@@ -1352,6 +1355,9 @@ ApplyPatch ath5k-fix-fast-channel-change.patch
 
 ApplyPatch bridge-fix-mglist-corruption-that-leads-to-memory-corruption.patch
 
+# rhbz#676860
+ApplyPatch usb-sierra-add-airprime-direct-ip.patch
+
 # END OF PATCH APPLICATIONS
 
 %endif
@@ -1955,6 +1961,9 @@ fi
 # and build.
 
 %changelog
+* Wed Feb 16 2011 Chuck Ebbert <cebbert@redhat.com>
+- Add support for Airprime/Sierra USB IP modem (#676860)
+
 * Tue Feb 15 2011 Kyle McMartin <kmcmartin@redhat.com> 2.6.38-0.rc5.git0.1
 - Linux 2.6.38-rc5 (81 minutes later...)
 
diff --git a/usb-sierra-add-airprime-direct-ip.patch b/usb-sierra-add-airprime-direct-ip.patch
new file mode 100644
index 000000000..62a7ddd89
--- /dev/null
+++ b/usb-sierra-add-airprime-direct-ip.patch
@@ -0,0 +1,30 @@
+From: Jon Thomas <jthomas@redhat.com>
+Subj: Add new ID for Airprime/Sierra USB IP modem
+
+I picked up a new Sierra usb 308 (At&t Shockwave) on 2/2011 and the vendor code
+is 0x0f3d
+
+Looking up vendor and product id's I see:
+
+0f3d  Airprime, Incorporated
+ 0112  CDMA 1xEVDO PC Card, PC 5220
+
+Sierra and Airprime are somehow related and I'm guessing the At&t usb 308 might
+be have some common hardware with the AirPrime SL809x.
+
+I patched sierra.c with this and it works.
+
+Signed-off-by: Jon Thomas <jthomas@redhat.com>
+
+--- a/drivers/usb/serial/sierra.c
++++ b/drivers/usb/serial/sierra.c
+@@ -301,6 +301,9 @@ static const struct usb_device_id id_tab
+ 	{ USB_DEVICE(0x1199, 0x68A3), 	/* Sierra Wireless Direct IP modems */
+ 	  .driver_info = (kernel_ulong_t)&direct_ip_interface_blacklist
+ 	},
++	{ USB_DEVICE(0x0f3d, 0x68A3), 	/* Airprime/Sierra Wireless Direct IP modems */
++	  .driver_info = (kernel_ulong_t)&direct_ip_interface_blacklist
++	},
+        { USB_DEVICE(0x413C, 0x08133) }, /* Dell Computer Corp. Wireless 5720 VZW Mobile Broadband (EVDO Rev-A) Minicard GPS Port */
+ 
+ 	{ }