Add resizecons (with man page) for x86_64
This commit is contained in:
parent
9c40f4d32b
commit
fa0e96f6aa
@ -1,20 +0,0 @@
|
|||||||
Patch by Keiichi Mori <kmori@redhat.com>.
|
|
||||||
|
|
||||||
--- kbd-1.12/man/Makefile.orig 2002-10-12 07:12:53.000000000 +0900
|
|
||||||
+++ kbd-1.12/man/Makefile 2006-03-27 09:17:54.000000000 +0900
|
|
||||||
@@ -1,3 +1,5 @@
|
|
||||||
+include ../make_include
|
|
||||||
+
|
|
||||||
# Generated files
|
|
||||||
GEN1=man1/dumpkeys.1 man1/loadkeys.1
|
|
||||||
GEN8=man8/setfont.8 man8/loadunimap.8 man8/mapscrn.8
|
|
||||||
@@ -8,6 +10,9 @@
|
|
||||||
install -m 644 $$i/*.[0-9] $(MANDIR)/$$i; \
|
|
||||||
done
|
|
||||||
rm -f $(MANDIR)/man5/keytables.5
|
|
||||||
+ if [ $(ARCH) != i386 ]; then \
|
|
||||||
+ rm -f $(MANDIR)/man8/resizecons.8; \
|
|
||||||
+ fi
|
|
||||||
|
|
||||||
clean:
|
|
||||||
rm -f $(GEN1) $(GEN8)
|
|
13
kbd-1.12-resizecon-x86.patch
Normal file
13
kbd-1.12-resizecon-x86.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- kbd-1.12/src/Makefile.in_old 2007-10-16 14:14:51.000000000 +0200
|
||||||
|
+++ kbd-1.12/src/Makefile.in 2007-10-16 15:27:38.000000000 +0200
|
||||||
|
@@ -43,6 +43,10 @@
|
||||||
|
PROGS += resizecons
|
||||||
|
endif
|
||||||
|
|
||||||
|
+ifeq ($(ARCH), x86_64)
|
||||||
|
+PROGS += resizecons
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
OLDPROGS= mapscrn loadunimap
|
||||||
|
|
||||||
|
# Not installed by default
|
18
kbd.spec
18
kbd.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
||||||
Name: kbd
|
Name: kbd
|
||||||
Version: 1.12
|
Version: 1.12
|
||||||
Release: 26%{?dist}
|
Release: 27%{?dist}
|
||||||
# Except possibly for the restrictions mentioned in the directory consolefonts
|
# Except possibly for the restrictions mentioned in the directory consolefonts
|
||||||
License: GPL+
|
License: GPL+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -26,9 +26,9 @@ Patch6: kbd-1.12-nostrip.patch
|
|||||||
Patch7: kbd-1.12-alias.patch
|
Patch7: kbd-1.12-alias.patch
|
||||||
Patch8: kbd-1.12-dir.patch
|
Patch8: kbd-1.12-dir.patch
|
||||||
Patch9: kbd-1.12-no-user-map.patch
|
Patch9: kbd-1.12-no-user-map.patch
|
||||||
Patch10: kbd-1.12-resizecon-man.patch
|
Patch10: kbd-1.12-gr-el.patch
|
||||||
Patch11: kbd-1.12-gr-el.patch
|
Patch11: kbd-1.12-keycodes-man.patch
|
||||||
Patch12: kbd-1.12-keycodes-man.patch
|
Patch12: kbd-1.12-resizecon-x86.patch
|
||||||
Obsoletes: console-tools open
|
Obsoletes: console-tools open
|
||||||
Provides: console-tools open
|
Provides: console-tools open
|
||||||
Conflicts: util-linux < 2.11r-9
|
Conflicts: util-linux < 2.11r-9
|
||||||
@ -53,9 +53,9 @@ fonts, the virtual terminals and font files.
|
|||||||
%patch7 -p1 -b .alias
|
%patch7 -p1 -b .alias
|
||||||
%patch8 -p1 -b .dir
|
%patch8 -p1 -b .dir
|
||||||
%patch9 -p1 -b .no-user-map
|
%patch9 -p1 -b .no-user-map
|
||||||
%patch10 -p1 -b .resizecon-man
|
%patch10 -p1 -b .gr-el
|
||||||
%patch11 -p1 -b .gr-el
|
%patch11 -p1 -b .keycodes-man
|
||||||
%patch12 -p1 -b .keycodes-man
|
%patch12 -p1 -b .resizecon-x86
|
||||||
|
|
||||||
# 7-bit maps are obsolete; so are non-euro maps
|
# 7-bit maps are obsolete; so are non-euro maps
|
||||||
pushd data/keymaps/i386
|
pushd data/keymaps/i386
|
||||||
@ -142,6 +142,10 @@ ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
|
|||||||
%config %{_sysconfdir}/pam.d/*
|
%config %{_sysconfdir}/pam.d/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 17 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.12-27
|
||||||
|
- Add resizecons (with man page) for x86_64
|
||||||
|
Resolves: #333651
|
||||||
|
|
||||||
* Mon Oct 15 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.12-26
|
* Mon Oct 15 2007 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.12-26
|
||||||
- Fix ro.map to generate right unicode for s, S, t, T with comma
|
- Fix ro.map to generate right unicode for s, S, t, T with comma
|
||||||
- Fix LatArCyrHeb-16 unicode mapping table to show comma-version
|
- Fix LatArCyrHeb-16 unicode mapping table to show comma-version
|
||||||
|
Loading…
Reference in New Issue
Block a user