Apply only tty non-breaking fixes from -10
This commit is contained in:
parent
1616f2c7f7
commit
eaa5607d56
@ -21,42 +21,6 @@ diff -up kbd-2.0.4/src/libkeymap/common.c.orig kbd-2.0.4/src/libkeymap/common.c
|
|||||||
+
|
+
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
diff -up kbd-2.0.4/src/libkeymap/parser.c.orig kbd-2.0.4/src/libkeymap/parser.c
|
|
||||||
diff -up kbd-2.0.4/src/psffontop.c.orig kbd-2.0.4/src/psffontop.c
|
|
||||||
--- kbd-2.0.4/src/psffontop.c.orig 2018-11-05 10:20:13.336587498 +0100
|
|
||||||
+++ kbd-2.0.4/src/psffontop.c 2018-11-05 10:27:26.342994244 +0100
|
|
||||||
@@ -271,8 +271,10 @@ int readpsffont(FILE *fontf, char **allb
|
|
||||||
ftoffset = assemble_int((unsigned char *)&psfhdr.headersize);
|
|
||||||
fontwidth = assemble_int((unsigned char *)&psfhdr.width);
|
|
||||||
utf8 = 1;
|
|
||||||
- } else
|
|
||||||
+ } else {
|
|
||||||
+ free(inputbuf);
|
|
||||||
return -1; /* not psf */
|
|
||||||
+ }
|
|
||||||
|
|
||||||
/* tests required - we divide by these */
|
|
||||||
if (fontlen == 0) {
|
|
||||||
@@ -301,8 +303,10 @@ int readpsffont(FILE *fontf, char **allb
|
|
||||||
if (fontwidthp)
|
|
||||||
*fontwidthp = fontwidth;
|
|
||||||
|
|
||||||
- if (!uclistheadsp)
|
|
||||||
+ if (!uclistheadsp) {
|
|
||||||
+ free(inputbuf);
|
|
||||||
return 0; /* got font, don't need unicode_list */
|
|
||||||
+ }
|
|
||||||
|
|
||||||
*uclistheadsp = xrealloc(*uclistheadsp,
|
|
||||||
(fontpos0 + fontlen) * sizeof(struct unicode_list));
|
|
||||||
@@ -330,6 +334,7 @@ int readpsffont(FILE *fontf, char **allb
|
|
||||||
}
|
|
||||||
}
|
|
||||||
|
|
||||||
+ free(inputbuf);
|
|
||||||
return 0; /* got psf font */
|
|
||||||
}
|
|
||||||
|
|
||||||
diff -up kbd-2.0.4/src/setfont.c.orig kbd-2.0.4/src/setfont.c
|
diff -up kbd-2.0.4/src/setfont.c.orig kbd-2.0.4/src/setfont.c
|
||||||
--- kbd-2.0.4/src/setfont.c.orig 2018-11-05 10:28:01.994027734 +0100
|
--- kbd-2.0.4/src/setfont.c.orig 2018-11-05 10:28:01.994027734 +0100
|
||||||
+++ kbd-2.0.4/src/setfont.c 2018-11-05 10:35:54.933477039 +0100
|
+++ kbd-2.0.4/src/setfont.c 2018-11-05 10:35:54.933477039 +0100
|
||||||
|
13
kbd.spec
13
kbd.spec
@ -1,6 +1,6 @@
|
|||||||
Name: kbd
|
Name: kbd
|
||||||
Version: 2.0.4
|
Version: 2.0.4
|
||||||
Release: 11%{?dist}
|
Release: 12%{?dist}
|
||||||
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://www.kbd-project.org/
|
URL: http://www.kbd-project.org/
|
||||||
@ -27,10 +27,8 @@ Patch5: kbd-1.15.5-loadkeys-search-path.patch
|
|||||||
# Patch6: don't hardcode font used in unicode_start, take it from vconsole.conf,
|
# Patch6: don't hardcode font used in unicode_start, take it from vconsole.conf,
|
||||||
# bz 1101007
|
# bz 1101007
|
||||||
Patch6: kbd-2.0.2-unicode-start-font.patch
|
Patch6: kbd-2.0.2-unicode-start-font.patch
|
||||||
# Patch7: fixes issues found by static analysis, accepted upstream
|
# Patch7: fixes issues found by static analysis
|
||||||
# DISABLED for now as something in this somehow stops all characters
|
Patch7: kbd-2.0.4-covscan-fixes.patch
|
||||||
# rendering in ttys: https://bugzilla.redhat.com/show_bug.cgi?id=1649531
|
|
||||||
#Patch7: kbd-2.0.4-covscan-fixes.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc, bison, flex, gettext, pam-devel, check-devel
|
BuildRequires: gcc, bison, flex, gettext, pam-devel, check-devel
|
||||||
BuildRequires: console-setup, xkeyboard-config
|
BuildRequires: console-setup, xkeyboard-config
|
||||||
@ -73,7 +71,7 @@ cp -fp %{SOURCE6} .
|
|||||||
%patch4 -p1 -b .sg-decimal-separator
|
%patch4 -p1 -b .sg-decimal-separator
|
||||||
%patch5 -p1 -b .loadkeys-search-path
|
%patch5 -p1 -b .loadkeys-search-path
|
||||||
%patch6 -p1 -b .unicode-start-font
|
%patch6 -p1 -b .unicode-start-font
|
||||||
#patch7 -p1 -b .covscan-fixes
|
%patch7 -p1 -b .covscan-fixes
|
||||||
|
|
||||||
# 7-bit maps are obsolete; so are non-euro maps
|
# 7-bit maps are obsolete; so are non-euro maps
|
||||||
pushd data/keymaps/i386
|
pushd data/keymaps/i386
|
||||||
@ -191,6 +189,9 @@ gzip $RPM_BUILD_ROOT/lib/kbd/keymaps/xkb/cz.map
|
|||||||
/lib/kbd/keymaps/legacy
|
/lib/kbd/keymaps/legacy
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 28 2018 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.0.4-12
|
||||||
|
- Apply only tty non-breaking fixes from -10
|
||||||
|
|
||||||
* Tue Nov 13 2018 Adam Williamson <awilliam@redhat.com> - 2.0.4-11
|
* Tue Nov 13 2018 Adam Williamson <awilliam@redhat.com> - 2.0.4-11
|
||||||
- Drop fixes from -10 for now as they are breaking ttys (#1649531)
|
- Drop fixes from -10 for now as they are breaking ttys (#1649531)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user