- Fix another violation of C aliasing rules (#157720, patch by Jan
Kratochvil)
This commit is contained in:
parent
2e2e7a72aa
commit
7feb970589
@ -1,5 +1,6 @@
|
|||||||
--- kbd-1.12/src/psffontop.c.alias 2005-03-12 00:47:45.296118344 +0100
|
diff -u kbd-1.12/src/psffontop.c kbd-1.12/src/psffontop.c
|
||||||
+++ kbd-1.12/src/psffontop.c 2005-03-12 00:48:30.075310872 +0100
|
--- kbd-1.12/src/psffontop.c 2005-03-12 00:48:30.075310872 +0100
|
||||||
|
+++ kbd-1.12/src/psffontop.c 2005-05-14 10:49:59.000000000 +0900
|
||||||
@@ -59,7 +59,6 @@
|
@@ -59,7 +59,6 @@
|
||||||
|
|
||||||
static unsigned int
|
static unsigned int
|
||||||
@ -19,3 +20,28 @@
|
|||||||
return (u1 | (u2 << 8));
|
return (u1 | (u2 << 8));
|
||||||
}
|
}
|
||||||
|
|
||||||
|
@@ -110,7 +109,6 @@
|
||||||
|
*/
|
||||||
|
static void
|
||||||
|
get_uni_entry(char **inptr, char **endptr, struct unicode_list *up, int utf8) {
|
||||||
|
- unsigned char **in = (unsigned char **) inptr;
|
||||||
|
unsigned char uc;
|
||||||
|
unicode unichar;
|
||||||
|
int inseq = 0;
|
||||||
|
@@ -126,14 +124,14 @@
|
||||||
|
exit(EX_DATAERR);
|
||||||
|
}
|
||||||
|
if (utf8) {
|
||||||
|
- uc = *(*in)++;
|
||||||
|
+ uc = *(*inptr)++;
|
||||||
|
if (uc == PSF2_SEPARATOR)
|
||||||
|
break;
|
||||||
|
if (uc == PSF2_STARTSEQ) {
|
||||||
|
inseq = 1;
|
||||||
|
continue;
|
||||||
|
}
|
||||||
|
- --(*in);
|
||||||
|
+ --(*inptr);
|
||||||
|
unichar = assemble_utf8(inptr, *endptr - *inptr);
|
||||||
|
} else {
|
||||||
|
unichar = assemble_ucs2(inptr, *endptr - *inptr);
|
||||||
|
7
kbd.spec
7
kbd.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
||||||
Name: kbd
|
Name: kbd
|
||||||
Version: 1.12
|
Version: 1.12
|
||||||
Release: 8
|
Release: 9
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source0: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2
|
Source0: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2
|
||||||
@ -120,8 +120,11 @@ install -c -m644 $RPM_SOURCE_DIR/kbdrate.pam \
|
|||||||
%config %{_sysconfdir}/pam.d/*
|
%config %{_sysconfdir}/pam.d/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 17 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-9
|
||||||
|
- Fix another violation of C aliasing rules (#157720, patch by Jan Kratochvil)
|
||||||
|
|
||||||
* Sat Mar 12 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-8
|
* Sat Mar 12 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-8
|
||||||
- Fix violation of C alias rules (#150440)
|
- Fix violation of C aliasing rules (#150440)
|
||||||
|
|
||||||
* Sun Mar 6 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-7
|
* Sun Mar 6 2005 Miloslav Trmac <mitr@redhat.com> - 1.12-7
|
||||||
- Don't run ldconfig
|
- Don't run ldconfig
|
||||||
|
Loading…
Reference in New Issue
Block a user