Update to kbd-2.0.1
This commit is contained in:
parent
52ea61062d
commit
44580b81dd
1
.gitignore
vendored
1
.gitignore
vendored
@ -17,3 +17,4 @@ kbd-1.15.tar.gz
|
||||
/kbd-latarcyrheb-32.tar.bz2
|
||||
/kbd-1.15.3.tar.gz
|
||||
/kbd-1.15.5.tar.gz
|
||||
/kbd-2.0.1.tar.gz
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up kbd-1.15.2/man/man1/showkey.1.orig kbd-1.15.2/man/man1/showkey.1
|
||||
--- kbd-1.15.2/man/man1/showkey.1.orig 2009-10-09 17:26:13.000000000 +0200
|
||||
+++ kbd-1.15.2/man/man1/showkey.1 2011-01-05 12:45:25.726030798 +0100
|
||||
--- kbd-1.15.2/docs/man/man1/showkey.1.orig 2009-10-09 17:26:13.000000000 +0200
|
||||
+++ kbd-1.15.2/docs/man/man1/showkey.1 2011-01-05 12:45:25.726030798 +0100
|
||||
@@ -80,6 +80,19 @@ corresponds to what the keyboard hardwar
|
||||
to know the scan codes sent by various keys it is better to boot a
|
||||
2.4 kernel. Since 2.6.9 there also is the boot option atkbd.softraw=0
|
||||
@ -22,8 +22,8 @@ diff -up kbd-1.15.2/man/man1/showkey.1.orig kbd-1.15.2/man/man1/showkey.1
|
||||
.BR loadkeys (1),
|
||||
.BR dumpkeys (1),
|
||||
diff -up kbd-1.15.2/man/man8/setkeycodes.8.orig kbd-1.15.2/man/man8/setkeycodes.8
|
||||
--- kbd-1.15.2/man/man8/setkeycodes.8.orig 2009-10-09 17:26:13.000000000 +0200
|
||||
+++ kbd-1.15.2/man/man8/setkeycodes.8 2011-01-05 12:47:46.894739942 +0100
|
||||
--- kbd-1.15.2/docs/man/man8/setkeycodes.8.orig 2009-10-09 17:26:13.000000000 +0200
|
||||
+++ kbd-1.15.2/docs/man/man8/setkeycodes.8 2011-01-05 12:47:46.894739942 +0100
|
||||
@@ -38,6 +38,10 @@ to showkey(1), the command
|
||||
.RE
|
||||
will assign the keycode 112 to it, and then loadkeys(1) can be used
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up kbd-1.15.2/man/man8/kbdrate.8.orig kbd-1.15.2/man/man8/kbdrate.8
|
||||
--- kbd-1.15.2/man/man8/kbdrate.8.orig 2009-06-07 21:48:42.000000000 +0200
|
||||
+++ kbd-1.15.2/man/man8/kbdrate.8 2011-01-05 12:58:34.579706016 +0100
|
||||
--- kbd-1.15.2/docs/man/man8/kbdrate.8.orig 2009-06-07 21:48:42.000000000 +0200
|
||||
+++ kbd-1.15.2/docs/man/man8/kbdrate.8 2011-01-05 12:58:34.579706016 +0100
|
||||
@@ -22,7 +22,7 @@ Using
|
||||
without any options will reset the repeat rate to 10.9 characters per second (cps)
|
||||
and the delay to 250 milliseconds (ms) for Intel- and M68K-based systems.
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up kbd-1.15.3/man/man1/dumpkeys.1.in.orig kbd-1.15.3/man/man1/dumpkeys.1.in
|
||||
--- kbd-1.15.3/man/man1/dumpkeys.1.in.orig 2011-08-23 13:06:16.905892768 +0200
|
||||
+++ kbd-1.15.3/man/man1/dumpkeys.1.in 2011-08-23 13:15:18.264853435 +0200
|
||||
--- kbd-1.15.3/docs/man/man1/dumpkeys.1.in.orig 2011-08-23 13:06:16.905892768 +0200
|
||||
+++ kbd-1.15.3/docs/man/man1/dumpkeys.1.in 2011-08-23 13:15:18.264853435 +0200
|
||||
@@ -156,6 +156,14 @@ output of
|
||||
.BR dumpkeys .
|
||||
.LP
|
||||
|
@ -1,38 +0,0 @@
|
||||
diff -up kbd-1.15.5/src/loadkeys.analyze.l.orig kbd-1.15.5/src/loadkeys.analyze.l
|
||||
--- kbd-1.15.5/src/loadkeys.analyze.l.orig 2013-01-21 11:22:51.374582275 +0100
|
||||
+++ kbd-1.15.5/src/loadkeys.analyze.l 2013-01-21 11:25:29.278331267 +0100
|
||||
@@ -307,8 +307,10 @@ To to|To|TO
|
||||
char *s = xstrndup(yytext+1, strlen(yytext)-2);
|
||||
/* use static pathname to store *s ? */
|
||||
open_include(s);
|
||||
- yy_pop_state();
|
||||
- state_ptr--;
|
||||
+ while (state_ptr > 0) {
|
||||
+ yy_pop_state();
|
||||
+ state_ptr--;
|
||||
+ }
|
||||
}
|
||||
<INCLSTR>[^"]|\"\"|\"[^"\n]*{Eol} {
|
||||
yyerror(_("expected filename between quotes"));
|
||||
@@ -323,7 +325,7 @@ To to|To|TO
|
||||
}
|
||||
{Eol} {
|
||||
line_nr++;
|
||||
- if (state_ptr > 0) {
|
||||
+ while (state_ptr > 0) {
|
||||
yy_pop_state();
|
||||
state_ptr--;
|
||||
}
|
||||
@@ -428,8 +430,10 @@ To to|To|TO
|
||||
}
|
||||
<STR>\" {
|
||||
*p = '\0';
|
||||
- yy_pop_state();
|
||||
- state_ptr--;
|
||||
+ while (state_ptr > 0) {
|
||||
+ yy_pop_state();
|
||||
+ state_ptr--;
|
||||
+ }
|
||||
return(STRLITERAL);
|
||||
}
|
||||
. {
|
20
kbd.spec
20
kbd.spec
@ -1,6 +1,6 @@
|
||||
Name: kbd
|
||||
Version: 1.15.5
|
||||
Release: 9%{?dist}
|
||||
Version: 2.0.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
||||
|
||||
Group: System Environment/Base
|
||||
@ -20,12 +20,10 @@ Patch1: kbd-1.15-sparc.patch
|
||||
Patch2: kbd-1.15-unicode_start.patch
|
||||
# Patch3: add missing dumpkeys option to man page
|
||||
Patch3: kbd-1.15.3-dumpkeys-man.patch
|
||||
# Patch4: fixes loadkeys regression (already upstream)
|
||||
Patch4: kbd-1.15.5-loadkeys-regression.patch
|
||||
# Patch5: fixes decimal separator in Swiss German keyboard layout, bz 882529
|
||||
Patch5: kbd-1.15.5-sg-decimal-separator.patch
|
||||
# Patch4: fixes decimal separator in Swiss German keyboard layout, bz 882529
|
||||
Patch4: kbd-1.15.5-sg-decimal-separator.patch
|
||||
|
||||
BuildRequires: bison, flex, gettext, pam-devel
|
||||
BuildRequires: bison, flex, gettext, pam-devel, check-devel
|
||||
BuildRequires: console-setup, xkeyboard-config
|
||||
Requires: initscripts >= 5.86-1
|
||||
Requires: %{name}-misc = %{version}-%{release}
|
||||
@ -63,8 +61,7 @@ cp -fp %{SOURCE6} .
|
||||
%patch1 -p1 -b .sparc
|
||||
%patch2 -p1 -b .unicode_start
|
||||
%patch3 -p1 -b .dumpkeys-man
|
||||
%patch4 -p1 -b .loadkeys-regression
|
||||
%patch5 -p1 -b .sg-decimal-separator
|
||||
%patch4 -p1 -b .sg-decimal-separator
|
||||
|
||||
# 7-bit maps are obsolete; so are non-euro maps
|
||||
pushd data/keymaps/i386
|
||||
@ -217,7 +214,7 @@ ln -s /lib/kbd/keymaps/xkb/us.map.gz $RPM_BUILD_ROOT/lib/kbd/keymaps/i386/qwerty
|
||||
%find_lang %{name}
|
||||
|
||||
%files -f %{name}.lang
|
||||
%doc ChangeLog AUTHORS README COPYING doc/kbd.FAQ*.html doc/font-formats/*.html doc/utf/utf* doc/dvorak/*
|
||||
%doc ChangeLog AUTHORS README COPYING docs/doc/kbd.FAQ*.html docs/doc/font-formats/*.html docs/doc/utf/utf* docs/doc/dvorak/*
|
||||
/bin/*
|
||||
%{_bindir}/*
|
||||
%{_mandir}/*/*
|
||||
@ -230,6 +227,9 @@ ln -s /lib/kbd/keymaps/xkb/us.map.gz $RPM_BUILD_ROOT/lib/kbd/keymaps/i386/qwerty
|
||||
/lib/kbd/keymaps/legacy
|
||||
|
||||
%changelog
|
||||
* Mon Nov 04 2013 Vitezslav Crhonek <vcrhonek@redhat.com> - 2.0.1-1
|
||||
- Update to kbd-2.0.1
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15.5-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -2,4 +2,4 @@
|
||||
884fdbb0b952b2e3e8389a0c40a3e301 kbd-latarcyrheb-16-fixed.tar.bz2
|
||||
dd16ff8c6fa9d81490df28cbd68882eb fr-dvorak.tar.bz2
|
||||
fe118f07a83134b15610503e5e3fe10e kbd-latarcyrheb-32.tar.bz2
|
||||
34c71feead8ab9c01ec638acea8cd877 kbd-1.15.5.tar.gz
|
||||
cc0ee9f2537d8636cae85a8c6541ed2e kbd-2.0.1.tar.gz
|
||||
|
Loading…
Reference in New Issue
Block a user