Rediff all patches to work with patch --fuzz=0, Add static loadkeys
This commit is contained in:
parent
37ad3b227b
commit
3c53437073
@ -1,7 +1,6 @@
|
|||||||
Map the PrintScreen key and Alt+AltGr to Compose.
|
diff -up /dev/null kbd-1.12/data/keymaps/i386/include/compose.inc
|
||||||
|
--- /dev/null 2008-08-23 19:55:25.045687917 +0200
|
||||||
--- kbd-1.08/data/keymaps/i386/include/compose.inc 2002-10-04 14:48:04.000000000 -0400
|
+++ kbd-1.12/data/keymaps/i386/include/compose.inc 2008-09-08 17:23:50.000000000 +0200
|
||||||
+++ kbd-1.08/data/keymaps/i386/include/compose.inc 2002-11-22 17:36:32.000000000 -0500
|
|
||||||
@@ -0,0 +1,8 @@
|
@@ -0,0 +1,8 @@
|
||||||
+# We map the PrintScreen key (useless) and Alt+AltGr to the Compose key...
|
+# We map the PrintScreen key (useless) and Alt+AltGr to the Compose key...
|
||||||
+# A really useful thing not found on normal keyboards. :/
|
+# A really useful thing not found on normal keyboards. :/
|
||||||
@ -11,33 +10,26 @@ Map the PrintScreen key and Alt+AltGr to Compose.
|
|||||||
+keycode 99 = Compose # SysRq/PrintScrn
|
+keycode 99 = Compose # SysRq/PrintScrn
|
||||||
+keycode 100 = AltGr
|
+keycode 100 = AltGr
|
||||||
+alt keycode 100 = Compose
|
+alt keycode 100 = Compose
|
||||||
--- kbd-1.08/data/keymaps/i386/include/qwerty-layout.inc 2002-10-11 07:08:50.000000000 -0400
|
diff -up kbd-1.12/data/keymaps/i386/include/qwertz-layout.inc.compose kbd-1.12/data/keymaps/i386/include/qwertz-layout.inc
|
||||||
+++ kbd-1.08/data/keymaps/i386/include/qwerty-layout.inc 2002-11-22 17:36:32.000000000 -0500
|
--- kbd-1.12/data/keymaps/i386/include/qwertz-layout.inc.compose 2002-10-11 13:08:50.000000000 +0200
|
||||||
@@ -28,3 +28,4 @@
|
+++ kbd-1.12/data/keymaps/i386/include/qwertz-layout.inc 2008-09-08 17:23:50.000000000 +0200
|
||||||
|
@@ -28,3 +28,4 @@ keycode 48 = b
|
||||||
keycode 49 = n
|
keycode 49 = n
|
||||||
keycode 50 = m
|
keycode 50 = m
|
||||||
#
|
#
|
||||||
+include "compose"
|
+include "compose"
|
||||||
--- kbd-1.08/data/keymaps/i386/include/qwertz-layout.inc 2002-10-11 07:08:50.000000000 -0400
|
diff -up kbd-1.12/data/keymaps/i386/include/qwerty-layout.inc.compose kbd-1.12/data/keymaps/i386/include/qwerty-layout.inc
|
||||||
+++ kbd-1.08/data/keymaps/i386/include/qwertz-layout.inc 2002-11-22 17:36:32.000000000 -0500
|
--- kbd-1.12/data/keymaps/i386/include/qwerty-layout.inc.compose 2002-10-11 13:08:50.000000000 +0200
|
||||||
@@ -28,3 +28,4 @@
|
+++ kbd-1.12/data/keymaps/i386/include/qwerty-layout.inc 2008-09-08 17:23:50.000000000 +0200
|
||||||
|
@@ -28,3 +28,4 @@ keycode 48 = b
|
||||||
keycode 49 = n
|
keycode 49 = n
|
||||||
keycode 50 = m
|
keycode 50 = m
|
||||||
#
|
#
|
||||||
+include "compose"
|
+include "compose"
|
||||||
--- kbd-1.08/data/keymaps/i386/include/linux-with-alt-and-altgr.inc 2002-10-11 07:08:50.000000000 -0400
|
diff -up kbd-1.12/data/keymaps/i386/include/linux-keys-bare.inc.compose kbd-1.12/data/keymaps/i386/include/linux-keys-bare.inc
|
||||||
+++ kbd-1.08/data/keymaps/i386/include/linux-with-alt-and-altgr.inc 2002-11-22 17:36:32.000000000 -0500
|
--- kbd-1.12/data/keymaps/i386/include/linux-keys-bare.inc.compose 2002-10-13 02:14:06.000000000 +0200
|
||||||
@@ -1,6 +1,7 @@
|
+++ kbd-1.12/data/keymaps/i386/include/linux-keys-bare.inc 2008-09-08 17:23:50.000000000 +0200
|
||||||
include "linux-keys-bare"
|
@@ -148,7 +148,8 @@ control alt keycode 111 = Boot
|
||||||
|
|
||||||
keycode 100 = AltGr
|
|
||||||
+alt keycode 100 = Compose
|
|
||||||
|
|
||||||
altgr keycode 70 = Show_Registers
|
|
||||||
alt keycode 70 = Scroll_Lock
|
|
||||||
--- kbd-1.08/data/keymaps/i386/include/linux-keys-bare.inc 2002-10-12 20:14:06.000000000 -0400
|
|
||||||
+++ kbd-1.08/data/keymaps/i386/include/linux-keys-bare.inc 2002-11-22 17:42:04.000000000 -0500
|
|
||||||
@@ -148,7 +148,8 @@
|
|
||||||
# The three system keys
|
# The three system keys
|
||||||
#
|
#
|
||||||
keycode 84 = Last_Console # Alt+SysRq/PrintScrn
|
keycode 84 = Last_Console # Alt+SysRq/PrintScrn
|
||||||
@ -47,3 +39,14 @@ Map the PrintScreen key and Alt+AltGr to Compose.
|
|||||||
alt keycode 99 = Control_backslash
|
alt keycode 99 = Control_backslash
|
||||||
control keycode 99 = Control_backslash
|
control keycode 99 = Control_backslash
|
||||||
|
|
||||||
|
diff -up kbd-1.12/data/keymaps/i386/include/linux-with-alt-and-altgr.inc.compose kbd-1.12/data/keymaps/i386/include/linux-with-alt-and-altgr.inc
|
||||||
|
--- kbd-1.12/data/keymaps/i386/include/linux-with-alt-and-altgr.inc.compose 2002-10-11 13:08:50.000000000 +0200
|
||||||
|
+++ kbd-1.12/data/keymaps/i386/include/linux-with-alt-and-altgr.inc 2008-09-08 17:23:50.000000000 +0200
|
||||||
|
@@ -1,6 +1,7 @@
|
||||||
|
include "linux-keys-bare"
|
||||||
|
|
||||||
|
keycode 100 = AltGr
|
||||||
|
+alt keycode 100 = Compose
|
||||||
|
|
||||||
|
altgr keycode 70 = Show_Registers
|
||||||
|
alt keycode 70 = Scroll_Lock
|
||||||
|
@ -1,5 +1,6 @@
|
|||||||
--- kbd-1.08/data/keymaps/i386/qwerty/ru.map.orig 2003-07-30 12:00:51.000000000 -0400
|
diff -up kbd-1.12/data/keymaps/i386/qwerty/ru.map.rukbd kbd-1.12/data/keymaps/i386/qwerty/ru.map
|
||||||
+++ kbd-1.08/data/keymaps/i386/qwerty/ru.map 2003-07-30 12:01:08.000000000 -0400
|
--- kbd-1.12/data/keymaps/i386/qwerty/ru.map.rukbd 2002-10-13 02:02:19.000000000 +0200
|
||||||
|
+++ kbd-1.12/data/keymaps/i386/qwerty/ru.map 2008-09-18 12:18:06.000000000 +0200
|
||||||
@@ -1,287 +1,609 @@
|
@@ -1,287 +1,609 @@
|
||||||
-! Russian Cyrillic keyboard.map. "Cyrillic" mode is toggled by
|
-! Russian Cyrillic keyboard.map. "Cyrillic" mode is toggled by
|
||||||
-! Right_Ctrl key and shifted by AltGr key.
|
-! Right_Ctrl key and shifted by AltGr key.
|
||||||
|
@ -1,14 +1,13 @@
|
|||||||
Output terminal control sequences only when output is a terminal.
|
diff -up kbd-1.12/src/unicode_start.terminal kbd-1.12/src/unicode_start
|
||||||
|
--- kbd-1.12/src/unicode_start.terminal 2001-02-12 17:30:17.000000000 +0100
|
||||||
--- kbd-1.08/src/unicode_start 2002-11-22 19:23:00.000000000 -0500
|
+++ kbd-1.12/src/unicode_start 2008-09-08 17:24:51.000000000 +0200
|
||||||
+++ kbd-1.08/src/unicode_start 2002-11-22 19:24:34.000000000 -0500
|
|
||||||
@@ -1,4 +1,4 @@
|
@@ -1,4 +1,4 @@
|
||||||
-#!/bin/sh
|
-#!/bin/sh
|
||||||
+#!/bin/bash
|
+#!/bin/bash
|
||||||
# Enables Unicode processing in the current console.
|
# Enables Unicode processing in the current console.
|
||||||
#
|
#
|
||||||
# 1. The input side: the keyboard driver.
|
# 1. The input side: the keyboard driver.
|
||||||
@@ -25,7 +25,9 @@
|
@@ -25,14 +25,16 @@ dumpkeys | loadkeys --unicode
|
||||||
# Tell the console output driver that the bytes arriving are UTF-8
|
# Tell the console output driver that the bytes arriving are UTF-8
|
||||||
# encoded multibyte sequences.
|
# encoded multibyte sequences.
|
||||||
|
|
||||||
@ -19,8 +18,17 @@ Output terminal control sequences only when output is a terminal.
|
|||||||
|
|
||||||
# Tell the graphics card how to display Unicode characters not
|
# Tell the graphics card how to display Unicode characters not
|
||||||
# contained in the IBM 437 character set (on PCs). The font should
|
# contained in the IBM 437 character set (on PCs). The font should
|
||||||
--- kbd-1.08/src/unicode_stop 2002-11-22 19:23:30.000000000 -0500
|
# have a Unicode map attached, or explicitly specified, e.g.,
|
||||||
+++ kbd-1.08/src/unicode_stop 2002-11-22 19:24:15.000000000 -0500
|
# by giving `def.uni' as a second argument.
|
||||||
|
|
||||||
|
-DEFAULT_UNICODE_FONT=LatArCyrHeb-16
|
||||||
|
+DEFAULT_UNICODE_FONT=latarcyrheb-sun16
|
||||||
|
# Also drdos8x16 is a good candidate.
|
||||||
|
|
||||||
|
case $# in
|
||||||
|
diff -up kbd-1.12/src/unicode_stop.terminal kbd-1.12/src/unicode_stop
|
||||||
|
--- kbd-1.12/src/unicode_stop.terminal 1997-11-13 14:22:52.000000000 +0100
|
||||||
|
+++ kbd-1.12/src/unicode_stop 2008-09-08 17:24:51.000000000 +0200
|
||||||
@@ -1,4 +1,6 @@
|
@@ -1,4 +1,6 @@
|
||||||
#!/bin/sh
|
#!/bin/sh
|
||||||
# stop unicode
|
# stop unicode
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- kbd-1.12/src/ksyms.c.org 2005-01-11 16:38:32.000000000 +0100
|
diff -up kbd-1.12/src/ksyms.c.Meta_utf8 kbd-1.12/src/ksyms.c
|
||||||
+++ kbd-1.12/src/ksyms.c 2005-01-11 16:46:19.000000000 +0100
|
--- kbd-1.12/src/ksyms.c.Meta_utf8 2004-01-16 20:45:31.000000000 +0100
|
||||||
@@ -1710,6 +1710,8 @@
|
+++ kbd-1.12/src/ksyms.c 2008-09-18 12:20:02.000000000 +0200
|
||||||
|
@@ -1710,6 +1710,8 @@ ksymtocode(const char *s) {
|
||||||
keycode = ksymtocode(s+5);
|
keycode = ksymtocode(s+5);
|
||||||
if (KTYP(keycode) == KT_LATIN)
|
if (KTYP(keycode) == KT_LATIN)
|
||||||
return K(KT_META, KVAL(keycode));
|
return K(KT_META, KVAL(keycode));
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -u kbd-1.12/src/psffontop.c kbd-1.12/src/psffontop.c
|
diff -up kbd-1.12/src/psffontop.c.alias kbd-1.12/src/psffontop.c
|
||||||
--- kbd-1.12/src/psffontop.c 2005-03-12 00:48:30.075310872 +0100
|
--- kbd-1.12/src/psffontop.c.alias 2004-01-16 20:45:31.000000000 +0100
|
||||||
+++ kbd-1.12/src/psffontop.c 2005-05-14 10:49:59.000000000 +0900
|
+++ kbd-1.12/src/psffontop.c 2008-09-18 12:20:55.000000000 +0200
|
||||||
@@ -59,7 +59,6 @@
|
@@ -59,7 +59,6 @@ store_int_le(unsigned char *ip, int num)
|
||||||
|
|
||||||
static unsigned int
|
static unsigned int
|
||||||
assemble_ucs2(char **inptr, int cnt) {
|
assemble_ucs2(char **inptr, int cnt) {
|
||||||
@ -9,7 +9,7 @@ diff -u kbd-1.12/src/psffontop.c kbd-1.12/src/psffontop.c
|
|||||||
unsigned int u1, u2;
|
unsigned int u1, u2;
|
||||||
|
|
||||||
if (cnt < 2) {
|
if (cnt < 2) {
|
||||||
@@ -68,8 +67,8 @@
|
@@ -68,8 +67,8 @@ assemble_ucs2(char **inptr, int cnt) {
|
||||||
exit(EX_DATAERR);
|
exit(EX_DATAERR);
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -20,7 +20,7 @@ diff -u kbd-1.12/src/psffontop.c kbd-1.12/src/psffontop.c
|
|||||||
return (u1 | (u2 << 8));
|
return (u1 | (u2 << 8));
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -110,7 +109,6 @@
|
@@ -110,7 +109,6 @@ clear_uni_entry(struct unicode_list *up)
|
||||||
*/
|
*/
|
||||||
static void
|
static void
|
||||||
get_uni_entry(char **inptr, char **endptr, struct unicode_list *up, int utf8) {
|
get_uni_entry(char **inptr, char **endptr, struct unicode_list *up, int utf8) {
|
||||||
@ -28,7 +28,7 @@ diff -u kbd-1.12/src/psffontop.c kbd-1.12/src/psffontop.c
|
|||||||
unsigned char uc;
|
unsigned char uc;
|
||||||
unicode unichar;
|
unicode unichar;
|
||||||
int inseq = 0;
|
int inseq = 0;
|
||||||
@@ -126,14 +124,14 @@
|
@@ -126,14 +124,14 @@ get_uni_entry(char **inptr, char **endpt
|
||||||
exit(EX_DATAERR);
|
exit(EX_DATAERR);
|
||||||
}
|
}
|
||||||
if (utf8) {
|
if (utf8) {
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
|
diff -up kbd-1.12/src/findfile.c.dir kbd-1.12/src/findfile.c
|
||||||
--- kbd-1.12/src/findfile.c.dir 2004-01-16 20:45:31.000000000 +0100
|
--- kbd-1.12/src/findfile.c.dir 2004-01-16 20:45:31.000000000 +0100
|
||||||
+++ kbd-1.12/src/findfile.c 2005-05-20 15:36:45.000000000 +0200
|
+++ kbd-1.12/src/findfile.c 2008-09-18 12:21:17.000000000 +0200
|
||||||
@@ -92,6 +92,7 @@
|
@@ -92,6 +92,7 @@ findfile_in_dir(char *fnam, char *dir, i
|
||||||
if (d == NULL)
|
if (d == NULL)
|
||||||
return NULL;
|
return NULL;
|
||||||
while ((de = readdir(d)) != NULL) {
|
while ((de = readdir(d)) != NULL) {
|
||||||
@ -8,7 +9,7 @@
|
|||||||
int okdir;
|
int okdir;
|
||||||
|
|
||||||
if (strcmp(de->d_name, ".") == 0 ||
|
if (strcmp(de->d_name, ".") == 0 ||
|
||||||
@@ -104,7 +105,6 @@
|
@@ -104,7 +105,6 @@ findfile_in_dir(char *fnam, char *dir, i
|
||||||
okdir = (ff && strcmp(de->d_name, fdir) == 0);
|
okdir = (ff && strcmp(de->d_name, fdir) == 0);
|
||||||
|
|
||||||
if ((secondpass && recdepth) || okdir) {
|
if ((secondpass && recdepth) || okdir) {
|
||||||
@ -16,7 +17,7 @@
|
|||||||
char *a;
|
char *a;
|
||||||
|
|
||||||
a = xmalloc(strlen(dir) + strlen(de->d_name) + 2);
|
a = xmalloc(strlen(dir) + strlen(de->d_name) + 2);
|
||||||
@@ -136,6 +136,8 @@
|
@@ -136,6 +136,8 @@ findfile_in_dir(char *fnam, char *dir, i
|
||||||
continue;
|
continue;
|
||||||
|
|
||||||
sprintf(pathname, "%s/%s", dir, de->d_name);
|
sprintf(pathname, "%s/%s", dir, de->d_name);
|
||||||
@ -25,7 +26,7 @@
|
|||||||
|
|
||||||
/* Does tail consist of a known suffix and possibly
|
/* Does tail consist of a known suffix and possibly
|
||||||
a compression suffix? */
|
a compression suffix? */
|
||||||
@@ -180,13 +182,16 @@
|
@@ -180,13 +182,16 @@ FILE *findfile(char *fnam, char **dirpat
|
||||||
/* Test for full pathname - opening it failed, so need suffix */
|
/* Test for full pathname - opening it failed, so need suffix */
|
||||||
/* (This is just nonsense, for backwards compatibility.) */
|
/* (This is just nonsense, for backwards compatibility.) */
|
||||||
if (*fnam == '/') {
|
if (*fnam == '/') {
|
||||||
@ -43,7 +44,7 @@
|
|||||||
return fp;
|
return fp;
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -196,7 +201,9 @@
|
@@ -196,7 +201,9 @@ FILE *findfile(char *fnam, char **dirpat
|
||||||
+ strlen(dc->ext) + 1 > sizeof(pathname))
|
+ strlen(dc->ext) + 1 > sizeof(pathname))
|
||||||
continue;
|
continue;
|
||||||
sprintf(pathname, "%s%s%s", fnam, *sp, dc->ext);
|
sprintf(pathname, "%s%s%s", fnam, *sp, dc->ext);
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- kbd-1.12/po/Makefile.in.gr-el 2006-10-31 03:42:15.000000000 +0100
|
diff -up kbd-1.12/po/Makefile.in.gr-el kbd-1.12/po/Makefile.in
|
||||||
+++ kbd-1.12/po/Makefile.in 2006-10-31 03:42:33.000000000 +0100
|
--- kbd-1.12/po/Makefile.in.gr-el 2004-01-03 16:46:07.000000000 +0100
|
||||||
@@ -34,9 +34,9 @@
|
+++ kbd-1.12/po/Makefile.in 2008-09-18 12:22:12.000000000 +0200
|
||||||
|
@@ -34,9 +34,9 @@ INCLUDES = -I.. -I$(INTL)
|
||||||
COMPILE = $(CC) -c $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS)
|
COMPILE = $(CC) -c $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS)
|
||||||
|
|
||||||
# Enter here all .po files
|
# Enter here all .po files
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- kbd-1.12/man/man1/showkey.1.keycodes-man 2006-12-07 17:37:00.000000000 +0100
|
diff -up kbd-1.12/man/man1/showkey.1.keycodes-man kbd-1.12/man/man1/showkey.1
|
||||||
+++ kbd-1.12/man/man1/showkey.1 2006-12-07 18:03:08.000000000 +0100
|
--- kbd-1.12/man/man1/showkey.1.keycodes-man 2002-10-11 13:08:58.000000000 +0200
|
||||||
@@ -66,6 +66,19 @@
|
+++ kbd-1.12/man/man1/showkey.1 2008-09-18 12:22:38.000000000 +0200
|
||||||
|
@@ -66,6 +66,19 @@ are present.
|
||||||
Starts
|
Starts
|
||||||
.B showkey
|
.B showkey
|
||||||
in `ascii' dump mode.
|
in `ascii' dump mode.
|
||||||
@ -20,9 +21,10 @@
|
|||||||
.SH "SEE ALSO"
|
.SH "SEE ALSO"
|
||||||
.BR loadkeys (1),
|
.BR loadkeys (1),
|
||||||
.BR dumpkeys (1),
|
.BR dumpkeys (1),
|
||||||
--- kbd-1.12/man/man8/setkeycodes.8.keycodes-man 2006-12-07 18:00:40.000000000 +0100
|
diff -up kbd-1.12/man/man8/setkeycodes.8.keycodes-man kbd-1.12/man/man8/setkeycodes.8
|
||||||
+++ kbd-1.12/man/man8/setkeycodes.8 2006-12-07 18:05:24.000000000 +0100
|
--- kbd-1.12/man/man8/setkeycodes.8.keycodes-man 2002-10-11 13:08:58.000000000 +0200
|
||||||
@@ -40,11 +40,24 @@
|
+++ kbd-1.12/man/man8/setkeycodes.8 2008-09-18 12:22:38.000000000 +0200
|
||||||
|
@@ -40,11 +40,24 @@ to showkey(1), the command
|
||||||
.RE
|
.RE
|
||||||
will assign the keycode 112 to it, and then loadkeys(1) can be used
|
will assign the keycode 112 to it, and then loadkeys(1) can be used
|
||||||
to define the function of this key.
|
to define the function of this key.
|
||||||
|
@ -1,9 +1,6 @@
|
|||||||
Non-root users are allowed to change the unicode mode of their console, but
|
diff -up kbd-1.12/src/unicode_start.no-user-map kbd-1.12/src/unicode_start
|
||||||
not the global keymap. root will have to load the keymap in unicode mode
|
--- kbd-1.12/src/unicode_start.no-user-map 2008-09-18 12:21:37.000000000 +0200
|
||||||
explicitly.
|
+++ kbd-1.12/src/unicode_start 2008-09-18 12:21:37.000000000 +0200
|
||||||
|
|
||||||
--- kbd-1.12/src/unicode_start.no-user-map 2005-12-01 19:33:19.000000000 +0100
|
|
||||||
+++ kbd-1.12/src/unicode_start 2005-12-01 19:33:28.000000000 +0100
|
|
||||||
@@ -14,12 +14,6 @@
|
@@ -14,12 +14,6 @@
|
||||||
|
|
||||||
kbd_mode -u
|
kbd_mode -u
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- kbd-1.12/src/Makefile.in.nostrip 2005-03-06 21:51:58.185047112 +0100
|
diff -up kbd-1.12/src/Makefile.in.nostrip kbd-1.12/src/Makefile.in
|
||||||
+++ kbd-1.12/src/Makefile.in 2005-03-06 21:52:19.791762392 +0100
|
--- kbd-1.12/src/Makefile.in.nostrip 2004-01-03 18:53:54.000000000 +0100
|
||||||
@@ -72,14 +72,14 @@
|
+++ kbd-1.12/src/Makefile.in 2008-09-18 12:20:30.000000000 +0200
|
||||||
|
@@ -72,14 +72,14 @@ old: $(OLDPROGS)
|
||||||
|
|
||||||
install: all
|
install: all
|
||||||
install -d -m 0755 $(BINDIR) $(LOADKEYS_BINDIR)
|
install -d -m 0755 $(BINDIR) $(LOADKEYS_BINDIR)
|
||||||
|
@ -1,6 +1,7 @@
|
|||||||
--- kbd-1.12/src/Makefile.in_old 2007-10-16 14:14:51.000000000 +0200
|
diff -up kbd-1.12/src/Makefile.in.resizecon-x86 kbd-1.12/src/Makefile.in
|
||||||
+++ kbd-1.12/src/Makefile.in 2007-10-16 15:27:38.000000000 +0200
|
--- kbd-1.12/src/Makefile.in.resizecon-x86 2008-09-18 12:23:11.000000000 +0200
|
||||||
@@ -43,6 +43,10 @@
|
+++ kbd-1.12/src/Makefile.in 2008-09-18 12:23:11.000000000 +0200
|
||||||
|
@@ -43,6 +43,10 @@ ifeq ($(ARCH), i386)
|
||||||
PROGS += resizecons
|
PROGS += resizecons
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
diff -Nrbu kbd-1.12/man/man8/setfont.8.in kbd-1.12-OK/man/man8/setfont.8.in
|
diff -up kbd-1.12/man/man8/setfont.8.in.man kbd-1.12/man/man8/setfont.8.in
|
||||||
--- kbd-1.12/man/man8/setfont.8.in 2004-01-03 07:15:59.000000000 +0300
|
--- kbd-1.12/man/man8/setfont.8.in.man 2004-01-03 05:15:59.000000000 +0100
|
||||||
+++ kbd-1.12-OK/man/man8/setfont.8.in 2004-11-26 19:20:15.000000000 +0300
|
+++ kbd-1.12/man/man8/setfont.8.in 2008-09-18 12:19:14.000000000 +0200
|
||||||
@@ -50,6 +50,10 @@
|
@@ -50,6 +50,10 @@ and provide one explicitly.
|
||||||
Load a given font (here a 512-glyph font combining several
|
Load a given font (here a 512-glyph font combining several
|
||||||
character sets) and indicate that one's local character set
|
character sets) and indicate that one's local character set
|
||||||
is ISO 8859-2.
|
is ISO 8859-2.
|
||||||
|
@ -1,24 +1,21 @@
|
|||||||
--- kbd-1.08/man/man8/kbdrate.8 2002-10-11 07:08:58.000000000 -0400
|
diff -up kbd-1.12/src/setleds.c.sparc kbd-1.12/src/setleds.c
|
||||||
+++ kbd-1.08/man/man8/kbdrate.8 2002-11-22 17:28:15.000000000 -0500
|
--- kbd-1.12/src/setleds.c.sparc 2004-01-16 20:45:31.000000000 +0100
|
||||||
@@ -22,7 +22,7 @@
|
+++ kbd-1.12/src/setleds.c 2008-09-08 17:20:46.000000000 +0200
|
||||||
without any options will reset the repeat rate to 10.9 characters per second (cps)
|
@@ -14,10 +14,6 @@
|
||||||
and the delay to 250 milliseconds (ms) for Intel- and M68K-based systems.
|
#include "nls.h"
|
||||||
These are the IBM defaults. On SPARC-based systems it will reset the repeat rate
|
#include "version.h"
|
||||||
-to 5 cps and the delay to 200 ms.
|
|
||||||
+to 20 cps and the delay to 200 ms.
|
|
||||||
|
|
||||||
.SH OPTIONS
|
-#ifdef __sparc__
|
||||||
.TP
|
-#include <asm/kbio.h>
|
||||||
@@ -69,3 +69,5 @@
|
-#endif
|
||||||
.I /etc/rc.local
|
-
|
||||||
.br
|
static void
|
||||||
.I /dev/port
|
usage(void)
|
||||||
+.br
|
{
|
||||||
+.I /dev/kbd
|
diff -up kbd-1.12/src/kbdrate.c.sparc kbd-1.12/src/kbdrate.c
|
||||||
diff -u kbd-1.08/src/kbdrate.c kbd-1.12/src/kbdrate.c
|
--- kbd-1.12/src/kbdrate.c.sparc 2004-01-16 20:45:31.000000000 +0100
|
||||||
--- kbd-1.08/src/kbdrate.c 2002-11-22 17:34:48.000000000 -0500
|
+++ kbd-1.12/src/kbdrate.c 2008-09-08 17:20:46.000000000 +0200
|
||||||
+++ kbd-1.12/src/kbdrate.c 2006-07-08 05:16:33.000000000 -0500
|
@@ -77,7 +77,6 @@ beats rebuilding the kernel!
|
||||||
@@ -77,7 +77,6 @@
|
|
||||||
|
|
||||||
#ifdef __sparc__
|
#ifdef __sparc__
|
||||||
#include <asm/param.h>
|
#include <asm/param.h>
|
||||||
@ -26,7 +23,7 @@ diff -u kbd-1.08/src/kbdrate.c kbd-1.12/src/kbdrate.c
|
|||||||
#endif
|
#endif
|
||||||
|
|
||||||
#ifndef KDKBDREP
|
#ifndef KDKBDREP
|
||||||
@@ -104,8 +103,11 @@
|
@@ -104,8 +103,11 @@ static int valid_delays[] = { 250, 500,
|
||||||
|
|
||||||
static int
|
static int
|
||||||
KDKBDREP_ioctl_ok(double rate, int delay, int silent) {
|
KDKBDREP_ioctl_ok(double rate, int delay, int silent) {
|
||||||
@ -39,7 +36,7 @@ diff -u kbd-1.08/src/kbdrate.c kbd-1.12/src/kbdrate.c
|
|||||||
struct kbd_repeat kbdrep_s;
|
struct kbd_repeat kbdrep_s;
|
||||||
|
|
||||||
/* don't change, just test */
|
/* don't change, just test */
|
||||||
@@ -150,6 +152,9 @@
|
@@ -150,6 +152,9 @@ KDKBDREP_ioctl_ok(double rate, int delay
|
||||||
rate, kbdrep_s.delay );
|
rate, kbdrep_s.delay );
|
||||||
|
|
||||||
return 1; /* success! */
|
return 1; /* success! */
|
||||||
@ -49,7 +46,7 @@ diff -u kbd-1.08/src/kbdrate.c kbd-1.12/src/kbdrate.c
|
|||||||
}
|
}
|
||||||
|
|
||||||
static int
|
static int
|
||||||
@@ -188,7 +193,7 @@
|
@@ -188,7 +193,7 @@ KIOCSRATE_ioctl_ok(double rate, int dela
|
||||||
int
|
int
|
||||||
main( int argc, char **argv ) {
|
main( int argc, char **argv ) {
|
||||||
#ifdef __sparc__
|
#ifdef __sparc__
|
||||||
@ -58,7 +55,7 @@ diff -u kbd-1.08/src/kbdrate.c kbd-1.12/src/kbdrate.c
|
|||||||
int delay = 200; /* Default delay */
|
int delay = 200; /* Default delay */
|
||||||
#else
|
#else
|
||||||
double rate = 10.9; /* Default rate */
|
double rate = 10.9; /* Default rate */
|
||||||
@@ -238,8 +243,9 @@
|
@@ -238,8 +243,9 @@ main( int argc, char **argv ) {
|
||||||
return 0;
|
return 0;
|
||||||
|
|
||||||
|
|
||||||
@ -69,23 +66,29 @@ diff -u kbd-1.08/src/kbdrate.c kbd-1.12/src/kbdrate.c
|
|||||||
for (i = 0; i < RATE_COUNT; i++)
|
for (i = 0; i < RATE_COUNT; i++)
|
||||||
if (rate * 10 >= valid_rates[i]) {
|
if (rate * 10 >= valid_rates[i]) {
|
||||||
value &= 0x60;
|
value &= 0x60;
|
||||||
@@ -286,4 +292,6 @@
|
@@ -285,5 +291,7 @@ main( int argc, char **argv ) {
|
||||||
|
valid_rates[value & 0x1f] / 10.0,
|
||||||
valid_delays[ (value & 0x60) >> 5 ] );
|
valid_delays[ (value & 0x60) >> 5 ] );
|
||||||
|
|
||||||
+#endif
|
+#endif
|
||||||
+
|
+
|
||||||
return 0;
|
return 0;
|
||||||
}
|
}
|
||||||
--- kbd-1.12-orig/src/setleds.c 2006-07-08 05:10:08.000000000 -0500
|
diff -up kbd-1.12/man/man8/kbdrate.8.sparc kbd-1.12/man/man8/kbdrate.8
|
||||||
+++ kbd-1.12/src/setleds.c 2006-07-08 05:10:36.000000000 -0500
|
--- kbd-1.12/man/man8/kbdrate.8.sparc 2002-10-11 13:08:58.000000000 +0200
|
||||||
@@ -14,10 +14,6 @@
|
+++ kbd-1.12/man/man8/kbdrate.8 2008-09-08 17:20:46.000000000 +0200
|
||||||
#include "nls.h"
|
@@ -22,7 +22,7 @@ Using
|
||||||
#include "version.h"
|
without any options will reset the repeat rate to 10.9 characters per second (cps)
|
||||||
|
and the delay to 250 milliseconds (ms) for Intel- and M68K-based systems.
|
||||||
|
These are the IBM defaults. On SPARC-based systems it will reset the repeat rate
|
||||||
|
-to 5 cps and the delay to 200 ms.
|
||||||
|
+to 20 cps and the delay to 200 ms.
|
||||||
|
|
||||||
-#ifdef __sparc__
|
.SH OPTIONS
|
||||||
-#include <asm/kbio.h>
|
.TP
|
||||||
-#endif
|
@@ -69,3 +69,5 @@ When these ioctls fail an ioport interfa
|
||||||
-
|
.I /etc/rc.local
|
||||||
static void
|
.br
|
||||||
usage(void)
|
.I /dev/port
|
||||||
{
|
+.br
|
||||||
|
+.I /dev/kbd
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
diff -up kbd-1.12/data/keymaps/i386/qwerty/trq.map_old kbd-1.12/data/keymaps/i386/qwerty/trq.map
|
diff -up kbd-1.12/data/keymaps/i386/qwerty/trq.map.trq-map kbd-1.12/data/keymaps/i386/qwerty/trq.map
|
||||||
--- kbd-1.12/data/keymaps/i386/qwerty/trq.map_old 2002-10-11 13:08:49.000000000 +0200
|
--- kbd-1.12/data/keymaps/i386/qwerty/trq.map.trq-map 2002-10-11 13:08:49.000000000 +0200
|
||||||
+++ kbd-1.12/data/keymaps/i386/qwerty/trq.map 2008-02-26 12:04:16.000000000 +0100
|
+++ kbd-1.12/data/keymaps/i386/qwerty/trq.map 2008-09-18 12:23:33.000000000 +0200
|
||||||
@@ -1,5 +1,5 @@
|
@@ -1,5 +1,5 @@
|
||||||
charset "iso-8859-9"
|
charset "iso-8859-9"
|
||||||
-keymaps 0-6,8-9,12
|
-keymaps 0-6,8-9,12
|
||||||
|
19
kbd.spec
19
kbd.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
||||||
Name: kbd
|
Name: kbd
|
||||||
Version: 1.12
|
Version: 1.12
|
||||||
Release: 31%{?dist}
|
Release: 32%{?dist}
|
||||||
# Except possibly for the restrictions mentioned in the directory consolefonts
|
# Except possibly for the restrictions mentioned in the directory consolefonts
|
||||||
License: GPL+
|
License: GPL+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -42,9 +42,9 @@ fonts, the virtual terminals and font files.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -a 2 -a 3 -a 4 -a 5 -a 6
|
%setup -q -a 2 -a 3 -a 4 -a 5 -a 6
|
||||||
%patch0 -p1 -b .sparc
|
%patch0 -p1 -b .sparc
|
||||||
%patch1 -p1
|
%patch1 -p1 -b .compose
|
||||||
%patch2 -p1 -b .terminal
|
%patch2 -p1 -b .terminal
|
||||||
%patch3 -p1
|
%patch3 -p1 -b .rukbd
|
||||||
%patch4 -p1 -b .man
|
%patch4 -p1 -b .man
|
||||||
%patch5 -p1 -b .Meta_utf8
|
%patch5 -p1 -b .Meta_utf8
|
||||||
%patch6 -p1 -b .nostrip
|
%patch6 -p1 -b .nostrip
|
||||||
@ -80,6 +80,11 @@ export OLD_PO_FILE_INPUT=yes
|
|||||||
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
||||||
./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
|
./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
|
||||||
|
|
||||||
|
make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-static"
|
||||||
|
mv src/loadkeys src/loadkeys.static
|
||||||
|
make clean
|
||||||
|
./configure --prefix=%{_prefix} --datadir=/lib/kbd --mandir=%{_mandir}
|
||||||
|
|
||||||
# Override CFLAGS because this configure ignores them anyway, and LDFLAGS
|
# Override CFLAGS because this configure ignores them anyway, and LDFLAGS
|
||||||
# because it defaults to -s, but that's a build policy decision.
|
# because it defaults to -s, but that's a build policy decision.
|
||||||
make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
|
make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
|
||||||
@ -112,6 +117,9 @@ sed -i -e 's,\<kbd_mode\>,/bin/kbd_mode,g;s,\<setfont\>,/bin/setfont,g' \
|
|||||||
# Link open to openvt
|
# Link open to openvt
|
||||||
ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
|
ln -s openvt $RPM_BUILD_ROOT%{_bindir}/open
|
||||||
|
|
||||||
|
# install static binary for mkinitrd to use
|
||||||
|
install -c -m755 src/loadkeys.static $RPM_BUILD_ROOT/bin
|
||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -129,6 +137,11 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
/lib/kbd
|
/lib/kbd
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Sep 8 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.12-32
|
||||||
|
- Rediff all patches to work with patch --fuzz=0
|
||||||
|
- Add static loadkeys
|
||||||
|
Related: #451672
|
||||||
|
|
||||||
* Tue Feb 26 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.12-31
|
* Tue Feb 26 2008 Vitezslav Crhonek <vcrhonek@redhat.com> - 1.12-31
|
||||||
- Fix trq.map
|
- Fix trq.map
|
||||||
Resolves: #216710
|
Resolves: #216710
|
||||||
|
Loading…
Reference in New Issue
Block a user