auto-import changelog data from kbd-1.08-4.src.rpm
Thu Jan 30 2003 Bill Nottingham <notting@redhat.com> 1.08-4 - remove condrestart from initscript Wed Jan 22 2003 Tim Powers <timp@redhat.com> - rebuilt Fri Dec 06 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-2 - only output terminal unicode init sequence if both stdout and stderr are connected to terminals, so that it doesn't show up when script outputs get piped to files Fri Nov 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-1 - update to 1.08 - drop updates which went mainline Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-27 - add detached signature - remove directory names from PAM configuration so that the same config file can be used for any arch on multilib systems
This commit is contained in:
parent
e9f7111cdb
commit
32b2036c3c
@ -1,3 +1,2 @@
|
||||
kbd-1.06.tar.bz2
|
||||
kbd-1.08.tar.bz2
|
||||
kbd-latsun-fonts.tar.bz2
|
||||
kbd-update-cyr.tar.bz2
|
||||
|
49
kbd-1.08-compose.patch
Normal file
49
kbd-1.08-compose.patch
Normal file
@ -0,0 +1,49 @@
|
||||
Map the PrintScreen key and Alt+AltGr to Compose.
|
||||
|
||||
--- kbd-1.08/data/keymaps/i386/include/compose.inc 2002-10-04 14:48:04.000000000 -0400
|
||||
+++ kbd-1.08/data/keymaps/i386/include/compose.inc 2002-11-22 17:36:32.000000000 -0500
|
||||
@@ -0,0 +1,8 @@
|
||||
+# We map the PrintScreen key (useless) and Alt+AltGr to the Compose key...
|
||||
+# A really useful thing not found on normal keyboards. :/
|
||||
+#
|
||||
+# (c) 2001 Bernhard Rosenkränzer <bero@arklinux.org>
|
||||
+
|
||||
+keycode 99 = Compose # SysRq/PrintScrn
|
||||
+keycode 100 = AltGr
|
||||
+alt keycode 100 = Compose
|
||||
--- kbd-1.08/data/keymaps/i386/include/qwerty-layout.inc 2002-10-11 07:08:50.000000000 -0400
|
||||
+++ kbd-1.08/data/keymaps/i386/include/qwerty-layout.inc 2002-11-22 17:36:32.000000000 -0500
|
||||
@@ -28,3 +28,4 @@
|
||||
keycode 49 = n
|
||||
keycode 50 = m
|
||||
#
|
||||
+include "compose"
|
||||
--- kbd-1.08/data/keymaps/i386/include/qwertz-layout.inc 2002-10-11 07:08:50.000000000 -0400
|
||||
+++ kbd-1.08/data/keymaps/i386/include/qwertz-layout.inc 2002-11-22 17:36:32.000000000 -0500
|
||||
@@ -28,3 +28,4 @@
|
||||
keycode 49 = n
|
||||
keycode 50 = m
|
||||
#
|
||||
+include "compose"
|
||||
--- kbd-1.08/data/keymaps/i386/include/linux-with-alt-and-altgr.inc 2002-10-11 07:08:50.000000000 -0400
|
||||
+++ kbd-1.08/data/keymaps/i386/include/linux-with-alt-and-altgr.inc 2002-11-22 17:36:32.000000000 -0500
|
||||
@@ -1,6 +1,7 @@
|
||||
include "linux-keys-bare"
|
||||
|
||||
keycode 100 = AltGr
|
||||
+alt keycode 100 = Compose
|
||||
|
||||
altgr keycode 70 = Show_Registers
|
||||
alt keycode 70 = Scroll_Lock
|
||||
--- kbd-1.08/data/keymaps/i386/include/linux-keys-bare.inc 2002-10-12 20:14:06.000000000 -0400
|
||||
+++ kbd-1.08/data/keymaps/i386/include/linux-keys-bare.inc 2002-11-22 17:42:04.000000000 -0500
|
||||
@@ -148,7 +148,8 @@
|
||||
# The three system keys
|
||||
#
|
||||
keycode 84 = Last_Console # Alt+SysRq/PrintScrn
|
||||
-keycode 99 = VoidSymbol # SysRq/PrintScrn
|
||||
+#keycode 99 = VoidSymbol # SysRq/PrintScrn
|
||||
+keycode 99 = Compose # SysRq/PrintScrn
|
||||
alt keycode 99 = Control_backslash
|
||||
control keycode 99 = Control_backslash
|
||||
|
31
kbd-1.08-terminal.patch
Normal file
31
kbd-1.08-terminal.patch
Normal file
@ -0,0 +1,31 @@
|
||||
Output terminal control sequences only when output is a terminal.
|
||||
|
||||
--- kbd-1.08/src/unicode_start 2002-11-22 19:23:00.000000000 -0500
|
||||
+++ kbd-1.08/src/unicode_start 2002-11-22 19:24:34.000000000 -0500
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/bin/sh
|
||||
+#!/bin/bash
|
||||
# Enables Unicode processing in the current console.
|
||||
#
|
||||
# 1. The input side: the keyboard driver.
|
||||
@@ -25,7 +25,9 @@
|
||||
# Tell the console output driver that the bytes arriving are UTF-8
|
||||
# encoded multibyte sequences.
|
||||
|
||||
-echo -n -e '\033%G'
|
||||
+if test -t 1 -a -t 2 ; then
|
||||
+ echo -n -e '\033%G'
|
||||
+fi
|
||||
|
||||
# Tell the graphics card how to display Unicode characters not
|
||||
# contained in the IBM 437 character set (on PCs). The font should
|
||||
--- kbd-1.08/src/unicode_stop 2002-11-22 19:23:30.000000000 -0500
|
||||
+++ kbd-1.08/src/unicode_stop 2002-11-22 19:24:15.000000000 -0500
|
||||
@@ -1,4 +1,6 @@
|
||||
#!/bin/sh
|
||||
# stop unicode
|
||||
kbd_mode -a
|
||||
-echo -n -e '\033%@'
|
||||
+if test -t ; then
|
||||
+ echo -n -e '\033%@'
|
||||
+fi
|
97
kbd.spec
97
kbd.spec
@ -1,22 +1,22 @@
|
||||
Summary: Tools for configuring the console (keyboard, virtual terminals, etc.)
|
||||
Name: kbd
|
||||
Version: 1.06
|
||||
Release: 26
|
||||
Version: 1.08
|
||||
Release: 4
|
||||
License: GPL
|
||||
Group: System Environment/Base
|
||||
Source0: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2
|
||||
Source1: kbdrate.apps
|
||||
Source2: kbdrate.pam
|
||||
Source3: keytable.init
|
||||
Source4: kbd-update-cyr.tar.bz2
|
||||
Source1: ftp://ftp.kernel.org/pub/linux/utils/kbd/kbd-%{version}.tar.bz2.sign
|
||||
Source2: kbdrate.apps
|
||||
Source3: kbdrate.pam
|
||||
Source4: keytable.init
|
||||
Source5: kbd-latsun-fonts.tar.bz2
|
||||
Requires: pam >= 0.66-4, /etc/pam.d/system-auth, usermode
|
||||
BuildRoot: %{_tmppath}/%{name}-root
|
||||
Patch: kbd-1.05-sparc.patch
|
||||
Patch1: kbd-1.06-compose.patch
|
||||
Patch2: kbd-1.0.6-cflags.patch
|
||||
Patch3: kbd-1.06-nonroot.patch
|
||||
Patch4: kbd-1.06-othervt.patch
|
||||
Patch0: kbd-1.08-sparc.patch
|
||||
Patch1: kbd-1.08-compose.patch
|
||||
Patch2: kbd-1.06-nonroot.patch
|
||||
Patch3: kbd-1.06-othervt.patch
|
||||
Patch4: kbd-1.08-terminal.patch
|
||||
Patch5: kbd-speakup.patch
|
||||
Obsoletes: console-tools
|
||||
Provides: console-tools
|
||||
@ -30,12 +30,12 @@ fonts, the virtual terminals and font files.
|
||||
|
||||
%prep
|
||||
|
||||
%setup -q -a 4 -a 5
|
||||
%patch -p1 -b .p0
|
||||
%patch1 -p1 -b .p1
|
||||
%patch2 -p1 -b .p2
|
||||
%patch3 -p1 -b .p3
|
||||
%patch4 -p1 -b .p4
|
||||
%setup -q -a 5
|
||||
%patch0 -p1 -b .sparc
|
||||
%patch1 -p1
|
||||
%patch2 -p1 -b .nonroot
|
||||
%patch3 -p1 -b .othervt
|
||||
%patch4 -p1 -b .terminal
|
||||
%patch5 -p0
|
||||
|
||||
# Default to latarcyrheb-sun16 font for unicode
|
||||
@ -48,33 +48,47 @@ export OLD_PO_FILE_INPUT=yes
|
||||
# (But we want them after an rpm -bp kbd.spec, so don't remove -b)
|
||||
find . -name "*.p[0-9]" |xargs rm -f
|
||||
|
||||
unset LINGUAS || :
|
||||
# We don't use % {configure} because the ./configure included here does not
|
||||
# understand most of the options.
|
||||
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
||||
./configure --prefix=/ --datadir=/lib/kbd --mandir=%{_mandir}
|
||||
|
||||
# we don't use % {configure} because the ./configure included here does not
|
||||
# understand most of the options
|
||||
CFLAGS="$RPM_OPT_FLAGS" ./configure --datadir=/lib/kbd \
|
||||
--mandir=%{_mandir}
|
||||
|
||||
cd src
|
||||
make
|
||||
# Override CFLAGS because this configure ignores them anyway, and LDFLAGS
|
||||
# because it defaults to -s, but that's a build policy decision.
|
||||
make CFLAGS="$RPM_OPT_FLAGS" LDFLAGS=
|
||||
|
||||
%install
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make install DESTDIR=${RPM_BUILD_ROOT}
|
||||
# Basic install.
|
||||
make install \
|
||||
BINDIR=$RPM_BUILD_ROOT/%{_bindir} \
|
||||
LOADKEYS_BINDIR=$RPM_BUILD_ROOT/bin \
|
||||
MANDIR=$RPM_BUILD_ROOT/%{_mandir} \
|
||||
datadir=$RPM_BUILD_ROOT/lib/kbd \
|
||||
DATADIR=$RPM_BUILD_ROOT/lib/kbd \
|
||||
gnulocaledir=$RPM_BUILD_ROOT/%{_datadir}/locale \
|
||||
localedir=$RPM_BUILD_ROOT/%{_datadir}/locale
|
||||
|
||||
# Move binaries which we use before /usr is mounted from %{_bindir} to /bin.
|
||||
for binary in setfont dumpkeys kbd_mode unicode_start unicode_stop ; do
|
||||
mv $RPM_BUILD_ROOT%{_bindir}/$binary $RPM_BUILD_ROOT/bin
|
||||
done
|
||||
|
||||
# Add init scripts
|
||||
install -d -m 755 $RPM_BUILD_ROOT/etc/rc.d/init.d
|
||||
install -m 755 %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/keytable
|
||||
install -m 755 %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/keytable
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sbindir} $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
|
||||
# Set up kbdrate to be userhelpered.
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sbindir}
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
|
||||
mv $RPM_BUILD_ROOT%{_bindir}/kbdrate $RPM_BUILD_ROOT%{_sbindir}
|
||||
ln -s consolehelper $RPM_BUILD_ROOT%{_bindir}/kbdrate
|
||||
install -c -m644 %SOURCE1 $RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kbdrate
|
||||
install -c -m644 %SOURCE2 $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kbdrate
|
||||
install -c -m644 $RPM_SOURCE_DIR/kbdrate.apps \
|
||||
$RPM_BUILD_ROOT%{_sysconfdir}/security/console.apps/kbdrate
|
||||
install -c -m644 $RPM_SOURCE_DIR/kbdrate.pam \
|
||||
$RPM_BUILD_ROOT%{_sysconfdir}/pam.d/kbdrate
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
@ -100,6 +114,7 @@ fi
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%doc CHANGES CREDITS README doc/*.txt doc/kbd.FAQ*.html doc/font-formats/*.html doc/utf/utf*
|
||||
/bin/*
|
||||
%{_bindir}/*
|
||||
%{_sbindir}/*
|
||||
@ -110,6 +125,26 @@ fi
|
||||
%config %{_sysconfdir}/pam.d/*
|
||||
|
||||
%changelog
|
||||
* Thu Jan 30 2003 Bill Nottingham <notting@redhat.com> 1.08-4
|
||||
- remove condrestart from initscript
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Dec 6 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-2
|
||||
- only output terminal unicode init sequence if both stdout and stderr are
|
||||
connected to terminals, so that it doesn't show up when script outputs
|
||||
get piped to files
|
||||
|
||||
* Fri Nov 22 2002 Nalin Dahyabhai <nalin@redhat.com> 1.08-1
|
||||
- update to 1.08
|
||||
- drop updates which went mainline
|
||||
|
||||
* Mon Nov 11 2002 Nalin Dahyabhai <nalin@redhat.com> 1.06-27
|
||||
- add detached signature
|
||||
- remove directory names from PAM configuration so that the same config file
|
||||
can be used for any arch on multilib systems
|
||||
|
||||
* Wed Sep 4 2002 Bill Nottingham <notting@redhat.com> 1.06-26
|
||||
- don't munge /etc/sysconfig/i18n
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
#%PAM-1.0
|
||||
auth sufficient /lib/security/pam_rootok.so
|
||||
auth required /lib/security/pam_console.so
|
||||
account required /lib/security/pam_permit.so
|
||||
auth sufficient pam_rootok.so
|
||||
auth required pam_console.so
|
||||
account required pam_permit.so
|
||||
|
Loading…
Reference in New Issue
Block a user