import kasumi-2.5-36.el9
This commit is contained in:
commit
9bead75357
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/kasumi-2.5.tar.gz
|
1
.kasumi.metadata
Normal file
1
.kasumi.metadata
Normal file
@ -0,0 +1 @@
|
||||
38155494d684f61e74ed1498ec90cc0fc68d791a SOURCES/kasumi-2.5.tar.gz
|
369
SOURCES/kasumi-1928410-gtk3.patch
Normal file
369
SOURCES/kasumi-1928410-gtk3.patch
Normal file
@ -0,0 +1,369 @@
|
||||
From 9de5eb6d221bf3438c75a756c9acffa01e2c51fb Mon Sep 17 00:00:00 2001
|
||||
From: fujiwarat <takao.fujiwara1@gmail.com>
|
||||
Date: Tue, 16 Feb 2021 07:45:51 +0900
|
||||
Subject: [PATCH] Migrate kasumi GUI to GTK3
|
||||
|
||||
---
|
||||
KasumiAddWindow.cxx | 41 ++++++++++------------
|
||||
KasumiAddWindow.hxx | 1 -
|
||||
KasumiMainWindow.cxx | 82 ++++++++++++++++++++++----------------------
|
||||
cellrendererspin.c | 16 +++++----
|
||||
cellrendererspin.h | 2 +-
|
||||
main.cxx | 15 ++++----
|
||||
6 files changed, 79 insertions(+), 78 deletions(-)
|
||||
|
||||
diff --git a/KasumiAddWindow.cxx b/KasumiAddWindow.cxx
|
||||
index 9b42c12..49c6a05 100644
|
||||
--- a/KasumiAddWindow.cxx
|
||||
+++ b/KasumiAddWindow.cxx
|
||||
@@ -59,9 +59,6 @@ KasumiAddWindow::KasumiAddWindow(KasumiDic *aDictionary,
|
||||
g_signal_connect(G_OBJECT(window), "delete_event",
|
||||
G_CALLBACK(_call_back_add_window_delete_event), this);
|
||||
|
||||
- // tooltips for every widget
|
||||
- Tooltips = gtk_tooltips_new();
|
||||
-
|
||||
// creating vbox for text entries, spin button and so on.
|
||||
GtkWidget *vbox = gtk_vbox_new(FALSE,0);
|
||||
gtk_container_set_border_width(GTK_CONTAINER(vbox), 6);
|
||||
@@ -111,12 +108,12 @@ KasumiAddWindow::KasumiAddWindow(KasumiDic *aDictionary,
|
||||
const int FREQ_DEFAULT = conf->getPropertyValueByInt("DefaultFrequency");
|
||||
const int FREQ_LBOUND = conf->getPropertyValueByInt("MinFrequency");
|
||||
const int FREQ_UBOUND = conf->getPropertyValueByInt("MaxFrequency");
|
||||
- GtkObject *adjustment = gtk_adjustment_new(FREQ_DEFAULT,
|
||||
- FREQ_LBOUND,
|
||||
- FREQ_UBOUND,
|
||||
- 1,
|
||||
- FREQ_UBOUND / 100
|
||||
- ,0);
|
||||
+ GtkAdjustment *adjustment = GTK_ADJUSTMENT (gtk_adjustment_new(FREQ_DEFAULT,
|
||||
+ FREQ_LBOUND,
|
||||
+ FREQ_UBOUND,
|
||||
+ 1,
|
||||
+ FREQ_UBOUND / 100
|
||||
+ ,0));
|
||||
FrequencySpin = gtk_spin_button_new(GTK_ADJUSTMENT(adjustment),1.0,0);
|
||||
alignment = gtk_alignment_new(0, 0.5, 1.0, 1.0);
|
||||
gtk_alignment_set_padding(GTK_ALIGNMENT(alignment), 0, 6, 6, 6);
|
||||
@@ -205,16 +202,14 @@ KasumiAddWindow::KasumiAddWindow(KasumiDic *aDictionary,
|
||||
gtk_box_pack_start(GTK_BOX(hbutton_box),GTK_WIDGET(button),TRUE,TRUE,0);
|
||||
g_signal_connect(G_OBJECT(button),"clicked",
|
||||
G_CALLBACK(_call_back_add_window_add),this);
|
||||
- gtk_tooltips_set_tip(Tooltips, button,
|
||||
- _("Add entered word and quit registration."),
|
||||
+ gtk_widget_set_tooltip_text(button,
|
||||
_("If all the necessary items are filled in, add entered word and quit registration."));
|
||||
|
||||
button = gtk_button_new_from_stock(GTK_STOCK_CLOSE);
|
||||
gtk_box_pack_start(GTK_BOX(hbutton_box),GTK_WIDGET(button),TRUE,TRUE,0);
|
||||
g_signal_connect(G_OBJECT(button),"clicked",
|
||||
G_CALLBACK(_call_back_add_window_quit),this);
|
||||
- gtk_tooltips_set_tip(Tooltips, button,
|
||||
- _("Cancel registration and quit."),
|
||||
+ gtk_widget_set_tooltip_text(button,
|
||||
_("Cancel registration and quit."));
|
||||
|
||||
gtk_window_set_keep_above(GTK_WINDOW(window), TRUE);
|
||||
@@ -227,24 +222,21 @@ KasumiAddWindow::KasumiAddWindow(KasumiDic *aDictionary,
|
||||
gtk_box_pack_start(GTK_BOX(hbutton_box),GTK_WIDGET(button),TRUE,TRUE,0);
|
||||
g_signal_connect(G_OBJECT(button),"clicked",
|
||||
G_CALLBACK(_call_back_add_window_add),this);
|
||||
- gtk_tooltips_set_tip(Tooltips, button,
|
||||
- _("Add entered word"),
|
||||
+ gtk_widget_set_tooltip_text(button,
|
||||
_("If all the necessary items are filled in, add entered word."));
|
||||
|
||||
button = gtk_button_new_from_stock(GTK_STOCK_EDIT);
|
||||
gtk_box_pack_start(GTK_BOX(hbutton_box),GTK_WIDGET(button),TRUE,TRUE,0);
|
||||
g_signal_connect(G_OBJECT(button),"clicked",
|
||||
G_CALLBACK(_call_back_manage_mode),this);
|
||||
- gtk_tooltips_set_tip(Tooltips, button,
|
||||
- _("Manage mode"),
|
||||
+ gtk_widget_set_tooltip_text(button,
|
||||
_("Make the shift to manage mode to modify and remove registered words."));
|
||||
|
||||
button = gtk_button_new_from_stock(GTK_STOCK_CLOSE);
|
||||
gtk_box_pack_start(GTK_BOX(hbutton_box),GTK_WIDGET(button),TRUE,TRUE,0);
|
||||
g_signal_connect(G_OBJECT(button),"clicked",
|
||||
G_CALLBACK(_call_back_add_window_quit),this);
|
||||
- gtk_tooltips_set_tip(Tooltips, button,
|
||||
- _("Quit this application"),
|
||||
+ gtk_widget_set_tooltip_text(button,
|
||||
_("Save dictionary and quit this application."));
|
||||
|
||||
// get selection at the time of launching
|
||||
@@ -443,16 +435,19 @@ void _call_back_manage_mode(GtkWidget *widget,
|
||||
void _call_back_selection_data_received(GtkWidget *widget,
|
||||
GtkSelectionData *selection_data,
|
||||
gpointer data){
|
||||
- if(selection_data->length < 0){
|
||||
+ int emit_length = gtk_selection_data_get_length(selection_data);
|
||||
+ GdkAtom emit_type = gtk_selection_data_get_data_type(selection_data);
|
||||
+ const guchar *emit_data = gtk_selection_data_get_data(selection_data);
|
||||
+ if(emit_length < 0){
|
||||
// failed retrieving selection
|
||||
// do nothing
|
||||
return;
|
||||
}
|
||||
|
||||
- string atom_name = string(gdk_atom_name(selection_data->type));
|
||||
+ string atom_name = string(gdk_atom_name(emit_type));
|
||||
|
||||
- gchar *str;
|
||||
- str = reinterpret_cast<gchar*>(selection_data->data);
|
||||
+ const gchar *str;
|
||||
+ str = reinterpret_cast<const gchar*>(emit_data);
|
||||
|
||||
if(atom_name == "UTF8_STRING"){
|
||||
gtk_entry_set_text(GTK_ENTRY(widget), str);
|
||||
diff --git a/KasumiAddWindow.hxx b/KasumiAddWindow.hxx
|
||||
index 5101314..352326a 100644
|
||||
--- a/KasumiAddWindow.hxx
|
||||
+++ b/KasumiAddWindow.hxx
|
||||
@@ -77,7 +77,6 @@ private:
|
||||
GtkWidget *FrequencySpin;
|
||||
GtkWidget *WordTypeCategoryCombo;
|
||||
GtkWidget *WordTypeCombo;
|
||||
- GtkTooltips *Tooltips;
|
||||
|
||||
GtkTreeIter defaultWordTypeCategoryIter;
|
||||
|
||||
diff --git a/KasumiMainWindow.cxx b/KasumiMainWindow.cxx
|
||||
index 4e86c7a..e8a8d56 100644
|
||||
--- a/KasumiMainWindow.cxx
|
||||
+++ b/KasumiMainWindow.cxx
|
||||
@@ -150,22 +150,22 @@ void KasumiMainWindow::createWindow()
|
||||
mSaveButton = gtk_button_new_from_stock ("gtk-save");
|
||||
gtk_widget_show (mSaveButton);
|
||||
gtk_box_pack_start (GTK_BOX (hbuttonbox1), mSaveButton, FALSE, TRUE, 0);
|
||||
- GTK_WIDGET_SET_FLAGS (mSaveButton, GTK_CAN_DEFAULT);
|
||||
+ gtk_widget_set_can_default (mSaveButton, TRUE);
|
||||
|
||||
mAddButton = gtk_button_new_from_stock ("gtk-add");
|
||||
gtk_widget_show (mAddButton);
|
||||
gtk_box_pack_start (GTK_BOX (hbuttonbox1), mAddButton, FALSE, TRUE, 0);
|
||||
- GTK_WIDGET_SET_FLAGS (mAddButton, GTK_CAN_DEFAULT);
|
||||
+ gtk_widget_set_can_default (mAddButton, TRUE);
|
||||
|
||||
mRemoveButton = gtk_button_new_from_stock ("gtk-delete");
|
||||
gtk_widget_show (mRemoveButton);
|
||||
gtk_box_pack_start (GTK_BOX (hbuttonbox1), mRemoveButton, FALSE, TRUE, 0);
|
||||
- GTK_WIDGET_SET_FLAGS (mRemoveButton, GTK_CAN_DEFAULT);
|
||||
+ gtk_widget_set_can_default (mRemoveButton, TRUE);
|
||||
|
||||
mQuitButton = gtk_button_new_from_stock ("gtk-close");
|
||||
gtk_widget_show (mQuitButton);
|
||||
gtk_box_pack_end (GTK_BOX (hbuttonbox1), mQuitButton, FALSE, TRUE, 0);
|
||||
- GTK_WIDGET_SET_FLAGS (mQuitButton, GTK_CAN_DEFAULT);
|
||||
+ gtk_widget_set_can_default (mQuitButton, TRUE);
|
||||
}
|
||||
|
||||
void KasumiMainWindow::createWordList()
|
||||
@@ -474,7 +474,7 @@ void KasumiMainWindow::editedTextColumn(GtkCellRendererText *renderer,
|
||||
|
||||
// set cursor right or left
|
||||
GtkTreeViewColumn *postCol = NULL;
|
||||
- if(lastKeyVal == GDK_Tab)
|
||||
+ if(lastKeyVal == GDK_KEY_Tab)
|
||||
{
|
||||
if(lastKeyState & GDK_CONTROL_MASK)
|
||||
{ // set cursor left
|
||||
@@ -887,42 +887,42 @@ guint getAccelKey(const string &key){
|
||||
|
||||
string shortkey = key.substr(i+1);
|
||||
|
||||
- if(shortkey == "A") return GDK_A;
|
||||
- else if(shortkey == "B") return GDK_B;
|
||||
- else if(shortkey == "C") return GDK_C;
|
||||
- else if(shortkey == "D") return GDK_D;
|
||||
- else if(shortkey == "E") return GDK_E;
|
||||
- else if(shortkey == "F") return GDK_F;
|
||||
- else if(shortkey == "G") return GDK_G;
|
||||
- else if(shortkey == "H") return GDK_H;
|
||||
- else if(shortkey == "I") return GDK_I;
|
||||
- else if(shortkey == "J") return GDK_J;
|
||||
- else if(shortkey == "K") return GDK_K;
|
||||
- else if(shortkey == "L") return GDK_L;
|
||||
- else if(shortkey == "M") return GDK_M;
|
||||
- else if(shortkey == "N") return GDK_N;
|
||||
- else if(shortkey == "O") return GDK_O;
|
||||
- else if(shortkey == "P") return GDK_P;
|
||||
- else if(shortkey == "Q") return GDK_Q;
|
||||
- else if(shortkey == "R") return GDK_R;
|
||||
- else if(shortkey == "S") return GDK_S;
|
||||
- else if(shortkey == "T") return GDK_T;
|
||||
- else if(shortkey == "U") return GDK_U;
|
||||
- else if(shortkey == "V") return GDK_V;
|
||||
- else if(shortkey == "W") return GDK_W;
|
||||
- else if(shortkey == "X") return GDK_X;
|
||||
- else if(shortkey == "Y") return GDK_Y;
|
||||
- else if(shortkey == "Z") return GDK_Z;
|
||||
- else if(shortkey == "0") return GDK_0;
|
||||
- else if(shortkey == "1") return GDK_1;
|
||||
- else if(shortkey == "2") return GDK_2;
|
||||
- else if(shortkey == "3") return GDK_3;
|
||||
- else if(shortkey == "4") return GDK_4;
|
||||
- else if(shortkey == "5") return GDK_5;
|
||||
- else if(shortkey == "6") return GDK_5;
|
||||
- else if(shortkey == "7") return GDK_7;
|
||||
- else if(shortkey == "8") return GDK_8;
|
||||
- else if(shortkey == "9") return GDK_9;
|
||||
+ if(shortkey == "A") return GDK_KEY_A;
|
||||
+ else if(shortkey == "B") return GDK_KEY_B;
|
||||
+ else if(shortkey == "C") return GDK_KEY_C;
|
||||
+ else if(shortkey == "D") return GDK_KEY_D;
|
||||
+ else if(shortkey == "E") return GDK_KEY_E;
|
||||
+ else if(shortkey == "F") return GDK_KEY_F;
|
||||
+ else if(shortkey == "G") return GDK_KEY_G;
|
||||
+ else if(shortkey == "H") return GDK_KEY_H;
|
||||
+ else if(shortkey == "I") return GDK_KEY_I;
|
||||
+ else if(shortkey == "J") return GDK_KEY_J;
|
||||
+ else if(shortkey == "K") return GDK_KEY_K;
|
||||
+ else if(shortkey == "L") return GDK_KEY_L;
|
||||
+ else if(shortkey == "M") return GDK_KEY_M;
|
||||
+ else if(shortkey == "N") return GDK_KEY_N;
|
||||
+ else if(shortkey == "O") return GDK_KEY_O;
|
||||
+ else if(shortkey == "P") return GDK_KEY_P;
|
||||
+ else if(shortkey == "Q") return GDK_KEY_Q;
|
||||
+ else if(shortkey == "R") return GDK_KEY_R;
|
||||
+ else if(shortkey == "S") return GDK_KEY_S;
|
||||
+ else if(shortkey == "T") return GDK_KEY_T;
|
||||
+ else if(shortkey == "U") return GDK_KEY_U;
|
||||
+ else if(shortkey == "V") return GDK_KEY_V;
|
||||
+ else if(shortkey == "W") return GDK_KEY_W;
|
||||
+ else if(shortkey == "X") return GDK_KEY_X;
|
||||
+ else if(shortkey == "Y") return GDK_KEY_Y;
|
||||
+ else if(shortkey == "Z") return GDK_KEY_Z;
|
||||
+ else if(shortkey == "0") return GDK_KEY_0;
|
||||
+ else if(shortkey == "1") return GDK_KEY_1;
|
||||
+ else if(shortkey == "2") return GDK_KEY_2;
|
||||
+ else if(shortkey == "3") return GDK_KEY_3;
|
||||
+ else if(shortkey == "4") return GDK_KEY_4;
|
||||
+ else if(shortkey == "5") return GDK_KEY_5;
|
||||
+ else if(shortkey == "6") return GDK_KEY_5;
|
||||
+ else if(shortkey == "7") return GDK_KEY_7;
|
||||
+ else if(shortkey == "8") return GDK_KEY_8;
|
||||
+ else if(shortkey == "9") return GDK_KEY_9;
|
||||
|
||||
cerr << "Invalid shortcut key option: " << key << endl;
|
||||
exit(1);
|
||||
diff --git a/cellrendererspin.c b/cellrendererspin.c
|
||||
index 885d462..85d3bda 100644
|
||||
--- a/cellrendererspin.c
|
||||
+++ b/cellrendererspin.c
|
||||
@@ -52,8 +52,6 @@
|
||||
*/
|
||||
|
||||
#include "cellrendererspin.h"
|
||||
-#include <gtk/gtkadjustment.h>
|
||||
-#include <gtk/gtkspinbutton.h>
|
||||
#include <stdlib.h>
|
||||
|
||||
#define GUI_CELL_RENDERER_SPIN_PATH "gui-cell-renderer-spin-path"
|
||||
@@ -239,6 +237,7 @@ gui_cell_renderer_spin_editing_done (GtkCellEditable *spinbutton,
|
||||
const gchar *path;
|
||||
const gchar *new_text;
|
||||
GCRSpinInfo *info;
|
||||
+ gboolean canceled = FALSE;
|
||||
|
||||
info = g_object_get_data (G_OBJECT (data), GUI_CELL_RENDERER_SPIN_INFO);
|
||||
|
||||
@@ -248,7 +247,8 @@ gui_cell_renderer_spin_editing_done (GtkCellEditable *spinbutton,
|
||||
info->focus_out_id = 0;
|
||||
}
|
||||
|
||||
- if (GTK_ENTRY(spinbutton)->editing_canceled)
|
||||
+ g_object_get (spinbutton, "editing-canceled", &canceled, NULL);
|
||||
+ if (canceled)
|
||||
return;
|
||||
|
||||
path = g_object_get_data (G_OBJECT (spinbutton), GUI_CELL_RENDERER_SPIN_PATH);
|
||||
@@ -317,19 +317,23 @@ gui_cell_renderer_spin_start_editing (GtkCellRenderer *cell,
|
||||
GtkWidget *spinbutton;
|
||||
GCRSpinInfo *info;
|
||||
gdouble curval = 0.0;
|
||||
+ gboolean editable = FALSE;
|
||||
+ gchar* str = NULL;
|
||||
|
||||
celltext = GTK_CELL_RENDERER_TEXT(cell);
|
||||
spincell = GUI_CELL_RENDERER_SPIN(cell);
|
||||
|
||||
/* If the cell isn't editable we return NULL. */
|
||||
- if (celltext->editable == FALSE)
|
||||
+ editable = GPOINTER_TO_INT(g_object_get_data (G_OBJECT (celltext), "editable"));
|
||||
+ if (editable == FALSE)
|
||||
return NULL;
|
||||
|
||||
spinbutton = g_object_new (GTK_TYPE_SPIN_BUTTON, "has_frame", FALSE, "numeric", TRUE, NULL);
|
||||
|
||||
/* dirty */
|
||||
- if (celltext->text)
|
||||
- curval = atof(celltext->text);
|
||||
+ str = (gchar *)g_object_get_data (G_OBJECT (celltext), "text");
|
||||
+ if (str)
|
||||
+ curval = atof(str);
|
||||
|
||||
adj = GTK_ADJUSTMENT(gtk_adjustment_new(curval,
|
||||
spincell->lower,
|
||||
diff --git a/cellrendererspin.h b/cellrendererspin.h
|
||||
index c6b33d2..36a2740 100644
|
||||
--- a/cellrendererspin.h
|
||||
+++ b/cellrendererspin.h
|
||||
@@ -27,7 +27,7 @@
|
||||
#ifndef _cellrendererspin_h_included_
|
||||
#define _cellrendererspin_h_included_
|
||||
|
||||
-#include <gtk/gtkcellrenderertext.h>
|
||||
+#include <gtk/gtk.h>
|
||||
|
||||
G_BEGIN_DECLS
|
||||
|
||||
diff --git a/main.cxx b/main.cxx
|
||||
index c5c459e..8ed5edf 100644
|
||||
--- a/main.cxx
|
||||
+++ b/main.cxx
|
||||
@@ -101,14 +101,15 @@ static void cb_selection_get(GtkWidget *widget,
|
||||
{
|
||||
gchar *text = NULL;
|
||||
gint length = 0;
|
||||
+ GdkAtom emit_selection = gtk_selection_data_get_selection(data);
|
||||
|
||||
- if (data->selection == atom0) {
|
||||
+ if (emit_selection == atom0) {
|
||||
text = "Kasumi Selection";
|
||||
length = strlen(text);
|
||||
gtk_selection_convert(window, atom1,
|
||||
GDK_SELECTION_TYPE_STRING,
|
||||
GDK_CURRENT_TIME);
|
||||
- } else if (data->selection == atom1 && arg_text != NULL) {
|
||||
+ } else if (emit_selection == atom1 && arg_text != NULL) {
|
||||
text = arg_text;
|
||||
arg_text = NULL;
|
||||
length = strlen(text);
|
||||
@@ -116,7 +117,7 @@ static void cb_selection_get(GtkWidget *widget,
|
||||
|
||||
if (text != NULL) {
|
||||
gtk_selection_data_set_text(data, text, length);
|
||||
- if (data->selection == atom1)
|
||||
+ if (emit_selection == atom1)
|
||||
g_free(text);
|
||||
}
|
||||
}
|
||||
@@ -126,9 +127,11 @@ static void cb_selection_received(GtkWidget *widget,
|
||||
guint time,
|
||||
gpointer user_data)
|
||||
{
|
||||
- if (data->selection == atom0) {
|
||||
- instance = MAX(data->length, 0);
|
||||
- } else if (data->selection == atom1 && data->length > 0) {
|
||||
+ GdkAtom emit_selection = gtk_selection_data_get_selection(data);
|
||||
+ int emit_length = gtk_selection_data_get_length(data);
|
||||
+ if (emit_selection == atom0) {
|
||||
+ instance = MAX(emit_length, 0);
|
||||
+ } else if (emit_selection == atom1 && emit_length > 0) {
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.28.0
|
||||
|
25
SOURCES/kasumi-853099-manpage.patch
Normal file
25
SOURCES/kasumi-853099-manpage.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff -pruN kasumi-2.5.orig/kasumi.1 kasumi-2.5/kasumi.1
|
||||
--- kasumi-2.5.orig/kasumi.1 2009-06-25 17:46:31.000000000 +0900
|
||||
+++ kasumi-2.5/kasumi.1 2012-08-31 11:14:19.000000000 +0900
|
||||
@@ -52,6 +52,10 @@ Run Kasumi in Manage mode\&. You may abb
|
||||
Run Kasumi in Add mode\&.
|
||||
|
||||
.TP
|
||||
+\fB\-e\fR \fB\-\-exclusive\fR
|
||||
+Run Kasumi in Exclusive mode\&.
|
||||
+
|
||||
+.TP
|
||||
\fB\-\-sound val\fR
|
||||
Set default sound entry (only in Add mode)
|
||||
|
||||
@@ -71,6 +75,10 @@ Import selected text as a spelling
|
||||
\fB\-I\fR \fB\-\-ignore\fR
|
||||
Ignore selected text
|
||||
|
||||
+.TP
|
||||
+\fB\-E\fR \fB\-\-eucjp\fR
|
||||
+Use EUC-JP encoding for dictionary
|
||||
+
|
||||
.SH "AUTHOR"
|
||||
|
||||
.PP
|
16
SOURCES/kasumi-check-anthy-pkg.patch
Normal file
16
SOURCES/kasumi-check-anthy-pkg.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -pruN kasumi-2.5.orig/configure.in kasumi-2.5/configure.in
|
||||
--- kasumi-2.5.orig/configure.in 2009-07-13 12:41:26.000000000 +0900
|
||||
+++ kasumi-2.5/configure.in 2021-03-31 16:59:21.255070350 +0900
|
||||
@@ -32,8 +32,10 @@ AC_CHECK_LIB(iconv, iconv)
|
||||
AC_CHECK_LIB(anthydic, anthy_dic_util_init)
|
||||
AC_CHECK_LIB(anthy, anthy_get_version_string)
|
||||
|
||||
-CFLAGS="$CFLAGS -Wall"
|
||||
-CXXFLAGS="$CXXFLAGS -Wall"
|
||||
+PKG_CHECK_MODULES(ANTHY, anthy)
|
||||
+
|
||||
+CFLAGS="$CFLAGS -Wall $ANTHY_CFLAGS"
|
||||
+CXXFLAGS="$CXXFLAGS -Wall $ANTHY_CFLAGS"
|
||||
|
||||
dnl Checks for header files.
|
||||
|
313
SPECS/kasumi.spec
Normal file
313
SPECS/kasumi.spec
Normal file
@ -0,0 +1,313 @@
|
||||
# anthy-unicode migration
|
||||
# https://github.com/fcitx/fcitx-anthy/issues/12
|
||||
# https://osdn.net/projects/scim-imengine/ticket/40956
|
||||
# https://github.com/uim/uim/issues/166
|
||||
|
||||
Name: kasumi
|
||||
Version: 2.5
|
||||
Release: 36%{?dist}
|
||||
|
||||
License: GPLv2+
|
||||
URL: http://kasumi.sourceforge.jp/
|
||||
%if 0%{?fedora}
|
||||
BuildRequires: anthy-devel
|
||||
%endif
|
||||
BuildRequires: autoconf automake libtool
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: make
|
||||
BuildRequires: gtk3-devel anthy-unicode-devel
|
||||
Requires: %{name}-common = %{version}-%{release}
|
||||
Source0: http://jaist.dl.sourceforge.jp/kasumi/41436/%{name}-%{version}.tar.gz
|
||||
Patch0: kasumi-853099-manpage.patch
|
||||
Patch1: kasumi-1928410-gtk3.patch
|
||||
Patch2: kasumi-check-anthy-pkg.patch
|
||||
|
||||
|
||||
Summary: An anthy dictionary management tool
|
||||
%description
|
||||
Kasumi is a dictionary management tool for Anthy.
|
||||
|
||||
|
||||
%package common
|
||||
Provides: %{name} = %{version}-%{release}
|
||||
Summary: Anthy dictionary management common files between kasumi and kasumi-unicode
|
||||
BuildArch: noarch
|
||||
|
||||
%description common
|
||||
This package contains common files for kasumi and kasumi-unicode.
|
||||
|
||||
|
||||
%package unicode
|
||||
Requires: %{name}-common = %{version}-%{release}
|
||||
Summary: An anthy-unicode dictionary management tool
|
||||
|
||||
%description unicode
|
||||
Kasumi-unicode is a dictionary management tool for Anthy-unicode.
|
||||
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
|
||||
%build
|
||||
sed -i -e '/AM_PATH_GTK_2_0(/i\
|
||||
PKG_CHECK_MODULES([GTK], [gtk+-3.0])\
|
||||
CFLAGS="$CFLAGS $GTK_CFLAGS"\
|
||||
CPPFLAGS="$CPPFLAGS $GTK_CFLAGS"\
|
||||
LIBS="$LIBS $GTK_LIBS"' \
|
||||
-e '/AM_PATH_GTK_2_0(/d' \
|
||||
configure.in
|
||||
autoreconf -f -i
|
||||
export CXXFLAGS="-std=c++14 $RPM_OPT_FLAGS"
|
||||
echo "# Building kasumi-unicode"
|
||||
sed -e 's/AC_CHECK_LIB(anthydic,/AC_CHECK_LIB(anthydic-unicode,/' \
|
||||
-e 's/AC_CHECK_LIB(anthy,/AC_CHECK_LIB(anthy-unicode,/' \
|
||||
-e 's/PKG_CHECK_MODULES(ANTHY, anthy/PKG_CHECK_MODULES(ANTHY, anthy-unicode/' \
|
||||
-i.orig configure.in
|
||||
autoreconf -f -i
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%if 0%{?fedora}
|
||||
mv kasumi kasumi-unicode
|
||||
make clean
|
||||
cp configure.in.orig configure.in
|
||||
|
||||
autoreconf -f -i
|
||||
echo "# Building kasumi"
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
%endif
|
||||
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
|
||||
%if 0%{?fedora}
|
||||
install -pm 755 kasumi-unicode $RPM_BUILD_ROOT%{_bindir}/kasumi-unicode
|
||||
%else
|
||||
mv $RPM_BUILD_ROOT%{_bindir}/kasumi $RPM_BUILD_ROOT%{_bindir}/kasumi-unicode
|
||||
%endif
|
||||
|
||||
# remove .desktop file so that kasumi is accessible from scim panel/ibus panel and it's not necessary for other users.
|
||||
rm -rf $RPM_BUILD_ROOT%{_datadir}/applications/*.desktop
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
|
||||
%if 0%{?fedora}
|
||||
%files
|
||||
%{_bindir}/kasumi
|
||||
%doc AUTHORS ChangeLog NEWS README
|
||||
%license COPYING
|
||||
%endif
|
||||
|
||||
%files unicode
|
||||
%{_bindir}/kasumi-unicode
|
||||
%doc AUTHORS ChangeLog NEWS README
|
||||
%license COPYING
|
||||
|
||||
%files common -f %{name}.lang
|
||||
%{_mandir}/man1/kasumi.1*
|
||||
%{_datadir}/pixmaps/kasumi.png
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 2.5-36
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Tue Apr 20 2021 Akira TAGOH <tagoh@redhat.com> - 2.5-35
|
||||
- Drop gtk2 dependency completely.
|
||||
- Make anthy build conditionally for Fedora release only.
|
||||
Resolves: rhbz#1939777
|
||||
- Fix build fail without anthy-devel.
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 2.5-34
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Tue Feb 16 2021 Takao Fujiwra <tfujiwar@redhat.com> - 2.5-33
|
||||
- Migrate kasumi GUI to GTK3
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-32
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Fri Nov 13 2020 Takao Fujiwra <tfujiwar@redhat.com> - 2.5-31
|
||||
- Add Provides and Obsoletes
|
||||
|
||||
* Thu Nov 12 2020 Takao Fujiwra <tfujiwar@redhat.com> - 2.5-30
|
||||
- Generate kasumi-unicode for anthy-unicode
|
||||
|
||||
* Thu Sep 03 2020 Takao Fujiwra <tfujiwar@redhat.com> - 2.5-29
|
||||
- Replace anthy with anthy-unicode
|
||||
|
||||
* Tue Jul 28 2020 Jeff Law <law@redhat.com> - 2.5-28
|
||||
- Force C++14 as this code is not C++17 ready
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-27
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-26
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-25
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-24
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-23
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Feb 19 2018 Akira TAGOH <tagoh@redhat.com> - 2.5-22
|
||||
- Add BR: gcc-c++
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-21
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-19
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 2.5-15
|
||||
- Rebuilt for GCC 5 C++11 ABI change
|
||||
|
||||
* Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Mar 27 2013 Akira TAGOH <tagoh@redhat.com> - 2.5-11
|
||||
- Rebuilt for aarch64 support (#925621)
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Nov 23 2012 Akira TAGOH <tagoh@redhat.com>
|
||||
- the spec file cleanup
|
||||
|
||||
* Fri Aug 31 2012 Akira TAGOH <tagoh@redhat.com> 2.5-9
|
||||
- Fix the missing descriptions for some options in --help (#853099)
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-7
|
||||
- Rebuilt for c++ ABI breakage
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Nov 07 2011 Adam Jackson <ajax@redhat.com> 2.5-5
|
||||
- Rebuild for new (ie, no) libpng
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Tue Mar 9 2010 Akira TAGOH <tagoh@redhat.com> - 2.5-3
|
||||
- Get rid of .desktop file again. (#546147)
|
||||
|
||||
* Mon Dec 21 2009 Akira TAGOH <tagoh@redhat.com> - 2.5-2
|
||||
- improve the spec file (#546147)
|
||||
|
||||
* Mon Aug 3 2009 Akira TAGOH <tagoh@redhat.com> - 2.5-1
|
||||
- New upstream release.
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Thu Jan 29 2009 Akira TAGOH <tagoh@redhat.com> - 2.4-1
|
||||
- New upstream release.
|
||||
|
||||
* Tue Apr 8 2008 Akira TAGOH <tagoh@redhat.com> - 2.3-4
|
||||
- Remove .desktop file since it's accessible from scim-panel and it's not
|
||||
necessarily used for every users, particularly on Live. (#439173)
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.3-3
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Tue Feb 19 2008 Akira TAGOH <tagoh@redhat.com> - 2.3-2
|
||||
- kasumi-2.3-gcc43.patch: Fix build fails with gcc-4.3.
|
||||
|
||||
* Wed Oct 31 2007 Akira TAGOH <tagoh@redhat.com> - 2.3-1
|
||||
- New upstream release.
|
||||
- kasumi-2.2-fix-dict-breakage.patch: removed.
|
||||
|
||||
* Thu Aug 23 2007 Akira TAGOH <tagoh@redhat.com> - 2.2-6
|
||||
- Rebuild
|
||||
|
||||
* Wed Aug 8 2007 Akira TAGOH <tagoh@redhat.com> - 2.2-4
|
||||
- Update License tag.
|
||||
|
||||
* Thu Jun 14 2007 Akira TAGOH <tagoh@redhat.com> - 2.2-3
|
||||
- kasumi-2.2-fix-dict-breakage.patch: patch from Debian to fix the dictionary
|
||||
breakage when adding words to the personal dictionary against the bugfix
|
||||
version of anthy that the version contains non-numeric characters.
|
||||
|
||||
* Wed Mar 28 2007 Akira TAGOH <tagoh@redhat.com> - 2.2-2
|
||||
- Add X-GNOME-PersonalSettings to the category. (#234169)
|
||||
|
||||
* Fri Mar 2 2007 Akira TAGOH <tagoh@redhat.com> - 2.2-1
|
||||
- Updated to 2.2
|
||||
- Remove kasumi-2.0.1-errorcode.patch. no longer needed.
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.1-1.1
|
||||
- rebuild
|
||||
|
||||
* Fri Jun 30 2006 Akira TAGOH <tagoh@redhat.com> - 2.0.1-1
|
||||
- New upstream release.
|
||||
- use dist tag.
|
||||
- kasumi-2.0.1-errorcode.patch: fixed not working when the private dictionary is empty. (#197313)
|
||||
|
||||
* Wed Jun 7 2006 Akira TAGOH <tagoh@redhat.com> - 2.0-2
|
||||
- added anthy-devel, automake and autoconf to BuildReq. (#194121)
|
||||
|
||||
* Tue May 30 2006 Akira TAGOH <tagoh@redhat.com> - 2.0-1
|
||||
- New upstream release.
|
||||
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-1.fc5.2
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-1.fc5.1
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Thu Dec 15 2005 Akira TAGOH <tagoh@redhat.com> - 1.0-1
|
||||
- New upstream release.
|
||||
- kasumi-1.0-gcc41.patch: build with -ffriend-injection to temporarily get it
|
||||
built with gcc-4.1.
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Thu Oct 13 2005 Akira TAGOH <tagoh@redhat.com> - 0.10-1
|
||||
- New upstream release.
|
||||
|
||||
* Tue Aug 16 2005 Akira TAGOH <tagoh@redhat.com> - 0.9-3
|
||||
- Rebuild
|
||||
|
||||
* Tue Aug 9 2005 Akira TAGOH <tagoh@redhat.com>
|
||||
- added dist tag in Release.
|
||||
|
||||
* Fri Aug 5 2005 Akira TAGOH <tagoh@redhat.com> - 0.9-2
|
||||
- Import into Core.
|
||||
- clean up spec file.
|
||||
|
||||
* Wed Jun 29 2005 Ryo Dairiki <ryo-dairiki@users.sourceforge.net> - 0.9-1
|
||||
- Initial packaging for Fedora Extras
|
||||
|
Loading…
Reference in New Issue
Block a user