diff --git a/jzlib.spec b/jzlib.spec
index e27fc5e..9b5bd1b 100644
--- a/jzlib.spec
+++ b/jzlib.spec
@@ -37,6 +37,9 @@ Requires: %{name} = %{version}-%{release}
%setup -q
%patch0
+%pom_xpath_set "pom:plugin[pom:artifactId='maven-compiler-plugin']/pom:configuration/pom:source" 1.6
+%pom_xpath_set "pom:plugin[pom:artifactId='maven-compiler-plugin']/pom:configuration/pom:target" 1.6
+
# Make into OSGi bundle
%pom_xpath_inject "pom:project" "bundle"
%pom_add_plugin "org.apache.felix:maven-bundle-plugin" . "true"