diff --git a/.gitignore b/.gitignore
index d4b4463..ecd44ef 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,4 +3,3 @@ junit3.8.2.zip
/r4.11.tar.gz
/junit-4.11-clean.tar.gz
/junit-4.12-clean.tar.gz
-/junit4-4.13-clean.tar.gz
diff --git a/create-tarball.sh b/create-tarball.sh
index d6b835e..1594760 100755
--- a/create-tarball.sh
+++ b/create-tarball.sh
@@ -8,15 +8,15 @@ fi
VERSION=${1}
NAME="junit"
-wget https://github.com/${NAME}-team/${NAME}4/archive/r${VERSION}.tar.gz
+wget https://github.com/${NAME}-team/${NAME}/archive/r${VERSION}.tar.gz
tar xvf r${VERSION}.tar.gz
(
- cd ${NAME}4-r${VERSION}
+ cd ${NAME}-r${VERSION}
find . -name "*.jar" -delete
find . -name "*.class" -delete
)
-tar czvf ${NAME}4-${VERSION}-clean.tar.gz ${NAME}4-r${VERSION}
-rm -Rf ${NAME}4-${VERSION}.tar.gz
+tar czvf ${NAME}-${VERSION}-clean.tar.gz ${NAME}-r${VERSION}
+rm -Rf ${NAME}-${VERSION}.tar.gz
diff --git a/junit.spec b/junit.spec
index 75426b3..7e10338 100644
--- a/junit.spec
+++ b/junit.spec
@@ -1,21 +1,20 @@
Name: junit
Epoch: 1
-Version: 4.13
-Release: 1%{?dist}
+Version: 4.12
+Release: 13%{?dist}
Summary: Java regression test package
License: EPL-1.0
URL: http://www.junit.org/
BuildArch: noarch
# ./clean-tarball.sh %{version}
-Source0: %{name}4-%{version}-clean.tar.gz
+Source0: %{name}-%{version}-clean.tar.gz
Source3: create-tarball.sh
BuildRequires: maven-local
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
BuildRequires: mvn(org.apache.maven.plugins:maven-enforcer-plugin)
BuildRequires: mvn(org.hamcrest:hamcrest-core)
-BuildRequires: mvn(org.hamcrest:hamcrest-library)
Obsoletes: %{name}-demo < 4.12
@@ -38,7 +37,7 @@ Summary: Javadoc for %{name}
Javadoc for %{name}.
%prep
-%setup -q -n %{name}4-r%{version}
+%setup -q -n %{name}-r%{version}
# InaccessibleBaseClassTest fails with Java 8
sed -i /InaccessibleBaseClassTest/d src/test/java/org/junit/tests/AllTests.java
@@ -68,18 +67,10 @@ sed s/@version@/%{version}/ src/main/java/junit/runner/Version.java.template >sr
"
-# Fix javadoc generation on java 11
-%pom_xpath_inject pom:build/pom:plugins "
-maven-javadoc-plugin
-
-"
-
%mvn_file : %{name}
-sed -i -e "s|1.5|1.6|" pom.xml
-
%build
-%mvn_build -- -Dmaven.compiler.source=1.8 -Dmaven.compiler.target=1.8
+%mvn_build
%install
%mvn_install
@@ -95,10 +86,6 @@ sed -i -e "s|1.5|1.6|" pom.xml
%doc doc/*
%changelog
-* Thu Jun 25 2020 Alexander Kurtakov 1:4.13-1
-- Update to 4.13
-- Fix build with Java 11.
-
* Wed Jan 29 2020 Fedora Release Engineering - 1:4.12-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
diff --git a/sources b/sources
index 90c2f5d..d77668d 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (junit4-4.13-clean.tar.gz) = 608718a813e6709b5e63efa378c055e57204fc4403ff6a638950b935cb6cb18e0d9857b6fe5709bd78803499525c694b45f7abfb01fa8271e5658acc2ae47314
+0de14594aaba3379f6b19ba75a393232 junit-4.12-clean.tar.gz