diff --git a/junit.spec b/junit.spec
index cae2b2e..849c541 100644
--- a/junit.spec
+++ b/junit.spec
@@ -1,7 +1,7 @@
Name: junit
Epoch: 1
Version: 4.12
-Release: 17%{?dist}
+Release: 18%{?dist}
Summary: Java regression test package
License: EPL-1.0
URL: http://www.junit.org/
@@ -82,6 +82,9 @@ sed s/@version@/%{version}/ src/main/java/junit/runner/Version.java.template >sr
# Ignore test that breaks on Java 11 due to unexpected extra annotations in the JDK standard library
sed -i -e '/providesAnnotatedMethodsSortedByName/i@Ignore' src/test/java/org/junit/runners/model/TestClassTest.java
+# Set JPMS module name
+%pom_xpath_inject "pom:plugin[pom:artifactId='maven-jar-plugin']/pom:configuration/pom:archive" "junit"
+
%mvn_file : %{name}
%build
@@ -102,6 +105,9 @@ sed -i -e '/providesAnnotatedMethodsSortedByName/i@Ignore' src/test/java/org/jun
%doc doc/*
%changelog
+* Tue Aug 04 2020 Mat Booth - 1:4.12-18
+- Add automatic module name
+
* Tue Aug 04 2020 Mat Booth - 1:4.12-17
- Allow building on Java 11