Resolves: mbz #1400884
- Mozilla Bugzilla #1400884 - new JSS failures: HMAC Unwrap and KeyWrapping FIPSMODE (jmagne)
This commit is contained in:
parent
d8d41b5f8c
commit
f263dec62c
22
jss-HMAC-unwrap-keywrap-FIPSMODE.patch
Normal file
22
jss-HMAC-unwrap-keywrap-FIPSMODE.patch
Normal file
@ -0,0 +1,22 @@
|
||||
# HG changeset patch
|
||||
# User Jack Magne <jmagne@redhat.com>
|
||||
# Date 1506640850 25200
|
||||
# Thu Sep 28 16:20:50 2017 -0700
|
||||
# Node ID 252c10f448971b7ae087bde259505abd5dc5a03a
|
||||
# Parent 3e9a5ae2149d04877dc19b117a8917c22854f8eb
|
||||
Fix: Bug 1400884 - new JSS failures: HMAC Unwrap and KeyWrapping FIPSMODE.
|
||||
|
||||
diff --git a/org/mozilla/jss/pkcs11/KeyType.java b/org/mozilla/jss/pkcs11/KeyType.java
|
||||
--- a/org/mozilla/jss/pkcs11/KeyType.java
|
||||
+++ b/org/mozilla/jss/pkcs11/KeyType.java
|
||||
@@ -204,9 +204,7 @@
|
||||
EncryptionAlgorithm.AES_192_CBC,
|
||||
EncryptionAlgorithm.AES_256_ECB,
|
||||
EncryptionAlgorithm.AES_256_CBC,
|
||||
- /* AES CBC PAD is the same as AES_256_CBC_PAD */
|
||||
- /* shouldn't break backward compatibility 313798*/
|
||||
- //EncryptionAlgorithm.AES_CBC_PAD,
|
||||
+ EncryptionAlgorithm.AES_CBC_PAD,
|
||||
EncryptionAlgorithm.AES_128_CBC_PAD,
|
||||
EncryptionAlgorithm.AES_192_CBC_PAD,
|
||||
EncryptionAlgorithm.AES_256_CBC_PAD
|
16
jss.spec
16
jss.spec
@ -1,6 +1,6 @@
|
||||
Name: jss
|
||||
Version: 4.4.2
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Summary: Java Security Services (JSS)
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -35,6 +35,7 @@ Requires: nss >= 3.28.4-6
|
||||
Patch1: jss-HMAC-test-for-AES-encrypt-unwrap.patch
|
||||
Patch2: jss-PBE-padded-block-cipher-enhancements.patch
|
||||
Patch3: jss-fix-PK11Store-getEncryptedPrivateKeyInfo-segfault.patch
|
||||
Patch4: jss-HMAC-unwrap-keywrap-FIPSMODE.patch
|
||||
|
||||
%description
|
||||
Java Security Services (JSS) is a java native interface which provides a bridge
|
||||
@ -51,9 +52,12 @@ This package contains the API documentation for JSS.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{version}
|
||||
%patch1 -d jss -p1
|
||||
%patch2 -d jss -p1
|
||||
%patch3 -d jss -p1
|
||||
pushd jss
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
popd
|
||||
|
||||
%build
|
||||
[ -z "$JAVA_HOME" ] && export JAVA_HOME=%{_jvmdir}/java
|
||||
@ -145,6 +149,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_javadocdir}/%{name}-%{version}/*
|
||||
|
||||
%changelog
|
||||
* Fri Oct 27 2017 Dogtag Team <pki-devel@redhat.com> 4.4.2-6
|
||||
- Mozilla Bugzilla #1400884 - new JSS failures: HMAC Unwrap and KeyWrapping
|
||||
FIPSMODE (jmagne)
|
||||
|
||||
* Mon Sep 11 2017 Dogtag Team <pki-devel@redhat.com> 4.4.2-5
|
||||
- Mozilla Bugzilla #1370778 - PBE and padded block cipher enhancements and
|
||||
fixes (ftweedal)
|
||||
|
Loading…
Reference in New Issue
Block a user