Resolves: bug #654657 - Incorrect socket accept error message due to bad pointer arithmetic
This commit is contained in:
parent
0447399904
commit
af4d29e93a
27
jss-bad-error-string-pointer.patch
Normal file
27
jss-bad-error-string-pointer.patch
Normal file
@ -0,0 +1,27 @@
|
||||
--- jss-4.2.6.orig/mozilla/security/jss/org/mozilla/jss/ssl/SSLServerSocket.c 2010-11-17 18:54:56.000000000 -0500
|
||||
+++ jss-4.2.6/mozilla/security/jss/org/mozilla/jss/ssl/SSLServerSocket.c 2010-11-18 09:46:34.000000000 -0500
|
||||
@@ -124,20 +124,16 @@
|
||||
/* Clean up after PR_interrupt. */
|
||||
PR_NT_CancelIo(sock->fd);
|
||||
#endif
|
||||
- JSSL_throwSSLSocketException(env,
|
||||
- "Accept operation interrupted with error code " + err);
|
||||
+ JSSL_throwSSLSocketException(env, "Accept operation interrupted");
|
||||
} else if( err == PR_IO_TIMEOUT_ERROR ) {
|
||||
#ifdef WINNT
|
||||
PR_NT_CancelIo(sock->fd);
|
||||
#endif
|
||||
- JSSL_throwSSLSocketException(env,
|
||||
- "Accept operation timed out with error code " + err);
|
||||
+ JSSL_throwSSLSocketException(env, "Accept operation timed out");
|
||||
} else if( err == PR_IO_ERROR ) {
|
||||
- JSSL_throwSSLSocketException(env,
|
||||
- "Accept operation received IO error with error code " + err);
|
||||
+ JSSL_throwSSLSocketException(env, "Accept operation received IO error");
|
||||
} else {
|
||||
- JSSL_throwSSLSocketException(env,
|
||||
- "Accept operation failed with error code " + err);
|
||||
+ JSSL_throwSSLSocketException(env, "Accept operation failed");
|
||||
}
|
||||
goto finish;
|
||||
}
|
8
jss.spec
8
jss.spec
@ -1,6 +1,6 @@
|
||||
Name: jss
|
||||
Version: 4.2.6
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
Summary: Java Security Services (JSS)
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -30,6 +30,7 @@ Patch5: jss-loadlibrary.patch
|
||||
Patch6: jss-ocspSettings.patch
|
||||
Patch7: jss-ECC_keygen_byCurveName.patch
|
||||
Patch8: jss-VerifyCertificate.patch
|
||||
Patch9: jss-bad-error-string-pointer.patch
|
||||
|
||||
|
||||
%description
|
||||
@ -55,6 +56,7 @@ This package contains the API documentation for JSS.
|
||||
%patch6 -p1
|
||||
%patch7 -p1
|
||||
%patch8 -p1
|
||||
%patch9 -p1
|
||||
|
||||
%build
|
||||
[ -z "$JAVA_HOME" ] && export JAVA_HOME=%{_jvmdir}/java
|
||||
@ -150,6 +152,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Dec 6 2010 John Dennis <jdennis@redhat.com> - 4.2.6-9
|
||||
- Resolves: bug #654657 - Incorrect socket accept error message due to bad pointer arithmetic
|
||||
added patch jss-bad-error-string-pointer.patch
|
||||
|
||||
* Mon Nov 1 2010 Christina Fu <cfu@redhat.com> 4.2.6-8
|
||||
- Bugzilla Bug # 647364 - Expose updated certificate verification function in JSS
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user