Resolves: rhbz #1221295
* Bugzilla Bug #1221295 - jss fails to decode EncryptedKey >> EnvelopedData (cfu for roysjosh@gmail.com)
This commit is contained in:
parent
f2ae793e30
commit
3af0c8d7b6
33
jss-crmf-envelopedData.patch
Normal file
33
jss-crmf-envelopedData.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -up jss-4.2.6/mozilla/security/jss/org/mozilla/jss/pkix/crmf/EncryptedKey.java.roysjosh jss-4.2.6/mozilla/security/jss/org/mozilla/jss/pkix/crmf/EncryptedKey.java
|
||||
--- jss-4.2.6/mozilla/security/jss/org/mozilla/jss/pkix/crmf/EncryptedKey.java.roysjosh 2016-06-24 14:51:48.929122053 -0700
|
||||
+++ jss-4.2.6/mozilla/security/jss/org/mozilla/jss/pkix/crmf/EncryptedKey.java 2016-06-24 14:52:29.487027005 -0700
|
||||
@@ -127,7 +127,8 @@ public class EncryptedKey implements ASN
|
||||
} else {
|
||||
Assert._assert(type == ENVELOPED_DATA);
|
||||
Assert._assert(envelopedData != null);
|
||||
- envelopedData.encode(implicitTag, ostream);
|
||||
+ EXPLICIT explicit = new EXPLICIT( new Tag(0), envelopedData );
|
||||
+ explicit.encode(tag, ostream);
|
||||
}
|
||||
}
|
||||
|
||||
@@ -147,7 +148,9 @@ public class EncryptedKey implements ASN
|
||||
choicet = new CHOICE.Template();
|
||||
|
||||
choicet.addElement( EncryptedValue.getTemplate() );
|
||||
- choicet.addElement( new Tag(0), ANY.getTemplate() );
|
||||
+ choicet.addElement( new EXPLICIT.Template(
|
||||
+ new Tag(0),
|
||||
+ ANY.getTemplate() ));
|
||||
}
|
||||
|
||||
public boolean tagMatch(Tag tag) {
|
||||
@@ -164,7 +167,7 @@ public class EncryptedKey implements ASN
|
||||
return new EncryptedKey( (EncryptedValue) choice.getValue() );
|
||||
} else {
|
||||
Assert._assert( choice.getTag().equals(new Tag(0)) );
|
||||
- return new EncryptedKey( (ANY) choice.getValue() );
|
||||
+ return new EncryptedKey( (ANY) ((EXPLICIT) choice.getValue()).getContent() );
|
||||
}
|
||||
|
||||
} catch(InvalidBERException e) {
|
8
jss.spec
8
jss.spec
@ -1,6 +1,6 @@
|
||||
Name: jss
|
||||
Version: 4.2.6
|
||||
Release: 40%{?dist}
|
||||
Release: 41%{?dist}
|
||||
Summary: Java Security Services (JSS)
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -52,6 +52,7 @@ Patch27: jss-Fixed-build-failures.patch
|
||||
Patch28: jss-VerifyCertificate-enhancement.patch
|
||||
Patch29: jss-lunasaUnwrap.patch
|
||||
Patch30: jss-symkey-enhancements.patch
|
||||
Patch31: jss-crmf-envelopedData.patch
|
||||
|
||||
|
||||
%description
|
||||
@ -99,6 +100,7 @@ This package contains the API documentation for JSS.
|
||||
%patch28 -p1
|
||||
%patch29 -p1
|
||||
%patch30 -p1
|
||||
%patch31 -p1
|
||||
|
||||
%build
|
||||
[ -z "$JAVA_HOME" ] && export JAVA_HOME=%{_jvmdir}/java
|
||||
@ -203,6 +205,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jun 24 2016 Christina Fu <cfu@redhat.com> - 4.2.6-41
|
||||
- Bugzilla 1221295 jss fails to decode EncryptedKey >> EnvelopedData
|
||||
(cfu for roysjosh@gmail.com)
|
||||
|
||||
* Thu May 19 2016 Christina Fu <cfu@redhat.com> - 4.2.6-40
|
||||
- Bugzilla 1074208 - pass up exact JSS certificate validation errors from NSS
|
||||
(edewata)
|
||||
|
Loading…
Reference in New Issue
Block a user