Fixed build issue on Rawhide

This commit is contained in:
Endi S. Dewata 2013-07-17 15:16:32 -04:00
parent 4ccc40462a
commit 18eacedf98
2 changed files with 30 additions and 2 deletions

View File

@ -0,0 +1,23 @@
diff -rupN jss-4.2.6.orig/mozilla/security/coreconf/config.mk jss-4.2.6/mozilla/security/coreconf/config.mk
--- jss-4.2.6.orig/mozilla/security/coreconf/config.mk 2007-05-03 23:54:05.000000000 -0700
+++ jss-4.2.6/mozilla/security/coreconf/config.mk 2013-07-22 18:42:19.000000000 -0700
@@ -68,8 +68,19 @@ TARGET_OSES = FreeBSD BSD_OS NetBSD Open
ifeq (,$(filter-out $(TARGET_OSES),$(OS_TARGET)))
include $(CORE_DEPTH)/coreconf/$(OS_TARGET).mk
else
+ifeq ($(OS_TARGET), Linux)
+OS_RELEASE_VER_MAJOR := $(shell echo $(OS_RELEASE) | cut -f1 -d.)
+OS_RELEASE_VER_MINOR := $(shell echo $(OS_RELEASE) | cut -f2 -d.)
+OS_RELEASE_GT_2_6 := $(shell [ $(OS_RELEASE_VER_MAJOR) -ge 2 -o \( $(OS_RELEASE_VER_MAJOR) -eq 2 -a $(OS_RELEASE_VER_MINOR) -ge 6 \) ] && echo true)
+ifeq ($(OS_RELEASE_GT_2_6),true)
+include $(CORE_DEPTH)/coreconf/Linux2.6.mk
+else
include $(CORE_DEPTH)/coreconf/$(OS_TARGET)$(OS_RELEASE).mk
endif
+else
+include $(CORE_DEPTH)/coreconf/$(OS_TARGET)$(OS_RELEASE).mk
+endif
+endif
#######################################################################
# [4.0] Master "Core Components" source and release <platform> tags #

View File

@ -1,6 +1,6 @@
Name: jss
Version: 4.2.6
Release: 29%{?dist}
Release: 30%{?dist}
Summary: Java Security Services (JSS)
Group: System Environment/Libraries
@ -44,6 +44,7 @@ Patch19: jss-HSM-manufacturerID.patch
Patch20: jss-ECC-Phase2KeyArchivalRecovery.patch
Patch21: jss-undo-JCA-deprecations.patch
Patch22: jss-undo-BadPaddingException-deprecation.patch
Patch23: jss-fixed-build-issue-on-F17-or-newer.patch
%description
@ -83,6 +84,7 @@ This package contains the API documentation for JSS.
%patch20 -p1
%patch21 -p1
%patch22 -p1
%patch23 -p1
%build
[ -z "$JAVA_HOME" ] && export JAVA_HOME=%{_jvmdir}/java
@ -187,6 +189,9 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Wed Jul 17 2013 Nathan Kinder <nkinder@redhat.com> - 4.2.6-30
- Bugzilla Bug #847120 - Unable to build JSS on F17 or newer
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.6-29
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
@ -350,5 +355,5 @@ rm -rf $RPM_BUILD_ROOT
- Added RPM_OPT_FLAGS to XCFLAGS
- Added link to Sun JCE information
* Mon Feb 27 2007 Rob Crittenden <rcritten@redhat.com> 4.2.4-1
* Tue Feb 27 2007 Rob Crittenden <rcritten@redhat.com> 4.2.4-1
- Initial build