diff --git a/.gitignore b/.gitignore
index e69de29..b550f07 100644
--- a/.gitignore
+++ b/.gitignore
@@ -0,0 +1,2 @@
+jsr-305-0.4.20090319.tar.xz
+/jsr-305-20130910svn.tgz
diff --git a/NOTICE-CC-BY.txt b/NOTICE-CC-BY.txt
new file mode 100644
index 0000000..ab3e0dd
--- /dev/null
+++ b/NOTICE-CC-BY.txt
@@ -0,0 +1,4 @@
+Copyright (c) 2005 Brian Goetz
+Released under the Creative Commons Attribution License
+ (http://creativecommons.org/licenses/by/2.5)
+Official home: http://www.jcip.net
diff --git a/jsr-305-java8.patch b/jsr-305-java8.patch
new file mode 100644
index 0000000..de90366
--- /dev/null
+++ b/jsr-305-java8.patch
@@ -0,0 +1,22 @@
+diff --git a/pom.xml b/pom.xml
+index dcafc07..f5799e2 100644
+--- a/pom.xml
++++ b/pom.xml
+@@ -27,8 +27,15 @@
+ org.apache.maven.plugins
+ maven-compiler-plugin
+
+-
+- 1.5
++
++ 1.8
++
++
++
++ org.apache.maven.plugins
++ maven-javadoc-plugin
++
++
+
+
+
diff --git a/jsr-305.spec b/jsr-305.spec
new file mode 100644
index 0000000..d98bab1
--- /dev/null
+++ b/jsr-305.spec
@@ -0,0 +1,190 @@
+Name: jsr-305
+Version: 0
+Release: 0.30.20130910svn%{?dist}
+Summary: Correctness annotations for Java code
+
+# The majority of code is BSD-licensed, but some Java sources
+# are licensed under CC-BY license, see: $ grep -r Creative .
+License: BSD and CC-BY
+URL: http://jsr-305.googlecode.com/
+BuildArch: noarch
+
+# There has been no official release yet. This is a snapshot of the Subversion
+# repository as of 10 Sep 2013. Use the following commands to generate the
+# tarball:
+# svn export -r 51 http://jsr-305.googlecode.com/svn/trunk jsr-305
+# tar -czvf jsr-305-20130910svn.tgz jsr-305
+Source0: jsr-305-20130910svn.tgz
+# File containing URL to CC-BY license text
+Source1: NOTICE-CC-BY.txt
+
+Patch0: %{name}-java8.patch
+
+BuildRequires: maven-local
+
+%package javadoc
+Summary: Javadoc documentation for %{name}
+
+%description
+This package contains reference implementations, test cases, and other
+documents for Java Specification Request 305: Annotations for Software Defect
+Detection.
+
+%description javadoc
+This package contains the API documentation for %{name}.
+
+%prep
+%setup -q -n %{name}
+cp %{SOURCE1} NOTICE-CC-BY
+%patch0 -p1
+
+%mvn_file :ri %{name}
+%mvn_alias :ri com.google.code.findbugs:jsr305
+%mvn_package ":{proposedAnnotations,tcl}" __noinstall
+
+# do not build sampleUses module - it causes Javadoc generation to fail
+%pom_disable_module sampleUses
+
+%build
+%mvn_build
+
+%install
+%mvn_install
+
+%files -f .mfiles
+%doc NOTICE-CC-BY sampleUses
+%license ri/LICENSE
+
+%files javadoc -f .mfiles-javadoc
+%doc NOTICE-CC-BY
+%license ri/LICENSE
+
+%changelog
+* Tue Jul 28 2020 Fedora Release Engineering - 0-0.30.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Fri Jul 10 2020 Jiri Vanek - 0-0.29.20130910svn
+- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
+
+* Sat May 23 2020 Richard Fearn - 0-0.28.20130910svn
+- Enable building with JDK 11: use source/target 1.8
+
+* Sun Feb 02 2020 Richard Fearn - 0-0.27.20130910svn
+- Use %%license
+
+* Wed Jan 29 2020 Fedora Release Engineering - 0-0.26.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Thu Jul 25 2019 Fedora Release Engineering - 0-0.25.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Fri Feb 01 2019 Fedora Release Engineering - 0-0.24.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Fri Jul 13 2018 Fedora Release Engineering - 0-0.23.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Wed Feb 07 2018 Fedora Release Engineering - 0-0.22.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Wed Jul 26 2017 Fedora Release Engineering - 0-0.21.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Fri Feb 10 2017 Fedora Release Engineering - 0-0.20.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+
+* Thu Feb 04 2016 Fedora Release Engineering - 0-0.19.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Wed Jun 17 2015 Fedora Release Engineering - 0-0.18.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Sun Jun 08 2014 Fedora Release Engineering - 0-0.17.20130910svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Tue Sep 10 2013 Richard Fearn - 0-0.16.20130910svn
+- Update to r51
+
+* Sat Aug 03 2013 Fedora Release Engineering - 0-0.15.20090319svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+
+* Tue Jun 18 2013 Mikolaj Izdebski - 0-0.14.20090319svn
+- Update to current packaging guidelines
+
+* Tue Jun 18 2013 Michal Srb - 0-0.14.20090319svn
+- Install license file with javadoc subpackage (Resolves: rhbz#975411)
+- Add file containing link to CC-BY license text
+
+* Thu Feb 14 2013 Fedora Release Engineering - 0-0.13.20090319svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
+
+* Wed Feb 06 2013 Java SIG - 0-0.12.20090319svn
+- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
+- Replace maven BuildRequires with maven-local
+
+* Fri Jan 4 2013 Mikolaj Izdebski - 0-0.11.20090319svn
+- Add CC-BY to license tag
+- Resolves: rhbz#876648
+
+* Thu Jul 19 2012 Fedora Release Engineering - 0-0.10.20090319svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Sat Jan 14 2012 Richard Fearn - 0-0.9.20090319svn
+- Do not build sampleUses module as it causes Javadoc generation to fail
+
+* Fri Jan 13 2012 Fedora Release Engineering - 0-0.8.20090319svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
+
+* Mon Sep 12 2011 Stanislav Ochotnicky - 0-0.7.20090319svn
+- Use maven3 to build
+- Fix depmap
+- Fix Jave BRs
+
+* Wed Feb 09 2011 Fedora Release Engineering - 0-0.6.20090319svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
+
+* Fri Nov 26 2010 Stanislav Ochotnicky - 0-0.5.20090319svn
+- Fix pom filename (Resolves rhbz#655811)
+- Remove tomcat5 BR (not needed anymore)
+- Use new maven plugin names
+- Remove gcj support
+- Few tweaks according to new guidelines
+- Make jars and javadocs versionless
+
+* Thu Jan 14 2010 Jerry James - 0-0.4.20090319svn
+- Update to 19 Mar 2009 snapshot
+- Compress with xz instead of bzip2
+- BR tomcat5, a horrible workaround to solve bz 538868
+
+* Fri Jul 24 2009 Fedora Release Engineering - 0-0.4.20090203svn
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
+
+* Wed Mar 4 2009 Jerry James - 0-0.3.20090203svn
+- Explicitly require OpenJDK to build
+
+* Sat Feb 28 2009 Jerry James - 0-0.2.20090203svn
+- Update to 03 Feb 2009 snapshot
+
+* Wed Feb 25 2009 Fedora Release Engineering - 0-0.2.20080824svn.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
+
+* Mon Nov 24 2008 Jerry James - 0-0.1.20080824svn.1
+- Cleaned up summary
+
+* Mon Sep 8 2008 Jerry James - 0-0.1.20080824svn
+- Update to 24 Aug 2008 snapshot
+
+* Mon Aug 4 2008 Jerry James - 0-0.1.20080721svn
+- Update to 21 Jul 2008 snapshot
+
+* Mon Jun 30 2008 Jerry James - 0-0.1.20080613svn
+- Update to 13 Jun 2008 snapshot
+- Fix broken URLs
+- Include instructions on regenerating the tarball
+- Conditionalize the gcj bits
+
+* Mon Jun 2 2008 Jerry James - 0-0.1.20080527svn
+- Update to 27 May 2008 snapshot
+
+* Mon May 12 2008 Jerry James - 0-0.1.20071105svn
+- Initial RPM
diff --git a/sources b/sources
new file mode 100644
index 0000000..2794243
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+7132c3378a43fa00f9067dee0c654abc jsr-305-20130910svn.tgz