Removed -Werror
This commit is contained in:
parent
f713284fa2
commit
dcab92994f
@ -2,12 +2,13 @@
|
|||||||
|
|
||||||
Name: jsoncpp
|
Name: jsoncpp
|
||||||
Version: 0.10.5
|
Version: 0.10.5
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: JSON library implemented in C++
|
Summary: JSON library implemented in C++
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
License: Public Domain or MIT
|
License: Public Domain or MIT
|
||||||
URL: https://github.com/open-source-parsers/jsoncpp
|
URL: https://github.com/open-source-parsers/jsoncpp
|
||||||
Source0: https://github.com/open-source-parsers/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
Source0: https://github.com/open-source-parsers/%{name}/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
|
||||||
|
Patch0: nowerror.patch
|
||||||
|
|
||||||
BuildRequires: doxygen cmake
|
BuildRequires: doxygen cmake
|
||||||
BuildRequires: python
|
BuildRequires: python
|
||||||
@ -40,9 +41,10 @@ This package contains the documentation for %{name}
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}
|
%setup -q -n %{name}-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -DBUILD_STATIC_LIBS=OFF .
|
CMAKE_CXX_FLAGS="-Wno-error" %cmake -DBUILD_STATIC_LIBS=OFF .
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
# Build the doc
|
# Build the doc
|
||||||
python doxybuild.py --with-dot --doxygen %{_bindir}/doxygen
|
python doxybuild.py --with-dot --doxygen %{_bindir}/doxygen
|
||||||
@ -77,6 +79,9 @@ install -p -m 0644 dist/doxygen/*/*.{html,png} $RPM_BUILD_ROOT%{_docdir}/%{name}
|
|||||||
%{_docdir}/%{name}/
|
%{_docdir}/%{name}/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 16 2016 Sébastien Willmann <sebastien.willmann@gmail.com> - 0.10.5-4
|
||||||
|
- Disabled Werror
|
||||||
|
|
||||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.5-3
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.10.5-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
16
nowerror.patch
Normal file
16
nowerror.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -ru jsoncpp-0.10.5/CMakeLists.txt jsoncpp-0.10.5.patched/CMakeLists.txt
|
||||||
|
--- jsoncpp-0.10.5/CMakeLists.txt 2015-07-23 07:32:47.000000000 +0200
|
||||||
|
+++ jsoncpp-0.10.5.patched/CMakeLists.txt 2016-02-16 19:10:50.731887585 +0100
|
||||||
|
@@ -97,10 +97,10 @@
|
||||||
|
|
||||||
|
if (CMAKE_CXX_COMPILER_ID MATCHES "Clang")
|
||||||
|
# using regular Clang or AppleClang
|
||||||
|
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Werror -Wall -Wshadow -Wshorten-64-to-32")
|
||||||
|
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -Wshadow -Wshorten-64-to-32")
|
||||||
|
elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "GNU")
|
||||||
|
# using GCC
|
||||||
|
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror -Wall -Wshadow -Wextra -pedantic -Wno-long-long")
|
||||||
|
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wshadow -Wextra -pedantic -Wno-long-long")
|
||||||
|
# not yet ready for -Wconversion
|
||||||
|
endif()
|
||||||
|
|
Loading…
Reference in New Issue
Block a user