- 0.1.39
This commit is contained in:
parent
55c6f9db7d
commit
3224de30d3
19
MANIFEST.MF
19
MANIFEST.MF
@ -1,13 +1,12 @@
|
||||
Manifest-Version: 1.0
|
||||
Bundle-Name: %bundleName
|
||||
Bundle-ClassPath: .
|
||||
Created-By: 1.4.0 (Sun Microsystems Inc.)
|
||||
Bundle-Vendor: %venderName
|
||||
Bundle-RequiredExecutionEnvironment: J2SE-1.4
|
||||
Bundle-ManifestVersion: 2
|
||||
Bundle-Localization: plugin
|
||||
Bundle-SymbolicName: com.jcraft.jsch
|
||||
Export-Package: com.jcraft.jsch, com.jcraft.jsch.jce;x-internal:=true,
|
||||
com.jcraft.jsch.jcraft;x-internal:=true
|
||||
Bundle-Version: 0.1.31
|
||||
|
||||
Bundle-ManifestVersion: 2
|
||||
Bundle-Name: %bundleName
|
||||
Bundle-Localization: plugin
|
||||
Bundle-Version: 0.1.37.v200803061811
|
||||
Bundle-ClassPath: .
|
||||
Bundle-Vendor: %venderName
|
||||
Export-Package: com.jcraft.jsch,com.jcraft.jsch.jce;x-internal:=true,c
|
||||
om.jcraft.jsch.jcraft;x-internal:=true,com.jcraft.jsch.jgss;x-interna
|
||||
l:=true
|
||||
|
@ -1,36 +0,0 @@
|
||||
diff -ru src/com/jcraft/jsch/HostKeyRepository.java.orig src/com/jcraft/jsch/HostKeyRepository.java
|
||||
--- src/com/jcraft/jsch/HostKeyRepository.java.orig 2006-10-15 13:14:46.000000000 -0400
|
||||
+++ src/com/jcraft/jsch/HostKeyRepository.java 2008-04-04 16:44:31.000000000 -0400
|
||||
@@ -36,6 +36,7 @@
|
||||
|
||||
int check(String host, byte[] key);
|
||||
void add(HostKey hostkey, UserInfo ui);
|
||||
+ void add(String host, byte[] key, UserInfo ui);
|
||||
void remove(String host, String type);
|
||||
void remove(String host, String type, byte[] key);
|
||||
String getKnownHostsRepositoryID();
|
||||
diff -ru src/com/jcraft/jsch/KnownHosts.java.orig src/com/jcraft/jsch/KnownHosts.java
|
||||
--- src/com/jcraft/jsch/KnownHosts.java.orig 2006-10-15 14:02:31.000000000 -0400
|
||||
+++ src/com/jcraft/jsch/KnownHosts.java 2008-04-04 16:46:41.000000000 -0400
|
||||
@@ -205,6 +205,20 @@
|
||||
//System.err.println("fail!!");
|
||||
return result;
|
||||
}
|
||||
+
|
||||
+ public void add(String host, byte[] key, UserInfo userinfo)
|
||||
+ {
|
||||
+ try
|
||||
+ {
|
||||
+ HostKey hostkey = new HostKey(host,key);
|
||||
+ add(hostkey, userinfo);
|
||||
+ }
|
||||
+ catch (Exception e)
|
||||
+ {
|
||||
+ // this should't get called
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
public void add(HostKey hostkey, UserInfo userinfo){
|
||||
int type=hostkey.type;
|
||||
String host=hostkey.getHost();
|
||||
|
27
jsch.spec
27
jsch.spec
@ -30,25 +30,27 @@
|
||||
|
||||
%define section free
|
||||
|
||||
%define _with_gcj_support 1
|
||||
|
||||
%define gcj_support %{?_with_gcj_support:1}%{!?_with_gcj_support:%{?_without_gcj_support:0}%{!?_without_gcj_support:%{?_gcj_support:%{_gcj_support}}%{!?_gcj_support:0}}}
|
||||
%define gcj_support 0
|
||||
|
||||
Name: jsch
|
||||
Version: 0.1.31
|
||||
Release: 2.5%{?dist}
|
||||
Version: 0.1.39
|
||||
Release: 1.1%{?dist}
|
||||
Epoch: 0
|
||||
Summary: Pure Java implementation of SSH2
|
||||
Group: Development/Libraries/Java
|
||||
License: BSD
|
||||
URL: http://www.jcraft.com/jsch/
|
||||
Source0: http://download.sourceforge.net/sourceforge/jsch/jsch-%{version}.zip
|
||||
# wget http://download.eclipse.org/tools/orbit/downloads/drops/S200705301823/bundles/com.jcraft.jsch_0.1.31.jar
|
||||
# unzip com.jcraft.jsch_0.1.31.jar META-INF/MANIFEST.MF
|
||||
# mv META-INF/MANIFEST.MF
|
||||
# rmdir META-INF
|
||||
# wget \
|
||||
# http://download.eclipse.org/tools/orbit/downloads/drops/R20080611105805/bundles/com.jcraft.jsch_0.1.37.v200803061811.jar
|
||||
# unzip com.jcraft.jsch_*.jar META-INF/MANIFEST.MF
|
||||
# mv META-INF/MANIFEST.MF .
|
||||
# sed -i "/^Name/d" MANIFEST.MF
|
||||
# sed -i "/^SHA1/d" MANIFEST.MF
|
||||
# dos2unix MANIFEST.MF
|
||||
# sed -i "/^$/d" MANIFEST.MF
|
||||
# unix2dos MANIFEST.MF
|
||||
Source1: MANIFEST.MF
|
||||
Patch0: %{name}-%{version}-backwards-compat.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
|
||||
@ -97,8 +99,6 @@ Requires(postun): coreutils
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch0
|
||||
|
||||
%build
|
||||
export CLASSPATH=$(build-classpath jzlib)
|
||||
ant dist javadoc
|
||||
@ -184,6 +184,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jul 11 2008 Andrew Overholt <overholt@redhat.com> 0:0.1.39-1.1
|
||||
- 0.1.39
|
||||
|
||||
* Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:0.1.31-2.5
|
||||
- drop repotag
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user