jq/jq-configure-c99-1.patch

20 lines
604 B
Diff

Use AC_USE_SYSTEM_EXTENSIONS to build with _GNU_SOURCE (and similar
macros on non-GNU systems), to avoid an implicit declaration of the
strptime function. This improves compatibility with future compilers
which do not support implicit function declarations.
Submitted upstream: <https://github.com/stedolan/jq/pull/2519>
diff --git a/configure.ac b/configure.ac
index 21628bfd5fe99485..ccd494ad7c365839 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,7 @@ AC_PROG_CPP_WERROR
AC_PROG_YACC
AC_OBJEXT
AC_EXEEXT
+AC_USE_SYSTEM_EXTENSIONS
LT_INIT([shared static win32-dll])
AM_PROG_CC_C_O