Auto sync2gitlab import of jq-1.6-5.el8.src.rpm

This commit is contained in:
CentOS Sources 2022-10-26 08:12:06 +00:00
parent 79462f3e3f
commit 0105f94099
2 changed files with 38 additions and 3 deletions

View File

@ -0,0 +1,25 @@
diff -up jq-1.6/src/jv.c.iteration jq-1.6/src/jv.c
--- jq-1.6/src/jv.c.iteration 2022-10-21 14:17:26.977551386 +0200
+++ jq-1.6/src/jv.c 2022-10-21 14:18:43.562430867 +0200
@@ -308,6 +308,7 @@ static jv jvp_literal_number_new(const c
n->refcnt = JV_REFCNT_INIT;
n->literal_data = NULL;
decContext *ctx = DEC_CONTEXT();
+ decContextClearStatus(ctx, DEC_Conversion_syntax);
decNumberFromString(&n->num_decimal, literal, ctx);
n->num_double = NAN;
diff -up jq-1.6/tests/optional.test.iteration jq-1.6/tests/optional.test
--- jq-1.6/tests/optional.test.iteration 2022-10-21 14:22:04.191734821 +0200
+++ jq-1.6/tests/optional.test 2022-10-21 14:23:45.820901911 +0200
@@ -17,4 +17,9 @@ strftime("%A, %B %e, %Y")
1435677542.822351
"Tuesday, June 30, 2015"
-
+# iteration must continue after hello
+.[]|tonumber?
+["1", "hello", "3", 4]
+1
+3
+4

16
jq.spec
View File

@ -1,12 +1,13 @@
Name: jq
Version: 1.6
Release: 3%{?dist}
Release: 5%{?dist}
Summary: Command-line JSON processor
License: MIT and ASL 2.0 and CC-BY and GPLv3
URL: http://stedolan.github.io/jq/
Source0: https://github.com/stedolan/jq/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
Patch0: 0000-jq-decimal-literal-number.patch
Patch1: 0001-iterration-problem-for-non-decimal-string.patch
BuildRequires: flex
BuildRequires: bison
@ -14,6 +15,7 @@ BuildRequires: oniguruma-devel
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
BuildRequires: chrpath
%ifnarch s390x
BuildRequires: valgrind
@ -45,8 +47,7 @@ Development files for %{name}
%prep
%setup -qn %{name}-%{version}
%patch0 -p1 -b .bigint
%autosetup -n %{name}-%{version} -p1
%build
autoreconf -fi
@ -69,6 +70,7 @@ make %{?_smp_mflags}
%install
make DESTDIR=%{buildroot} install
find %{buildroot} -name '*.la' -exec rm -f {} ';'
chrpath --delete %{buildroot}/usr/bin/jq
%check
# Valgrind used, so restrict architectures for check
@ -94,6 +96,14 @@ make check
%changelog
* Tue Oct 11 2022 Tomas Halman <thalman@redhat.com> - 1.6-5
- Remove rpath from jq binary
- Related: rhbz#2049601
* Tue Oct 11 2022 Tomas Halman <thalman@redhat.com> - 1.6-4
- Fix iterration problem for non decimal string
- Resolves: rhbz#2049601
* Mon Oct 4 2021 Tomas Halman <thalman@redhat.com>
- Fix big integers issue
- Resolves: bug#2008717