Update to 1.7

This commit is contained in:
Mikel Olasagasti Uranga 2023-09-08 17:08:33 +02:00
parent 8e77e767fc
commit 000a817246
7 changed files with 18 additions and 27667 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/jq-1.3.tar.gz
/jq-1.5.tar.gz
/jq-1.6.tar.gz
/jq-1.7.tar.gz

View File

@ -1,19 +0,0 @@
Use AC_USE_SYSTEM_EXTENSIONS to build with _GNU_SOURCE (and similar
macros on non-GNU systems), to avoid an implicit declaration of the
strptime function. This improves compatibility with future compilers
which do not support implicit function declarations.
Submitted upstream: <https://github.com/stedolan/jq/pull/2519>
diff --git a/configure.ac b/configure.ac
index 21628bfd5fe99485..ccd494ad7c365839 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,7 @@ AC_PROG_CPP_WERROR
AC_PROG_YACC
AC_OBJEXT
AC_EXEEXT
+AC_USE_SYSTEM_EXTENSIONS
LT_INIT([shared static win32-dll])
AM_PROG_CC_C_O

View File

@ -1,18 +0,0 @@
The gettimeofday function is declared in <sys/time.h>, not <time.h>,
according to POSIX and actual systems.
Submitted upstream: <https://github.com/stedolan/jq/pull/2519>
diff --git a/configure.ac b/configure.ac
index ccd494ad7c365839..c3edaa32756b807c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -135,7 +135,7 @@ AC_FIND_FUNC([gmtime_r], [c], [#include <time.h>], [0, 0])
AC_FIND_FUNC([gmtime], [c], [#include <time.h>], [0])
AC_FIND_FUNC([localtime_r], [c], [#include <time.h>], [0, 0])
AC_FIND_FUNC([localtime], [c], [#include <time.h>], [0])
-AC_FIND_FUNC([gettimeofday], [c], [#include <time.h>], [0, 0])
+AC_FIND_FUNC([gettimeofday], [c], [#include <sys/time.h>], [0, 0])
AC_CHECK_MEMBER([struct tm.tm_gmtoff], [AC_DEFINE([HAVE_TM_TM_GMT_OFF],1,[Define to 1 if the system has the tm_gmt_off field in struct tm])],
[], [[#include <time.h>]])
AC_CHECK_MEMBER([struct tm.__tm_gmtoff], [AC_DEFINE([HAVE_TM___TM_GMT_OFF],1,[Define to 1 if the system has the __tm_gmt_off field in struct tm])],

File diff suppressed because it is too large Load Diff

View File

@ -1,11 +0,0 @@
diff -Naur a/src/jv.c b/src/jv.c
--- a/src/jv.c 2022-03-08 12:42:41.169813593 -0800
+++ b/src/jv.c 2022-03-08 12:43:28.189080921 -0800
@@ -308,6 +308,7 @@
n->refcnt = JV_REFCNT_INIT;
n->literal_data = NULL;
decContext *ctx = DEC_CONTEXT();
+ decContextClearStatus(ctx, DEC_Conversion_syntax);
decNumberFromString(&n->num_decimal, literal, ctx);
n->num_double = NAN;

38
jq.spec
View File

@ -1,17 +1,13 @@
%bcond_without check
Name: jq
Version: 1.6
Version: 1.7
Release: %autorelease
Summary: Command-line JSON processor
License: MIT and ASL 2.0 and CC-BY and GPLv3
URL: http://stedolan.github.io/jq/
Source0: https://github.com/stedolan/jq/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
# Backport of PR#1752 for RHBZ#2008979
Patch0: jq-decimal-literal-number.patch
# Backport of PR#2400 for RHBZ#2017285
Patch1: jq-fix-non-decimal-string.patch
Patch2: jq-configure-c99-1.patch
Patch3: jq-configure-c99-2.patch
URL: https://jqlang.github.io/jq/
Source0: https://github.com/jqlang/jq/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
BuildRequires: gcc
BuildRequires: flex
@ -22,10 +18,10 @@ BuildRequires: oniguruma-devel
%ifarch %{valgrind_arches}
BuildRequires: valgrind
%endif
BuildRequires: make
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
BuildRequires: make
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
%description
@ -45,8 +41,8 @@ lightweight and flexible command-line JSON processor
you'd expect.
%package devel
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
Summary: Development files for %{name}
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
Development files for %{name}
@ -81,28 +77,26 @@ find %{buildroot} -name '*.la' -exec rm -f {} ';'
# system - rhbz#1987608
chrpath -d %{buildroot}%{_bindir}/%{name}
%if %{with check}
%check
# Valgrind used, so restrict architectures for check
%ifarch %{ix86} x86_64
make check
%endif
%ldconfig_scriptlets
%endif
%files
%license COPYING
%doc AUTHORS COPYING NEWS.md README.md
%{_bindir}/%{name}
%{_libdir}/libjq.so.*
%{_datadir}/man/man1/jq.1.gz
%{_datadir}/doc/jq/AUTHORS
%{_datadir}/doc/jq/COPYING
%{_datadir}/doc/jq/README
%{_datadir}/doc/jq/README.md
%files devel
%{_includedir}/jq.h
%{_includedir}/jv.h
%{_libdir}/libjq.so
%{_libdir}/pkgconfig/libjq.pc
%changelog
%autochangelog

View File

@ -1 +1 @@
SHA512 (jq-1.6.tar.gz) = f5ae8be558ca2ff15324c378d623106b74bd0823be50835e23548584aa1eb24eb81f8f054693d5d3fe44f157d0735c5f0f40b9f21899ba068f2a11d1345ace19
SHA512 (jq-1.7.tar.gz) = 4f8a6b0401e6c881dcb97d948fe38871062599a43fff667ede21cf185ec9de33e61878f0a6ea12786d0a632eea592ea0ff860520ba02dbb32f2fa2d2b5db7a0a