aefd102bb0
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/jna#82a0a123311fb18e15ac6dc722a3f6628951199e
31 lines
1003 B
Diff
31 lines
1003 B
Diff
From 6e8784db2fa3b3b2efedaae75d15d5d5cf3ed50c Mon Sep 17 00:00:00 2001
|
|
From: Michael Simacek <msimacek@redhat.com>
|
|
Date: Thu, 22 Feb 2018 16:17:15 +0100
|
|
Subject: [PATCH 6/6] Remove -Werror
|
|
|
|
---
|
|
native/Makefile | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/native/Makefile b/native/Makefile
|
|
index cb3afed..028c201 100644
|
|
--- a/native/Makefile
|
|
+++ b/native/Makefile
|
|
@@ -337,11 +337,11 @@ ifeq ($(CC),gcc)
|
|
GCC_MAJOR_VERSION = $(shell gcc -dumpversion | cut -f 1 -d '.')
|
|
ifneq ($(GCC_MAJOR_VERSION),4)
|
|
ifneq ($(GCC_MAJOR_VERSION),3)
|
|
- LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable
|
|
+ LOC_CC_OPTS=-Wno-unknown-warning-option -Wno-clobbered -Wno-unused-variable
|
|
endif
|
|
endif
|
|
else
|
|
- LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable
|
|
+ LOC_CC_OPTS=-Wno-unknown-warning-option -Wno-clobbered -Wno-unused-variable
|
|
endif
|
|
|
|
# Enable 64-bit builds if the arch demands it
|
|
--
|
|
2.20.1
|
|
|