jna/SOURCES/0006-Remove-Werror.patch

30 lines
961 B
Diff

From 6e8784db2fa3b3b2efedaae75d15d5d5cf3ed50c Mon Sep 17 00:00:00 2001
From: Michael Simacek <msimacek@redhat.com>
Date: Thu, 22 Feb 2018 16:17:15 +0100
Subject: [PATCH 6/6] Remove -Werror
---
native/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/native/Makefile b/native/Makefile
index 3712a9e..73a906f 100644
--- a/native/Makefile
+++ b/native/Makefile
@@ -336,10 +336,10 @@ endif
ifeq ($(CC),gcc)
GCC_MAJOR_VERSION = $(shell gcc -dumpversion | cut -f 1 -d '.')
ifneq ($(GCC_MAJOR_VERSION),4)
- LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable
+ LOC_CC_OPTS=-Wno-unknown-warning-option -Wno-clobbered -Wno-unused-variable
endif
else
- LOC_CC_OPTS=-Wno-unknown-warning-option -Werror -Wno-clobbered -Wno-unused-variable
+ LOC_CC_OPTS=-Wno-unknown-warning-option -Wno-clobbered -Wno-unused-variable
endif
# Enable 64-bit builds if the arch demands it
--
2.14.3