aefd102bb0
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/jna#82a0a123311fb18e15ac6dc722a3f6628951199e
34 lines
1.1 KiB
Diff
34 lines
1.1 KiB
Diff
From 52ef407584801916d6e60c4f4c5411023b5ac369 Mon Sep 17 00:00:00 2001
|
|
From: Michael Simacek <msimacek@redhat.com>
|
|
Date: Mon, 16 Jan 2017 11:29:06 +0100
|
|
Subject: [PATCH 1/6] Adapt build
|
|
|
|
---
|
|
native/Makefile | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/native/Makefile b/native/Makefile
|
|
index 1bea2dc..cb3afed 100644
|
|
--- a/native/Makefile
|
|
+++ b/native/Makefile
|
|
@@ -97,7 +97,7 @@ CDEFINES=-D_REENTRANT
|
|
PCFLAGS=-W -Wall -Wno-unused -Wno-parentheses
|
|
CFLAGS=$(PCFLAGS) $(CFLAGS_EXTRA) $(COPT) $(CDEBUG) $(CDEFINES) $(CINCLUDES) \
|
|
-DJNA_JNI_VERSION='"$(JNA_JNI_VERSION)"' -DCHECKSUM='"$(CHECKSUM)"'
|
|
-LDFLAGS=-o $@ -shared
|
|
+LDFLAGS=$(RPM_LD_FLAGS) -o $@ -shared
|
|
ifeq ($(DYNAMIC_LIBFFI),true)
|
|
CFLAGS += $(shell pkg-config --cflags libffi 2>/dev/null || echo)
|
|
LIBS += $(shell pkg-config --libs libffi 2>/dev/null || echo -lffi)
|
|
@@ -457,7 +457,6 @@ $(BUILD)/$(JNA_JNI_VERSION).stamp:
|
|
|
|
$(LIBRARY): $(JNIDISPATCH_OBJS) $(FFI_LIB)
|
|
$(LD) $(LDFLAGS) $(JNIDISPATCH_OBJS) $(FFI_LIB) $(LIBS)
|
|
- $(STRIP) $@
|
|
|
|
$(TESTLIB): $(BUILD)/testlib.o
|
|
$(LD) $(LDFLAGS) $< $(LIBS)
|
|
--
|
|
2.20.1
|
|
|