Update to upstream version 4.5.1
This commit is contained in:
parent
02b3586320
commit
c20644b2a7
1
.gitignore
vendored
1
.gitignore
vendored
@ -12,3 +12,4 @@ jna-3.2.7.tar.bz2
|
||||
/jna-4.3.0-clean.tar.xz
|
||||
/jna-4.4.0-clean.tar.xz
|
||||
/jna-4.5.0-clean.tar.xz
|
||||
/jna-4.5.1-clean.tar.xz
|
||||
|
@ -1,4 +1,4 @@
|
||||
From d9b409e9d7cf16a8bb109f3336cb8c8f4e8a3531 Mon Sep 17 00:00:00 2001
|
||||
From 52ef407584801916d6e60c4f4c5411023b5ac369 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Mon, 16 Jan 2017 11:29:06 +0100
|
||||
Subject: [PATCH 1/5] Adapt build
|
||||
@ -29,5 +29,5 @@ index 6f9ad25..3712a9e 100644
|
||||
$(TESTLIB): $(BUILD)/testlib.o
|
||||
$(LD) $(LDFLAGS) $< $(LIBS)
|
||||
--
|
||||
2.13.5
|
||||
2.14.3
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From d16fea5f0fb7720ca4d7b58d4facfb36eb293ef4 Mon Sep 17 00:00:00 2001
|
||||
From 3d08314de0494ff8bdc1a7bccc0ecc1730dbdd60 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Mon, 16 Jan 2017 11:31:32 +0100
|
||||
Subject: [PATCH 2/5] Load system library
|
||||
@ -118,5 +118,5 @@ index 91b195f..9ac3815 100644
|
||||
|
||||
static final String JNA_TMPLIB_PREFIX = "jna";
|
||||
--
|
||||
2.13.5
|
||||
2.14.3
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 02150119b13f944ed40ab9b6335eb1540de52516 Mon Sep 17 00:00:00 2001
|
||||
From c0f33e9ed0a5cfd79b58487c2a36c9b880b49947 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Mon, 16 Jan 2017 11:32:32 +0100
|
||||
Subject: [PATCH 3/5] Tests headless
|
||||
@ -8,10 +8,10 @@ Subject: [PATCH 3/5] Tests headless
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index b956b6e..10fdab2 100644
|
||||
index 63a9cc7..ab9cf52 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -1118,6 +1118,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
@@ -1128,6 +1128,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
<sysproperty key="jna.builddir" file="${build}"/>
|
||||
<sysproperty key="jna.nativedir" file="${build.native}"/>
|
||||
<jvmarg value="${vmopt.arch}"/>
|
||||
@ -20,5 +20,5 @@ index b956b6e..10fdab2 100644
|
||||
<formatter type="brief" usefile="false"/>
|
||||
<formatter type="xml"/>
|
||||
--
|
||||
2.13.5
|
||||
2.14.3
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 5c45622fff4f2f4ed80b4619f4b575af6bac6a22 Mon Sep 17 00:00:00 2001
|
||||
From ced8baacd3bccba7ebaba80785b891bf579af215 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Simacek <msimacek@redhat.com>
|
||||
Date: Tue, 31 Jan 2017 14:21:19 +0100
|
||||
Subject: [PATCH 4/5] Fix javadoc build
|
||||
@ -8,10 +8,10 @@ Subject: [PATCH 4/5] Fix javadoc build
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index 10fdab2..56f2b6e 100644
|
||||
index ab9cf52..d1fe4aa 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -1223,6 +1223,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
@@ -1233,6 +1233,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
<group title="Platform Specific" packages="com.sun.jna.platform.*"/>
|
||||
|
||||
<arg value="-notimestamp"/>
|
||||
@ -20,5 +20,5 @@ index 10fdab2..56f2b6e 100644
|
||||
<jar jarfile="${platform-javadoc-jar}">
|
||||
<fileset dir="${javadoc}" />
|
||||
--
|
||||
2.13.5
|
||||
2.14.3
|
||||
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 3e50e65e9139587414959e89e7721eff5c38552b Mon Sep 17 00:00:00 2001
|
||||
From de939d7c9266f89542cea5ebef5980a95f1244a9 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Mon, 10 Jul 2017 11:48:43 +0200
|
||||
Subject: [PATCH 5/5] Fix duplicate manifest entry
|
||||
@ -9,10 +9,10 @@ Resolves https://bugzilla.redhat.com/show_bug.cgi?id=1469022
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/build.xml b/build.xml
|
||||
index 56f2b6e..f9713da 100644
|
||||
index d1fe4aa..c0a0b78 100644
|
||||
--- a/build.xml
|
||||
+++ b/build.xml
|
||||
@@ -561,9 +561,9 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
@@ -571,9 +571,9 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
|
||||
includes="*jnidispatch*"
|
||||
prefix="com/sun/jna/w32ce-arm"/>
|
||||
</jar>
|
||||
@ -25,5 +25,5 @@ index 56f2b6e..f9713da 100644
|
||||
|
||||
<target name="aar" depends="jar" description="Build Android Archive">
|
||||
--
|
||||
2.13.5
|
||||
2.14.3
|
||||
|
||||
|
5
jna.spec
5
jna.spec
@ -1,5 +1,5 @@
|
||||
Name: jna
|
||||
Version: 4.5.0
|
||||
Version: 4.5.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Pure Java access to native libraries
|
||||
# Most of code is dual-licensed under either LGPL 2.1 only or Apache
|
||||
@ -126,6 +126,9 @@ install -m 755 build/native*/libjnidispatch*.so %{buildroot}%{_libdir}/%{name}/
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jan 05 2018 Michael Simacek <msimacek@redhat.com> - 4.5.1-1
|
||||
- Update to upstream version 4.5.1
|
||||
|
||||
* Tue Sep 19 2017 Michael Simacek <msimacek@redhat.com> - 4.5.0-1
|
||||
- Update to upstream version 4.5.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (jna-4.5.0-clean.tar.xz) = 7d9e009bdc708ac139feec2eac994937bff5ae962b1fa4d684b0a824cc6f694a7e958a0df9e5949f2cdfd3e7e9f828ec174f3b304b0eb94db47131fa76a6a38e
|
||||
SHA512 (jna-4.5.1-clean.tar.xz) = e27a5635ebcb746dd7c1de9d408ef803039fe46b865aca4d7352ffda6439f1b4d3e19b2543d7de2790505c3e5d1f4d4749b5cc3e5d2bccfba878d6c6bcb2fcdd
|
||||
|
Loading…
Reference in New Issue
Block a user