diff --git a/jna.spec b/jna.spec
index f4f03dc..84648c2 100644
--- a/jna.spec
+++ b/jna.spec
@@ -3,7 +3,7 @@
Name: jna
Version: 4.5.1
-Release: 7%{?dist}
+Release: 8%{?dist}
Summary: Pure Java access to native libraries
# Most of code is dual-licensed under either LGPL 2.1 only or Apache
# License 2.0. WeakIdentityHashMap.java was taken from Apache CXF,
@@ -97,13 +97,14 @@ chmod -c 0644 LICENSE OTHERS CHANGES.md
%if %{with reflections}
sed s,',&,' -i build.xml
-build-jar-repository -s -p lib junit reflections ant
+build-jar-repository -s -p lib junit reflections
%else
-build-jar-repository -s -p lib junit ant
+build-jar-repository -s -p lib junit
rm test/com/sun/jna/StructureFieldOrderInspector.java
rm test/com/sun/jna/StructureFieldOrderInspectorTest.java
rm contrib/platform/test/com/sun/jna/platform/StructureFieldOrderTest.java
%endif
+ln -s $(xmvn-resolve ant:ant:1.10.5) lib/ant.jar
cp lib/native/aix-ppc64.jar lib/clover.jar
@@ -153,6 +154,9 @@ install -m 755 build/native*/libjnidispatch*.so %{buildroot}%{_libdir}/%{name}/
%changelog
+* Mon Jun 17 2019 Mat Booth - 4.5.1-8
+- Use xmvn-resolve for portable way to get the ant jar
+
* Sat Jun 08 2019 Mat Booth - 4.5.1-7
- Speed up builds on 32bit arm