sync with f-13
This commit is contained in:
parent
4f6871ad71
commit
b6a9ecd964
11
jna-3.2.4-build-md5.patch
Normal file
11
jna-3.2.4-build-md5.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- build.xml 2010-04-21 17:45:22.419903811 -0400
|
||||||
|
+++ build.xml.orig 2010-04-21 17:45:10.204664997 -0400
|
||||||
|
@@ -43,7 +43,7 @@
|
||||||
|
<property name="jni.revision" value="1"/>
|
||||||
|
<property name="jni.build" value="${build.number}"/>
|
||||||
|
<property name="jni.version" value="${jni.major}.${jni.minor}.${jni.revision}"/>
|
||||||
|
- <property name="jni.md5" value=""/>
|
||||||
|
+ <property name="jni.md5" value="c870290c36c8d3fdf85db7c782febc3f"/>
|
||||||
|
<property name="spec.title" value="Java Native Access (JNA)"/>
|
||||||
|
<property name="spec.vendor" value="${vendor}"/>
|
||||||
|
<property name="spec.version" value="${jna.major}"/>
|
40
jna-3.2.4-gcj-javadoc.patch
Normal file
40
jna-3.2.4-gcj-javadoc.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
--- build.xml.orig 2010-04-22 15:22:49.082452327 -0400
|
||||||
|
+++ build.xml 2010-04-22 15:22:54.266203934 -0400
|
||||||
|
@@ -540,8 +540,6 @@
|
||||||
|
<group title="Examples" packages="com.sun.jna.examples,com.sun.jna.examples.dnd"/>
|
||||||
|
<group title="Unix Examples" packages="com.sun.jna.examples.unix"/>
|
||||||
|
<group title="Windows Examples" packages="com.sun.jna.examples.win32"/>
|
||||||
|
-
|
||||||
|
- <arg value="-notimestamp"/>
|
||||||
|
</javadoc>
|
||||||
|
</target>
|
||||||
|
|
||||||
|
--- src/com/sun/jna/Function.java.orig 2010-04-22 15:23:32.766205632 -0400
|
||||||
|
+++ src/com/sun/jna/Function.java 2010-04-22 15:23:55.909207399 -0400
|
||||||
|
@@ -76,7 +76,7 @@
|
||||||
|
* Library in which to find the native function
|
||||||
|
* @param functionName
|
||||||
|
* Name of the native function to be linked with
|
||||||
|
- * @throws {@link UnsatisfiedLinkError} if the library is not found or
|
||||||
|
+ * @throws UnsatisfiedLinkError if the library is not found or
|
||||||
|
* the given function name is not found within the library.
|
||||||
|
*/
|
||||||
|
public static Function getFunction(String libraryName, String functionName) {
|
||||||
|
@@ -97,7 +97,7 @@
|
||||||
|
* @param callFlags
|
||||||
|
* Function <a href="#callflags">call flags</a>
|
||||||
|
*
|
||||||
|
- * @throws {@link UnsatisfiedLinkError} if the library is not found or
|
||||||
|
+ * @throws UnsatisfiedLinkError if the library is not found or
|
||||||
|
* the given function name is not found within the library.
|
||||||
|
*/
|
||||||
|
public static Function getFunction(String libraryName, String functionName, int callFlags) {
|
||||||
|
@@ -161,7 +161,7 @@
|
||||||
|
* Name of the native function to be linked with
|
||||||
|
* @param callFlags
|
||||||
|
* Function <a href="#callflags">call flags</a>
|
||||||
|
- * @throws {@link UnsatisfiedLinkError} if the given function name is
|
||||||
|
+ * @throws UnsatisfiedLinkError if the given function name is
|
||||||
|
* not found within the library.
|
||||||
|
*/
|
||||||
|
Function(NativeLibrary library, String functionName, int callFlags) {
|
12
jna.spec
12
jna.spec
@ -1,6 +1,6 @@
|
|||||||
Name: jna
|
Name: jna
|
||||||
Version: 3.2.4
|
Version: 3.2.4
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Summary: Pure Java access to native libraries
|
Summary: Pure Java access to native libraries
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -23,13 +23,15 @@ Patch2: jna-3.2.4-tests-headless.patch
|
|||||||
# Upstream appears to have some sort of MD5 check on the contents of their
|
# Upstream appears to have some sort of MD5 check on the contents of their
|
||||||
# native jar. Carve that out so we always build it.
|
# native jar. Carve that out so we always build it.
|
||||||
Patch3: jna-3.2.4-build-md5.patch
|
Patch3: jna-3.2.4-build-md5.patch
|
||||||
|
# Build using GCJ javadoc
|
||||||
|
Patch4: jna-3.2.4-gcj-javadoc.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
BuildRequires: java-devel >= 1.6 ant jpackage-utils ant-nodeps
|
BuildRequires: java-devel ant jpackage-utils ant-nodeps
|
||||||
BuildRequires: libX11-devel libXt-devel libffi-devel
|
BuildRequires: libX11-devel libXt-devel libffi-devel
|
||||||
# We manually require libffi because find-requires doesn't work
|
# We manually require libffi because find-requires doesn't work
|
||||||
# inside jars.
|
# inside jars.
|
||||||
Requires: java >= 1:1.6.0 jpackage-utils libffi
|
Requires: java jpackage-utils libffi
|
||||||
# for ExcludeArch see bug: 468831
|
# for ExcludeArch see bug: 468831
|
||||||
%if 0%{?rhel} < 6 && 0%{?fedora} < 10
|
%if 0%{?rhel} < 6 && 0%{?fedora} < 10
|
||||||
ExcludeArch: ppc ppc64
|
ExcludeArch: ppc ppc64
|
||||||
@ -70,6 +72,7 @@ This package contains the examples for %{name}.
|
|||||||
sed -e 's|@JNIPATH@|%{_libdir}/%{name}|' %{PATCH1} | patch -p1
|
sed -e 's|@JNIPATH@|%{_libdir}/%{name}|' %{PATCH1} | patch -p1
|
||||||
%patch2 -p1 -b .tests-headless
|
%patch2 -p1 -b .tests-headless
|
||||||
%patch3 -p0 -R -b .md5
|
%patch3 -p0 -R -b .md5
|
||||||
|
%patch4 -p0 -b .gcj-javadoc
|
||||||
|
|
||||||
# all java binaries must be removed from the sources
|
# all java binaries must be removed from the sources
|
||||||
find . -name '*.jar' -exec rm -f '{}' \;
|
find . -name '*.jar' -exec rm -f '{}' \;
|
||||||
@ -132,6 +135,9 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Apr 22 2010 Colin Walters <walters@verbum.org> - 3.2.4-5
|
||||||
|
- Add patches to make the build happen with gcj
|
||||||
|
|
||||||
* Wed Apr 21 2010 Colin Walters <walters@verbum.org> - 3.2.4-4
|
* Wed Apr 21 2010 Colin Walters <walters@verbum.org> - 3.2.4-4
|
||||||
- Fix the build by removing upstream's hardcoded md5
|
- Fix the build by removing upstream's hardcoded md5
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user