Try to fix javadoc generation

This commit is contained in:
Michael Simacek 2017-01-31 14:24:51 +01:00
parent 204ab98f9b
commit 98ca199be2
5 changed files with 37 additions and 4 deletions

View File

@ -1,7 +1,7 @@
From c38ff2904958eeae70e3d47b7b2363f9f181013b Mon Sep 17 00:00:00 2001
From: Michael Simacek <msimacek@redhat.com>
Date: Mon, 16 Jan 2017 11:29:06 +0100
Subject: [PATCH 1/3] Adapt build
Subject: [PATCH 1/4] Adapt build
---
native/Makefile | 3 +--

View File

@ -1,7 +1,7 @@
From 3f48354a76a0d24fb21e9132482d9ff7af6df8b4 Mon Sep 17 00:00:00 2001
From: Michael Simacek <msimacek@redhat.com>
Date: Mon, 16 Jan 2017 11:31:32 +0100
Subject: [PATCH 2/3] Load system library
Subject: [PATCH 2/4] Load system library
---
src/com/sun/jna/Native.java | 97 ++-------------------------------------------

View File

@ -1,7 +1,7 @@
From 4a4aae7689b217a0057608667eb03d2eea3f3eba Mon Sep 17 00:00:00 2001
From: Michael Simacek <msimacek@redhat.com>
Date: Mon, 16 Jan 2017 11:32:32 +0100
Subject: [PATCH 3/3] Tests headless
Subject: [PATCH 3/4] Tests headless
---
build.xml | 1 +

View File

@ -0,0 +1,24 @@
From 5fb86e7e8a37d8215d16480672a39e3ba75bd79d Mon Sep 17 00:00:00 2001
From: Michael Simacek <msimacek@redhat.com>
Date: Tue, 31 Jan 2017 14:21:19 +0100
Subject: [PATCH 4/4] Fix javadoc build
---
build.xml | 1 +
1 file changed, 1 insertion(+)
diff --git a/build.xml b/build.xml
index d9be501..bbb93a3 100644
--- a/build.xml
+++ b/build.xml
@@ -1113,6 +1113,7 @@ osname=macosx;processor=x86;processor=x86-64;processor=ppc
<group title="Platform Specific" packages="com.sun.jna.platform.*"/>
<arg value="-notimestamp"/>
+ <arg value="--allow-script-in-comments"/>
</javadoc>
<jar jarfile="${platform-javadoc-jar}">
<fileset dir="${javadoc}" />
--
2.9.3

View File

@ -1,6 +1,6 @@
Name: jna
Version: 4.3.0
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Pure Java access to native libraries
# Most of code is dual-licensed under either LGPL 2.1 only or Apache
# License 2.0. WeakIdentityHashMap.java was taken from Apache CXF,
@ -20,6 +20,8 @@ Patch1: 0002-Load-system-library.patch
# and using a complex API like X11 through JNA just increases the potential
# for problems.
Patch2: 0003-Tests-headless.patch
# Adds --allow-script-in-comments arg to javadoc to avoid error
Patch3: 0004-Fix-javadoc-build.patch
# We manually require libffi because find-requires doesn't work
# inside jars.
@ -65,6 +67,10 @@ cp %{SOURCE1} .
%patch0 -p1 -b .build
%patch1 -p1 -b .loadlib
%patch2 -p1 -b .tests-headless
# openjdk on arm is older, so it doesn't have the check, nor the option to disable it
%ifnarch armv7hl
%patch3 -p1
%endif
chmod -Rf a+rX,u+w,g-w,o-w .
sed -i 's|@LIBDIR@|%{_libdir}/%{name}|' src/com/sun/jna/Native.java
@ -126,6 +132,9 @@ cp -a doc/javadoc/* %{buildroot}%{_javadocdir}/%{name}
%changelog
* Tue Jan 31 2017 Michael Simacek <msimacek@redhat.com> - 4.3.0-2
- Try to fix javadoc generation
* Mon Jan 16 2017 Michael Simacek <msimacek@redhat.com> - 4.3.0-1
- Update to upstream version 4.3.0
- Cleanup rhel macros, because packages was retired in EPEL