update to 4.1.0
This commit is contained in:
parent
1213bf7f16
commit
8f3eecab06
48
jna-4.1.0-junit.patch
Normal file
48
jna-4.1.0-junit.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
diff -up ./build.xml.junit ./build.xml
|
||||||
|
--- ./build.xml.junit 2014-03-07 12:52:05.899899902 +0100
|
||||||
|
+++ ./build.xml 2014-03-07 12:58:14.956255306 +0100
|
||||||
|
@@ -290,7 +290,7 @@
|
||||||
|
<target name="-setup" depends="-dynamic-properties">
|
||||||
|
<path id="compile-test.path">
|
||||||
|
<path id="test.libs">
|
||||||
|
- <fileset dir="lib">
|
||||||
|
+ <fileset dir="/usr/share/java">
|
||||||
|
<include name="junit.jar"/>
|
||||||
|
</fileset>
|
||||||
|
<fileset dir="lib/test"/>
|
||||||
|
@@ -486,7 +486,7 @@ osname=macosx;processor=x86;processor=x8
|
||||||
|
<subant target="jar" failonerror="true">
|
||||||
|
<property name="file.reference.jna.build" location="${build}"/>
|
||||||
|
<property name="file.reference.jna.jar" location="${build}/${jar}"/>
|
||||||
|
- <property name="libs.junit.classpath" location="lib/junit.jar"/>
|
||||||
|
+ <property name="libs.junit.classpath" location="/usr/share/java/junit.jar"/>
|
||||||
|
<property name="javac.source" value="${platform.compatibility}"/>
|
||||||
|
<property name="javac.target" value="${platform.compatibility}"/>
|
||||||
|
<!-- OSGi manifest properties -->
|
||||||
|
@@ -509,7 +509,7 @@ osname=macosx;processor=x86;processor=x8
|
||||||
|
<subant target="jar" failonerror="true">
|
||||||
|
<property name="file.reference.jna.build" location="${build}"/>
|
||||||
|
<property name="file.reference.jna.jar" location="${build}/${jar}"/>
|
||||||
|
- <property name="libs.junit.classpath" location="lib/junit.jar"/>
|
||||||
|
+ <property name="libs.junit.classpath" location="/usr/share/java/junit.jar"/>
|
||||||
|
<fileset dir="${contrib}" includes="*/build.xml" excludes="platform/build.xml"/>
|
||||||
|
</subant>
|
||||||
|
</target>
|
||||||
|
@@ -822,7 +822,7 @@ osname=macosx;processor=x86;processor=x8
|
||||||
|
<mkdir dir="${build}/jws"/>
|
||||||
|
<copy todir="${build}/jws" file="${build}/${jar}"/>
|
||||||
|
<copy todir="${build}/jws" file="${build}/${testjar}"/>
|
||||||
|
- <copy todir="${build}/jws" file="lib/junit.jar"/>
|
||||||
|
+ <copy todir="${build}/jws" file="/usr/share/java/junit.jar"/>
|
||||||
|
<copy todir="${build}/jws" file="lib/clover.jar"/>
|
||||||
|
<jar jarfile="${build}/jws/jnidispatch.jar">
|
||||||
|
<fileset dir="${build.native}" includes="*jnidispatch.*"/>
|
||||||
|
@@ -933,7 +933,7 @@ osname=macosx;processor=x86;processor=x8
|
||||||
|
<subant target="test" failonerror="true" inheritall="true" inheritrefs="true">
|
||||||
|
<property name="file.reference.jna.build" location="${build}"/>
|
||||||
|
<property name="file.reference.jna.jar" location="${build}/${jar}"/>
|
||||||
|
- <property name="libs.junit.classpath" location="lib/junit.jar"/>
|
||||||
|
+ <property name="libs.junit.classpath" location="/usr/share/java/junit.jar"/>
|
||||||
|
<property name="javac.source" value="${test.compatibility}"/>
|
||||||
|
<property name="javac.target" value="${test.compatibility}"/>
|
||||||
|
<fileset dir="${contrib}" includes="platform/build.xml"/>
|
18
jna.spec
18
jna.spec
@ -1,8 +1,6 @@
|
|||||||
%global innerversion 4.0
|
|
||||||
|
|
||||||
Name: jna
|
Name: jna
|
||||||
Version: 4.0.0
|
Version: 4.1.0
|
||||||
Release: 5%{?dist}
|
Release: 4%{?dist}
|
||||||
Summary: Pure Java access to native libraries
|
Summary: Pure Java access to native libraries
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -15,7 +13,7 @@ URL: https://jna.dev.java.net/
|
|||||||
# mv twall-jna-* jna-%{version}
|
# mv twall-jna-* jna-%{version}
|
||||||
# rm -rf jna-%{version}/{dist/*,www}
|
# rm -rf jna-%{version}/{dist/*,www}
|
||||||
# tar cjf ~/rpm/SOURCES/jna-%{version}.tar.gz jna-%{version}
|
# tar cjf ~/rpm/SOURCES/jna-%{version}.tar.gz jna-%{version}
|
||||||
Source0: https://github.com/twall/jna/archive/%{name}-%{innerversion}.tar.gz
|
Source0: https://github.com/twall/jna/archive/%{name}-%{version}.tar.gz
|
||||||
Source1: package-list
|
Source1: package-list
|
||||||
Patch0: jna-3.5.0-build.patch
|
Patch0: jna-3.5.0-build.patch
|
||||||
# This patch is Fedora-specific for now until we get the huge
|
# This patch is Fedora-specific for now until we get the huge
|
||||||
@ -29,8 +27,7 @@ Patch2: jna-4.0.0-tests-headless.patch
|
|||||||
# Build using GCJ javadoc
|
# Build using GCJ javadoc
|
||||||
Patch3: jna-3.5.2-gcj-javadoc.patch
|
Patch3: jna-3.5.2-gcj-javadoc.patch
|
||||||
# junit cames from rpm
|
# junit cames from rpm
|
||||||
Patch4: jna-4.0.0-junit.patch
|
Patch4: jna-4.1.0-junit.patch
|
||||||
Patch5: jna-4.0.0-charfix.patch
|
|
||||||
Patch6: jna-4.0.0-ffi.patch
|
Patch6: jna-4.0.0-ffi.patch
|
||||||
Patch7: jna-4.0.0-fix-native-test.patch
|
Patch7: jna-4.0.0-fix-native-test.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -88,7 +85,7 @@ This package contains the contributed examples for %{name}.
|
|||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{innerversion}
|
%setup -q -n %{name}-%{version}
|
||||||
cp %{SOURCE1} .
|
cp %{SOURCE1} .
|
||||||
%patch0 -p1 -b .build
|
%patch0 -p1 -b .build
|
||||||
%patch1 -p1 -b .loadlib
|
%patch1 -p1 -b .loadlib
|
||||||
@ -97,7 +94,6 @@ sed -i 's|@JNIPATH@|%{_libdir}/%{name}|' src/com/sun/jna/Native.java
|
|||||||
chmod -Rf a+rX,u+w,g-w,o-w .
|
chmod -Rf a+rX,u+w,g-w,o-w .
|
||||||
%patch3 -p0 -b .gcj-javadoc
|
%patch3 -p0 -b .gcj-javadoc
|
||||||
%patch4 -p1 -b .junit
|
%patch4 -p1 -b .junit
|
||||||
%patch5 -p1 -b .charfix
|
|
||||||
%patch6 -p1 -b .ffi
|
%patch6 -p1 -b .ffi
|
||||||
%patch7 -p1
|
%patch7 -p1
|
||||||
|
|
||||||
@ -212,8 +208,8 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Tue Mar 04 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 4.0.0-5
|
* Fri Mar 7 2014 Levente Farkas <lfarkas@lfarkas.org> - 4.1.0-1
|
||||||
- Use Requires: java-headless rebuild (#1067528)
|
- Update to 4.1.0
|
||||||
|
|
||||||
* Fri Jan 10 2014 Roland Grunberg <rgrunber@redhat.com> - 4.0.0-4
|
* Fri Jan 10 2014 Roland Grunberg <rgrunber@redhat.com> - 4.0.0-4
|
||||||
- fix updated depmap
|
- fix updated depmap
|
||||||
|
Loading…
Reference in New Issue
Block a user