diff --git a/import.log b/import.log
index b7653a0..a95de9d 100644
--- a/import.log
+++ b/import.log
@@ -1,2 +1,3 @@
jna-3_2_4-1_el5:HEAD:jna-3.2.4-1.el5.src.rpm:1259001126
jna-3_2_7-2_fc12:F-13:jna-3.2.7-2.fc12.src.rpm:1279835196
+jna-3_2_7-3_fc12:F-13:jna-3.2.7-3.fc12.src.rpm:1279925941
diff --git a/jna-3.2.4-build-md5.patch b/jna-3.2.4-build-md5.patch
deleted file mode 100644
index 70fcfc0..0000000
--- a/jna-3.2.4-build-md5.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- build.xml 2010-04-21 17:45:22.419903811 -0400
-+++ build.xml.orig 2010-04-21 17:45:10.204664997 -0400
-@@ -43,7 +43,7 @@
-
-
-
--
-+
-
-
-
diff --git a/jna-3.2.5-direct.patch b/jna-3.2.5-direct.patch
deleted file mode 100644
index 8534f50..0000000
--- a/jna-3.2.5-direct.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up ./native/dispatch.c.old ./native/dispatch.c
---- ./native/dispatch.c.old 2010-05-12 09:56:55.478872622 +0200
-+++ ./native/dispatch.c 2010-05-12 09:57:11.639872467 +0200
-@@ -2808,7 +2808,7 @@ Java_com_sun_jna_Native_unregister(JNIEn
- free(md);
- }
- (*env)->ReleaseLongArrayElements(env, handles, data, 0);
-- (*env)->UnregisterNatives(env, cls);
-+ //(*env)->UnregisterNatives(env, cls);
- }
-
- JNIEXPORT jlong JNICALL
diff --git a/jna-3.2.7-gcj-javadoc.patch b/jna-3.2.7-gcj-javadoc.patch
index f1ea6d6..def1c19 100644
--- a/jna-3.2.7-gcj-javadoc.patch
+++ b/jna-3.2.7-gcj-javadoc.patch
@@ -1,18 +1,18 @@
diff -up ./build.xml.gcj-javadoc ./build.xml
---- ./build.xml.gcj-javadoc 2010-07-22 11:47:35.097371333 +0200
-+++ ./build.xml 2010-07-22 11:47:56.222245622 +0200
-@@ -555,8 +555,6 @@
-
+--- ./build.xml.gcj-javadoc 2010-07-23 21:41:42.000000000 +0200
++++ ./build.xml 2010-07-23 21:43:12.161570259 +0200
+@@ -570,8 +570,6 @@
-
+
+
-
-
-
-
+
+
diff -up ./src/com/sun/jna/Function.java.gcj-javadoc ./src/com/sun/jna/Function.java
---- ./src/com/sun/jna/Function.java.gcj-javadoc 2010-07-22 11:48:33.732370892 +0200
-+++ ./src/com/sun/jna/Function.java 2010-07-22 11:49:25.324392691 +0200
+--- ./src/com/sun/jna/Function.java.gcj-javadoc 2009-10-24 17:43:53.000000000 +0200
++++ ./src/com/sun/jna/Function.java 2010-07-23 21:41:42.148570758 +0200
@@ -76,7 +76,7 @@ public class Function extends Pointer {
* Library in which to find the native function
* @param functionName
diff --git a/jna-3.2.7-javadoc.patch b/jna-3.2.7-javadoc.patch
new file mode 100644
index 0000000..cf077fa
--- /dev/null
+++ b/jna-3.2.7-javadoc.patch
@@ -0,0 +1,173 @@
+Index: jnalib/build.xml
+===================================================================
+--- jnalib/build.xml (revision 1138)
++++ jnalib/build.xml (revision 1139)
+@@ -22,6 +22,7 @@
+
+
+
++
+
+
+
+@@ -526,6 +527,14 @@
+
+
+
++
++
++
++
++
++
++
++
+
+
+
+
+@@ -551,15 +560,18 @@
+
+
+
++
++
++
++
++
+
+
+-
++
++
+
+
+
+-
+-
+-
+
+
+
+
+
+-
+
+
+
+-
++
+
+
+
+Index: jnalib/contrib/platform/src/com/sun/jna/platform/mac/package.html
+===================================================================
+--- jnalib/contrib/platform/src/com/sun/jna/platform/mac/package.html (revision 0)
++++ jnalib/contrib/platform/src/com/sun/jna/platform/mac/package.html (revision 1139)
+@@ -0,0 +1,13 @@
++
++
++
++
++
++
++
++Provides common library mappings for the OS X platform.
++
++
++
+\ No newline at end of file
+Index: jnalib/contrib/platform/src/com/sun/jna/platform/win32/package.html
+===================================================================
+--- jnalib/contrib/platform/src/com/sun/jna/platform/win32/package.html (revision 0)
++++ jnalib/contrib/platform/src/com/sun/jna/platform/win32/package.html (revision 1139)
+@@ -0,0 +1,13 @@
++
++
++
++
++
++
++
++Provides common library mappings for the Windows platform.
++
++
++
+\ No newline at end of file
+Index: jnalib/contrib/platform/src/com/sun/jna/platform/unix/package.html
+===================================================================
+--- jnalib/contrib/platform/src/com/sun/jna/platform/unix/package.html (revision 0)
++++ jnalib/contrib/platform/src/com/sun/jna/platform/unix/package.html (revision 1139)
+@@ -0,0 +1,13 @@
++
++
++
++
++
++
++
++Provides common library mappings for Unix and X11-based platforms.
++
++
++
+\ No newline at end of file
+Index: jnalib/contrib/platform/src/com/sun/jna/platform/dnd/package.html
+===================================================================
+--- jnalib/contrib/platform/src/com/sun/jna/platform/dnd/package.html (revision 0)
++++ jnalib/contrib/platform/src/com/sun/jna/platform/dnd/package.html (revision 1139)
+@@ -0,0 +1,14 @@
++
++
++
++
++
++
++
++Provides integrated, extended drag and drop functionality,
++allowing ghosted drag images to be used on all platforms.
++
++
++
+\ No newline at end of file
+Index: jnalib/contrib/platform/src/com/sun/jna/platform/package.html
+===================================================================
+--- jnalib/contrib/platform/src/com/sun/jna/platform/package.html (revision 0)
++++ jnalib/contrib/platform/src/com/sun/jna/platform/package.html (revision 1139)
+@@ -0,0 +1,13 @@
++
++
++
++
++
++
++
++Provides cross-platform utilities based on platform-specific libraries.
++
++
++
+\ No newline at end of file
diff --git a/jna.spec b/jna.spec
index 7ba3e03..d709e36 100644
--- a/jna.spec
+++ b/jna.spec
@@ -1,6 +1,6 @@
Name: jna
Version: 3.2.7
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Pure Java access to native libraries
Group: Development/Libraries
@@ -21,14 +21,11 @@ Patch1: jna-3.2.5-loadlibrary.patch
# and using a complex API like X11 through JNA just increases the potential
# for problems.
Patch2: jna-3.2.4-tests-headless.patch
-# native jar. Carve that out so we always build it.
-Patch3: jna-3.2.4-build-md5.patch
+Patch3: jna-3.2.7-javadoc.patch
# Build using GCJ javadoc
Patch4: jna-3.2.7-gcj-javadoc.patch
# junit cames from rpm
Patch5: jna-3.2.5-junit.patch
-# see: https://jna.dev.java.net/issues/show_bug.cgi?id=154
-Patch6: jna-3.2.5-direct.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# We manually require libffi because find-requires doesn't work
@@ -36,7 +33,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Requires: java >= 1:1.6.0 jpackage-utils libffi
Requires(post): jpackage-utils
Requires(postun): jpackage-utils
-BuildRequires: java-devel >= 1:1.6.0 ant jpackage-utils ant-nodeps
+BuildRequires: java-devel >= 1:1.6.0 ant jpackage-utils ant-nodeps junit4
BuildRequires: libX11-devel libXt-devel libffi-devel
# for ExcludeArch see bug: 468831
%if 0%{?rhel} < 6 && 0%{?fedora} < 10
@@ -77,10 +74,9 @@ This package contains the contributed examples for %{name}.
%setup -q -n %{name}-%{version}
sed -e 's|@JNIPATH@|%{_libdir}/%{name}|' %{PATCH1} | patch -p1
%patch2 -p1 -b .tests-headless
-#patch3 -p0 -R -b .md5
+%patch3 -p1 -b .javadoc
%patch4 -p0 -b .gcj-javadoc
%patch5 -p1 -b .junit
-#patch6 -p1 -b .direct
cp %{SOURCE1} ./
# all java binaries must be removed from the sources
@@ -99,12 +95,7 @@ chmod 0644 LICENSE.txt
%build
# We pass -Ddynlink.native which comes from our patch because
# upstream doesn't want to default to dynamic linking.
-ant -Dcflags_extra.native="%{optflags}" -Ddynlink.native=true -Dnomixedjar.native=true jar
-# dirty 64bit hack
-%ifarch x86_64
-ln -s build-d64 build
-%endif
-ant -Dcflags_extra.native="%{optflags}" -Ddynlink.native=true -Dnomixedjar.native=true javadoc
+ant -Dcflags_extra.native="%{optflags}" -Ddynlink.native=true -Dnomixedjar.native=true jar javadoc
# remove compiled contribs
find contrib -name build -delete || :
sed -i "s/VERSION/%{version}/" %{name}-pom.xml
@@ -112,10 +103,6 @@ sed -i "s/VERSION/%{version}/" %{name}-pom.xml
%install
rm -rf %{buildroot}
-# dirty 64bit hack
-%ifarch x86_64
-rm build
-%endif
# jars
install -D -m 644 build*/%{name}.jar %{buildroot}%{_javadir}/%{name}-%{version}.jar
(cd %{buildroot}%{_javadir}/; for jar in `ls *-%{version}.jar`; do ln -s $jar `echo $jar | sed -e 's/-%{version}//'`; done)
@@ -136,7 +123,7 @@ install -p -d -m 755 %{buildroot}%{_javadocdir}/%{name}-%{version}
cp -a doc/javadoc/* %{buildroot}%{_javadocdir}/%{name}-%{version}
-%if 0%{?fedora} >= 9
+%if 0%{?rhel} >= 6 || 0%{?fedora} >= 9
%check
#ant -Dcflags_extra.native="%{optflags}" -Ddynlink.native=true -Dnomixedjar.native=true test
%endif
@@ -175,6 +162,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Jul 24 2010 Levente Farkas - 3.2.7-3
+- upstream 64bit fixes
+
* Thu Jul 23 2010 Levente Farkas - 3.2.7-2
- Temporary hack for 64bit build